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Before You Begin
Before You Begin
This section provides you with safety information, technical support infor-
mation, and sources for additional product information.

Safety Information
Your safety is extremely important. Read and follow all warnings and cau-
tions in this document before handling and operating Intermec equipment. 
You can be seriously injured, and equipment and data can be damaged if 
you do not follow the safety warnings and cautions.

This section explains how to identify and understand dangers, warnings, 
cautions, and notes that are in this document.

A warning alerts you of an operating procedure, practice, condition, or 
statement that must be strictly observed to avoid death or serious injury 
to the persons working on the equipment.

A caution alerts you to an operating procedure, practice, condition, or 
statement that must be strictly observed to prevent equipment damage 
or destruction, or corruption or loss of data.

Note: Notes either provide extra information about a topic or contain spe-
cial instructions for handling a particular condition or set of circumstances.

Global Services and Support

Warranty Information
To understand the warranty for your Intermec product, visit the Intermec 
web site at www.intermec.com and click Service & Support. The Intermec 
Global Sales & Service page appears. From the Service & Support menu, 
move your pointer over Support, and then click Warranty.

Disclaimer of warranties: The sample code included in this document is 
presented for reference only. The code does not necessarily represent com-
plete, tested programs. The code is provided “as is with all faults.” All war-
ranties are expressly disclaimed, including the implied warranties of 
merchantability and fitness for a particular purpose.

Web Support
Visit the Intermec web site at www.intermec.com to download our current 
manuals in PDF format. To order printed versions of the Intermec manu-
als, contact your local Intermec representative or distributor.

Visit the Intermec technical knowledge base (Knowledge Central) at 
intermec.custhelp.com to review technical information or to request 
technical support for your Intermec product.
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Telephone Support
These services are available from Intermec Technologies Corporation.

Service Description

In the U.S.A. and Canada 
call 1-800-755-5505 and 
choose this option

Order Intermec 
products

• Place an order.
• Ask about an existing order.

1 and then choose 2

Order Intermec media Order printer labels and ribbons. 1 and then choose 1
Order spare parts Order spare parts. 1 or 2 and then choose 4
Technical Support Talk to technical support about 

your Intermec product.
2 and then choose 2

Service • Get a return authorization 
number for authorized service 
center repair.

• Request an on-site repair tech-
nician.

2 and then choose 1

Service contracts • Ask about an existing con-
tract.

• Renew a contract.
• Inquire about repair billing or 

other service invoicing ques-
tions.

1 or 2 and then choose 3

Outside the U.S.A. and Canada, contact your local Intermec representative. 
To search for your local representative, from the Intermec web site, click 
Contact.

Who Should Read This Document?
The CN2B Mobile Computer User’s Manual is written for the person who is 
responsible for installing, configuring, maintaining, and troubleshooting 
the product.

Before you install and configure your product, you should be familiar with 
your network and general networking terms, such as IP address.

Related Documents
This table contains a list of related Intermec documents and part numbers.

Document Title Part Number

CN2B Mobile Computer Quick Start Guide 962-054-053

The Intermec web site contains Intermec documents (in PDF) that you can 
download for free.

To download documents

1 Browse to www.intermec.com.
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2 Click Service & Support > Manuals.

3 In the Select a Product field, choose the product whose documentation 
you want to download.

To order printed versions of the Intermec manuals, contact your local 
Intermec representative or distributor.

Patent Information
This product is protected by one or more of the following patents:

4,455,523; 4,553,081; 4,709,202; 4,845,419; 4,961,043; 5,195,183; 5.216,233; 
5,218,187; 5,218,188; 5,227,614; 5,241,488; 5,278,487; 5,322,991; 5,331,136; 
5,331,580; 5,349,678; 5,397,885; 5,371,858; 5,373,478; 5,410,141; 5,488,575; 
5,500,516; 5,504,367; 5,508,599; 5,530,619; 5,567,925; 5,568,645; 5,592,512; 
5,598,007; 5,617,343; 5,627,360; 5,657,317; 5,671,436; 5,684,290; 5,777,309; 
5,793,604; 5,805,807; 5,818,027; 5,821,523; 5,828,052; 5,831,819; 5,834,753; 
5,841,121; 5,844,222; 5,883,492; 5,883,493; 5,886,338; 5,889,386; 5,898,162; 
5,969,328; 5,986,435; 6,075,340; 6,109,528; 6,158,661; 6,234,395; 6,244,512; 
6,330,975; 6,431,451; 6,497,368; 6,538,413; Des. 417,445.

There may be other U.S. and foreign patents pending.
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1Using the CN2B Computer

This chapter introduces the CN2B Mobile Computer, developed by Inter-
mec to enhance wireless connectivity needs. This chapter contains hard-
ware and software configuration information to assist you in making the 
most out of your CN2B Computer. 
Note: Desktop icons and applet icons are shown to the left.
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Audio System

Speaker
A speaker capable of variable volume levels is located on the back of the 
computer. This speaker has a transducer maximum volume of 85 dB at 10 
cm, a frequency range of 1 to 8KHz, and a separate volume control. 

Speaker

Warning: Do not place the speaker next to your ear when the speaker 
volume is set to “Loud” (maximum), or you may damage your hearing.

Microphone
The built-in microphone is located on the front, left corner of the keypad, 
to the left of the BkSp and B key. 

Microphone

External Headset Jack
The external headset jack connects a mobile phone style headset to your 
mobile computer for use in noisy environments. The jack is a 2.5 mm, 
three-conductor jack, with autosensing of the headset jack insertion which 
disables the internal speaker and microphone. The external headset jack is 
located on the top of the mobile computer next to the scanner. 

Headset Jack
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Battery
The CN2B Computer comes with an 7.95 Watt-hour, 3.7V, 2150mAh, 
replaceable LiIon battery. To view the status of this battery, tap Start > Set-
tings > the System tab > the Power icon > the Power tab to view the cur-
rent status of both the main battery and the backup battery. Tap ok to exit. 

If your computer shuts down because of low battery conditions, your com-
puter does not operate. This is done to ensure that data is protected. 
Although the battery does protect the data against loss for several hours, 
you should connect your computer to a power source when you first detect 
a low battery condition.

Your computer contains an internal supercapacitor, a temporary power 
storage device, that protects data for up to ten minutes. This is to give you 
time to replace the main battery pack before that data is lost. Be sure to put 
the computer in a suspend mode before doing so.
The lithium-ion battery pack that is used in this device may present a 
fire or chemical burn hazard if it is mistreated. Do not disassemble it, 
heat it above 100°C (212°F), or incinerate it.

Removing the main battery when the backup battery low or critically 
low icon appears on the status bar may cause your CN2B Computer to 
cold boot and you may lose data.

If you fail to replace the battery immediately, you may lose important 
data or applications.

If you have at least one device in your CN2B Computer (radio, scanner, or 
imager), the battery power fail level is set so that after the system shuts 
down in a low battery condition, there is still sufficient charge to allow the 
unit to remain configured, keep proper time, and maintain DRAM 
(Dynamic Random Access Memory) for at least 23 to 32 hours at room 
temperature if the main battery remains in the mobile computer. 
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The configuration and time are lost if:

• The battery discharges beyond this level.

• The battery is removed when the computer is not in suspend mode.

• A cold reset is performed on the computer.
You can modify RAM maintenance in a limited way. On the CN2B Com-
puter, tap Start > Settings > the System tab > the Power icon > the Battery 
tab. Drag the top slider bar to the left to change the suspend voltage to 
favor suspend time over rundown time, then click ok to exit. 

 

Installing and Charging the Battery
Make sure you fully charge the battery before you use your CN2B Com-
puter. To charge the battery, you need to install it in the CN2B Computer.

1 Push down on the battery door latch, pull up on and remove the battery 
door, then set it aside. 

Battery door latch

2 Align the battery contacts, then slide the battery into the compartment. 
Press on the battery until it clicks in place, then replace the battery door. 

Battery
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3 Connect the AC power supply to the power connector on the back of the 
CN2B Communications Dock, and then connect the power cord to the 
AC power supply.

You must use only the Intermec power supply approved for use with 
the CN2B Computer. Using any other power supply will damage the 
CN2B Computer.

Note: For help installing and using the communications dock, see the CN2 
Communications Dock Quick Start Guide (P/N: 930-061-001), which 
shipped with the dock. 

4 Connect the power cord to an AC power outlet. The green Power light 
on the CN2B Communications Dock turns on. 

AC power 
supply

Communications
dock

Power
light

CN2

5 Place the CN2B Computer in the communications dock. The battery is 
fully charged in approximately four hours.

Removing the Battery
Follow these instructions to remove the battery from the CN2B Computer.
Only use either the stylus or the bottom tabs on the battery door to dis-
lodge and remove the battery. Using any other tool or method to 
remove the battery may damage the battery or the CN2B Computer.

Removing the main battery when the backup battery low or critically 
low icon appears on the status bar may cause your CN2B Computer to 
cold boot and you may lose data.

If you fail to replace the battery immediately, you may lose important 
data or applications. 
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To remove the battery

1 Push down on the battery door latch, and pull up on the battery door. 

Battery door latch

2 Remove the battery door and set it aside.

3 Insert the stylus between the battery and the CN2B case, and press 
straight down until the battery is released. 

4 Lift the battery out of the battery compartment.

Maximizing Battery Life
• Set the Backlight Timeout to 10 seconds.

• Verify that Radio Power Management is enabled (Fast PSP). Enabling 
radio power management allows your radio to switch between awake and 
sleep modes based on network traffic.

• Verify that each setting under Power Management has a value of 1 
minute for a combined automatic shutoff time of 3 minutes.

Beeper
Note: Each time a cold-boot is performed on the CN2B Computer, all 
default settings are restored unless registry storage is enabled. See page 193 
for information about enabling the registry storage.

To learn how to set volume levels for screen taps, ActiveSync alert noises, 
etc., tap Start > Help > Pocket PC Basics, then select Notifications.

Enabling the Beeper
Tap Start > Settings > the Personal tab > Sounds & Notifications > the 
Volume tab, then drag the System volume slider bar away from the 
“Silent” position.
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Adjusting the Beeper Volume
Tap or drag the System volume slider bar to your most comfortable level.

Disabling the Beeper
Drag the System volume slider bar completely to the left to the “Silent” 
position, then tap ok to exit this applet. 

Intermec Settings Applet
Use the Intermec Settings applet to gather, view, and update device config-
uration settings. Information about the settings you can configure with the 
Intermec Settings applet is in the Intermec Computer Command Reference 
Manual (P/N: 073529) available online at www.intermec.com.

See the Data Collection Resource Kit in the Intermec Developer Library 
(IDL) for information about data collection functions. The IDL is available 
as a download from the Intermec web site at www.intermec.com/idl. Con-
tact your Intermec representative for more information. 
Tap Start > Settings > the System tab > the Intermec Settings icon to 
access the applet. 
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Key Sequences

[Orange] Plane Keys
The orange plane key provides you access to display controls, special char-
acters, and Pocket PC options.

Press the orange key for each orange plane key stroke you wish to make. 
For example to turn on the front light, press and hold the orange key plus 
the [3] key. To turn the front light off, press the appropriate keys again. 
Below and on the next page are the key sequences.

This table lists sequences that use the orange plane key. See Chapter 2, 
“Windows Mobile 2003” to learn about the Pocket PC applications.

Press the Keys To Do This

orange [3] Toggles the backlight (also goes through backlight power levels if 
this key is held down)

orange [.] Access the Pocket PC Record application (see Note).

orange [4] Access the Pocket PC Calendar application (see Note).

orange [5] Access the Pocket PC Contacts application (see Note).

orange [6] Access the Pocket PC Tasks application (see Note).

orange [7] Move up one page.

orange [8] Enter an asterisk (*).

orange [9] Move down one page.

orange [0] Access the Pocket PC Start menu.

orange [ENTER] Enter an at symbol (@).

orange [BkSp] Enter a backslash (/).

orange [Esc] Enter a minus sign (–).

orange [Action] Enter a plus sign (+).

orange [ ] Tab to the right.

orange [ ] Tab to the left.

Pocket PC applications are accessible only if configured to do so via Utilitiese > App Launch.

Alpha (Green) Plane Keys
You can enter the alphabet using the Alpha (green) plane keys. Below and 
on the next page are the key sequences.

When you press [Alpha], the Scanning/Alpha LED shows red for the 
Alpha mode. The keypad stays in Alpha mode until you press [Alpha] 
again.
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To type a lowercase “c,” press [Alpha] [2] [2] [2]. To type a letter on the 
same key as the last letter entered, wait two seconds, then enter the correct 
series of keystrokes to create the next letter.

While in the Alpha mode and you press [1] to initiate the CAPS mode, you 
will render a CAPS LOCK until you press [1] again. Once you are in CAPS 
mode, you stay in CAPS until it is pressed again. Press [0] to enter a space.

To Enter Press the Keys To Enter Press the Keys

a [Alpha] [2] A [Alpha] [1] [2]

b [Alpha] [2] [2] B [Alpha] [1] [2] [2]

c [Alpha] [2] [2] [2] C [Alpha] [1] [2] [2] [2]

d [Alpha] [3] D [Alpha] [1] [3]

e [Alpha] [3] [3] E [Alpha] [1] [3] [3]

f [Alpha] [3] [3] [3] F [Alpha] [1] [3] [3] [3]

g [Alpha] [4] G [Alpha] [1] [4]

h [Alpha] [4] [4] H [Alpha] [1] [4] [4]

i [Alpha] [4] [4] [4] I [Alpha] [1] [4] [4] [4]

j [Alpha] [5] J [Alpha] [1] [5]

k [Alpha] [5] [5] K [Alpha] [1] [5] [5]

l [Alpha] [5] [5] [5] L [Alpha] [1] [5] [5] [5]

m [Alpha] [6] M [Alpha] [1] [6]

n [Alpha] [6] [6] N [Alpha] [1] [6] [6]

o [Alpha] [6] [6] [6] O [Alpha] [1] [6] [6] [6]

p [Alpha] [7] P [Alpha] [1] [7]

q [Alpha] [7] [7] Q [Alpha] [1] [7] [7]

r [Alpha] [7] [7] [7] R [Alpha] [1] [7] [7] [7]

s [Alpha] [7] [7] [7] [7] S [Alpha] [1] [7] [7] [7] [7]

t [Alpha] [8] T [Alpha] [1] [8]

u [Alpha] [8] [8] U [Alpha] [1] [8] [8]

v [Alpha] [8] [8] [8] V [Alpha] [1] [8] [8] [8]

w [Alpha] [9] W [Alpha] [1] [9]

x [Alpha] [9] [9] X [Alpha] [1] [9] [9]

y [Alpha] [9] [9] [9] Y [Alpha] [1] [9] [9] [9]

z [Alpha] [9] [9] [9] [9] Z [Alpha] [1] [9] [9] [9] [9]
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LEDs
The battery status LED and the scanning/keypad shift and notification 
LED turn red, green, or yellow.

Battery Status LED

LED Color and Action Description

Steady Green Battery is more than 95% charged and the CN2B Computer is on charger.

Blinking Red Battery is less than 10% charged and the CN2B Computer is not on charger.

Red The CN2B Computer is on charge.

Yellow The CN2B Computer is on a charging source and there is no battery pack installed. The 
mobile computer may also be out of the charging range of 32° to 104° F (0° to 40° C). 
When back in range, charging resumes and the LED changes to red or green.

Scanning/Keypad Shift and Notification LED

LED Color and Action Description

Momentary Green Indicates the scanner has initialized and had a good scan.

Steady Red Indicates the keypad is shifted to the Alpha plane and the CN2B Computer is turned on.

PSM Build Version
The Persistent Storage Manager (PSM) is an area of storage which is 
embedded in a section of the system’s FLASH memory. This storage area is 
not erased when a cold-boot is performed. It may, however, erase during the 
reflashing process. In addition to storing applications and data files, you do 
have the option to store a persistent registry to the PSM region.
To determine what PSM Build is on your CN2B Computer, tap Start > 
Programs > File Explorer. Access the Flash File Store folder from the My 
Device root directory, then tap the PSMinfo text file. Tap ok to exit. 
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Resetting Your CN2B Computer

Performing a Warm-Boot
Performing a warm-boot may be necessary to correct conditions where an 
application stops responding to the system. It does, however, unload all 
running programs.

Press and hold the I/O key for ten seconds, then the CN2B Computer con-
tinues from the screen you were at before you performed the warm-boot.

Performing a Cold-Boot
In some cases where the CN2B Computer completely stops responding, it 
may be necessary to perform a cold-boot. Because this may result in data 
loss, this procedure is not recommended unless all other recovery methods 
have failed.
Note: This deletes all programs and data stored in RAM including the 
Object Store. Make sure data is backed up to your host computer or a stor-
age card before performing a cold-boot.

1 Pull the stylus from its place in the back of the CN2B Computer. 
Pull the stylus out

2 Using the stylus, press the reset button in the stylus holder. 

Press to reset
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Software Build Version
To check to see if your CN2B Computer has the latest software build, 
select Start > Internet Explorer > the Intermec logo.

The latest software build version is displayed beneath the Version Informa-
tion title. This information is useful should you need assistance. 

Software Tools
The following Intermec software tools are available as free downloads:

SmartSystems Foundation Console (www.intermec.com/SmartSystems)
This tool includes a management console that provides a default method to 
configure and manage Intermec devices “out-of-the-box,” without the pur-
chase of additional software licenses. This is for anyone who must configure 
and deploy multiple devices or manage multiple licenses.

Intermec Resource Kits (www.intermec.com/IDL)
Resource Kits provide tools that build applications using the features of 
Intermec devices.  Resource kits include: Bluetooth, Communications, 
Data Collection, Device Settings, Mobile Gadgets, Printing, and RFID.

This is for anyone who develops software for the CN2B Computer.
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Storage Media
Note: MultiMediaCards (MMCs) and CompactFlash (CF) storage cards 
are not supported in CN2B Computers.

Note: The CN2B Computer currently supports Delkin Devices Secure 
Digital cards only. Intermec cannot guarantee that other SD cards will 
work with the CN2B Computer.

The CN2B Computer supports the Secure Digital storage card. The Com-
pactFlash card slot is embedded in the CN2B Computer and cannot be 
removed. 

The following procedures explain how to:

• insert an SD card.

• access the files on an SD card.

• remove an SD card. 

For help using a Secure Digital card to install applications and files, see 
“Using a Secure Digital Card to Upgrade the CN2B Computer” on 
page 81.

To insert the SD card

1 Before inserting the Secure Digital card, you must attach one of the 
pull-tabs that ships with the CN2B Computer. A Secure Digial card 
without a pull-tab can be very difficult to remove.  

SD card

Pull-tab

2 Align the Secure Digital card as shown in the next illustration, and insert 
the Secure Digital card into the slot.  

SD card

Pull-tab
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3 Push the card into the slot until it is fully inserted. 
Fully inserted
SD card

4 Align the battery contacts as shown in the next illustration, and insert the 
battery in the battery compartment. Press down on the battery until it 
clicks into place. 

Battery

5 Install the battery door.

To access files stored on the Secure Digital card
If you have a Secure Digital card inserted in your CN2B Computer, it 
appears as the “\Storage Card” folder. To access this folder, select My 
Device, then tap the “\Storage Card” folder. You can copy files to and from 
this folder just as you would any other folder on the CN2B Computer.  

To remove the Secure Digital card

1 Press and hold the Power key for two to three seconds, and then release 
the Power key to turn off the CN2B Computer.

2 Place the CN2B Computer face-down on a clean, flat, stable surface.

3 Push down on the battery door latch, and pull up on the battery door. 

4 Remove the battery door and set it aside.
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5 Insert the stylus between the battery and the CN2B case, and press 
straight down until the battery is released.  

6 Remove the battery and set it aside.

7 Pull the tab toward the bottom on the CN2B Computer to remove the 
Secure Digital card. 

rd

Tab

Wireless Network Support
Radios are installed at the factory and cannot be installed by a user. The 
CN2B Computer must be serviced to install or replace radios. Contact your 
Intermec representative for more information. See Chapter 4, “Network 
Support” for information about supported radios.
Note: Changes or modifications not expressly approved by Intermec could 
void the user’s authority to operate the equipment.
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Accessories
The following accessories are available for the CN2B Computer. Note that 
this is not a complete list. Contact your Intermec representative for informa-
tion about these and other accessories that are not in this list.

AC Wall Adaptor

Battery

Car Charger

Handstrap

Holster

Modem Dock

Replacement Stylus Kit - tethered stylus

Screen Cleaner Kit

Screen Protector Kit - 3 pack

Single USB Client Dock

Two-Wire Phone Cord

Universal Power Supply

USB Type B Interface Cable

Physical and Environmental Specifications
Use these specifications to locate technical information about the CN2B 
Computer and its available features and options.

Display
Transflective: TFT all-light readable color display with LED backlight 
Pixels: 240x320 
Diagonal: 89 mm (3.52 in) 
Colors: 65 K

Environmental
Operating Temperature: -10° to 50°C (14° to 122°F) 
Storage Temperature: -20° to 60°C (-4° to 140°F) 
Relative Humidity: 5% to 95% noncondensing 
Rain and Dust Resistance: IP54 compliant 
Drop Specifications: 0.9 m (3 ft) drop, 26 times on concrete

Secure Digital Expansion Slots
The CN2B Computer supports the Delkin Devices Secure Digital storage 
card.
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Integrated Scanner Options
EV10 Linear Imager

Integrated Wireless
802.11b/g (Wi-Fi® certified): WLAN (802.11b/g) 
Bluetooth™ compatible module

Keypad Options
Numeric

Memory and Storage
RAM Memory: 64 MB 
Flash ROM: 64 MB, includes ROM folder for application storage

Microprocessor
Intel® XScale™ PXA255 Application Processor, 400 MHz

Operating System
Microsoft® Windows® Mobile software for Pocket PC

Physical Dimensions
Length: 147 mm (5.8 in) 
Width: 86 mm (3.4 in) 
Height: 35 mm (1.4 in) 
Weight: 370 g (11.9 oz)

Power
Battery Type: Lithium-Ion (LiIon), 3.7V, (1x2150 mAh cells),  

customer-replaceable 
Battery Capacity: 7.95 Watt-hours 
Battery Life: 6-10 hours, application dependent 
Recharging Time: 4 hours 
Charging Range: 0° to 40°C (32° to 104°F)

Regulator Approvals
FCC Part 15 Class B; UL Listing; CE Mark; CB Report

Standard Communications
RS232; USB
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2Windows Mobile 2003

This chapter introduces Microsoft Windows Mobile 2003 for Pocket PC. 
While using your CN2B Computer, keep these key points in mind:

• Tap Start on the navigation bar, located at the top of the screen, to 
quickly move to programs, files, and settings. Use the command bar at 
the bottom of the screen to perform tasks in programs. The command 
bar includes menus, icons, and the onscreen keyboard.

• Tap and hold an item to see a pop-up menu containing a list of actions 
you can perform. Pop-up menus give you quick and easy access to the 
most common actions.

Below is a list of Windows Mobile 2003 components described in this 
chapter. Tap Start > Help on your CN2B Computer to find additional 
information on Windows Mobile components.

Microsoft ActiveSync  (page 34)

Microsoft Pocket Outlook  (page 35)

Pocket Word  (page 57)

Pocket Excel  (page 60)

MSN Messenger  (page 62)

Windows Media Player for Windows Mobile  (page 65)

Microsoft Reader  (page 66)

Pocket Internet Explorer  (page 68)
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Software Builds
Go to “Software Build Version” on page 12 to determine which Intermec 
build of Windows Mobile 2003 is on your unit.

Where to Find Information
This chapter describes your CN2B Computer hardware, provides an over-
view of the programs on your CN2B Computer, and explains how to con-
nect your CN2B Computer to a desktop, a network, or the Internet. For 
instructions on setting up your CN2B Computer and installing Active-
Sync, see the Quick Start Guide. The following is a guide to more informa-
tion to assist you use your CN2B Computer.

For Information: See this Source:

Programs on the mobile computer. This chapter and mobile computer Help. To view Help, tap Start > Help.

Additional programs that can be 
installed on the mobile computer.

The Windows Mobile Companion CD.

Connecting to and synchronizing 
with a desktop.

The Quick Start Guide or ActiveSync Help on your desktop. To view Help, 
click Help > Microsoft ActiveSync Help.

Last-minute updates and detailed 
technical information.

The Read Me files, located in the Microsoft ActiveSync folder on the desktop 
and on the Windows Mobile Companion CD.

Up-to-date information on your 
Windows Mobile.

www.microsoft.com/windowsmobile/resources/communities/default.mspx

Windows Mobile and many of the technologies supported by the CN2B 
Computer are not from Intermec. Many of the utilities and features on a 
Windows Mobile device come directly from Microsoft without any modifi-
cation from Intermec. There may be certain Microsoft-specific issues that 
Intermec would not be able to support, so contact our front-line support 
personnel to determine the best source of assistance.

Use these URLs for additional information about Microsoft Windows 
Mobile (Pocket PC):

• msdn.microsoft.com/support/

• support.microsoft.com/

• news://news.microsoft.com (a free support option)
20 CN2B Mobile Computer User’s Manual

http://www.microsoft.com/windowsmobile/resources/communities/default.mspx
http://msdn.microsoft.com/support/
http://support.microsoft.com/
news://news.microsoft.com


Chapter 2 —  Windows Mobile 2003
Basic Skills
Learning to use your CN2B Computer is easy. This section describes the 
basic concepts of using and customizing your CN2B Computer.

Today Screen
When you turn on your CN2B Computer for the first time each day (or 
after four hours of inactivity), you see the Today screen. You can also display 
it by tapping the Start flag (shown left) and then Today. On the Today 
screen, you can see important information for the day. 

Tap to start a program Tap and hold to change the time format

Tap to change date and time

Tap to change owner information

Your day at a glance. Tap to open the associated program

To customize what is displayed on the Today screen, including the back-
ground image, tap Start > Settings > the Personal tab > Today.

Status icons display information such as low batteries or when the CN2B 
Computer is connected to a desktop or to the Internet. You can tap an icon 
to open the associated setting or program.

Programs
You can switch from one program to another by selecting it from the Start 
menu. (You can customize which programs you see on this menu. For 
information, see “Adjusting Settings” on page 31.) To access some pro-
grams, tap Start > Programs, and then the program name.

You can also switch to some programs by pressing a program icon. Your 
CN2B Computer has one or more program icons located on the front or 
side of the computer. The icons on the icons identify the programs to 
which they switch.
Note: Some programs have abbreviated labels for check boxes and drop-
down menus. To see the full spelling of an abbreviated label, tap and hold 
the stylus on the label. Drag the stylus off the label so that the command is 
not carried out.
CN2B Mobile Computer User’s Manual 21



Chapter 2 — Windows Mobile 2003
The following is a partial list of programs that are on your CN2B Com-
puter. Look on the Windows Mobile Companion CD for additional pro-
grams that you can install onto your CN2B Computer.

Synchronize information between your CN2B Computer and desktop.

Keep track of your appointments and create meeting requests.

Keep track of your friends and colleagues.

Send and receive e-mail messages.

Browse Web and WAP (Wireless Application Protocol) sites, and down-
load new programs and files from the Internet.

Create handwritten or typed notes, drawings, and recordings.

Keep track of your tasks.

Play digital audio and video files that are stored on your CN2B Computer 
or on a network.

Navigation Bar and Command Bar
The navigation bar is located at the top of the screen. It displays the active 
program and current time, switches to programs, and closes screens. 

Tap to switch to a program that you recently used.

Tap to switch to a program.

Tap to see more programs.

Tap to change device settings.

Tap to see a Help topic for the current screen.

Use the command bar at the bottom of the screen to perform tasks in pro-
grams. The command bar includes menu names, icons, and the Input 
Panel icon. To create a new item in the current program, tap New. To see 
the name of an icon, tap and hold the stylus on the icon. Drag the stylus off 
the icon so that the command is not carried out. 

Tap to select menu commands.
Tap to select icon commands.

Tap to display the input panel.
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Pop-up Menus
Use pop-up menus to quickly perform an action on an item. For example, 
you can use a pop-up menu to delete or make a copy of an item. To access 
a pop-up menu, tap and hold the item on which you want to perform the 
action. When the menu appears, tap the action to perform, or tap anywhere 
outside the menu to close the menu without performing the action. 

Tap and hold to display the pop-up menu

Lift the stylus and tap the action you want

Tap outside the menu to close it without performing
 an action

Notifications
When you have something to do, your device notifies you in a variety of 
ways. For example, if you have set up an appointment in Calendar, an e-
mail message arrives, or a friend sends you an instant message, you are noti-
fied in any of the following ways:

• A message box appears on the screen.

• A sound, which you can specify, is played.

• A light flashes on your CN2B Computer.

You can choose the notification types.

Entering Information
You can enter information on your CN2B Computer in several ways, 
depending on the type of device you have and the program you are using:

• Synchronizing 
Using Microsoft ActiveSync, synchronize or copy information between 
your desktop and CN2B Computer. For more information on Active-
Sync, see ActiveSync Help on your desktop.

• Typing 
Using the input panel, enter typed text into the CN2B Computer either 
by tapping keys on the onscreen keyboard or using handwriting recogni-
tion software.

• Writing 
Using the stylus, write directly on the screen.
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• Drawing 
Using the stylus, draw directly on the screen.

• Recording 
Create a stand-alone recording or embed a recording into a document or 
note.

Use the input panel to enter information in any program on your CN2B 
Computer. You can either type using the onscreen keyboard or write using 
Block Recognizer, Letter Recognizer, or Transcriber. In either case, the 
characters appear as typed text on the screen.
To show or hide the input panel, tap the Input Panel icon. Tap the arrow 
next to the Input Panel icon to see your choices. 

Select an input method

Tap to see your choices

When you use the input panel, your CN2B Computer anticipates the word 
you are typing or writing and displays it above the input panel. When you 
tap the displayed word, it is inserted into your text at the insertion point. 
The more you use your CN2B Computer, the more words it anticipates. 

Tap a text box to display the currently selected input

Tap to insert the anticipated word

Tap keys on the onscreen keyboard to enter characters 

Typing With the Onscreen Keyboard
Tap the input panel arrow, then tap Keyboard. On the soft keyboard that is 
displayed, tap the keys with your stylus.

• To type lowercase letters, tap the keys with the stylus.

• To type a single uppercase letter or symbol, tap the Shift key. To tap 
multiple uppercase letters or symbols, tap the CAP key.

• To convert a letter to uppercase, tap and hold the stylus on the letter and 
drag up.

• To add a space, drag the stylus to the right across at least two keys.

• To backspace a character, drag the stylus to the left over at least two keys.
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• To insert a carriage return, tap and hold the stylus anywhere on the key-
board and drag down. 

To use larger keys, tap the input panel arrow, tap Options, select “Key-
board” from the Input method drop-down list, then select Large keys. 

Using Block Recognizer
Character recognition software gives you a fast and easy method for enter-
ing information in any program on your CN2B Computer. Letters, num-
bers, and punctuation you write are translated into typed text.
Tap the input panel arrow, then tap Block Recognizer. Write a letter in the 
box, which then is converted to typed text that appears on the screen.

For specific instructions on using Block Recognizer, with Block Recognizer 
open, tap the question mark next to the writing area. 

Tap for assistance

Using Letter Recognizer
With Letter Recognizer, you can write letters using the stylus just as you 
would on paper.
Tap the input panel arrow, then tap Letter Recognizer. Write a letter in the 
box. When you write a letter, it is converted to typed text that appears on 
the screen. For specific instructions on using Letter Recognizer, with Letter 
Recognizer open, tap the question mark next to the writing area. 

Tap for assistance
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Using Transcriber
With Transcriber, you can write anywhere on the screen using the stylus 
just as you would on paper. Unlike Letter Recognizer and Block Recog-
nizer, you can write a sentence, then pause and let Transcriber change the 
written characters to typed characters.
Tap the input panel arrow, then tap Transcriber. Tap ok, then write any-
where on the screen. 

For specific instructions on using Transcriber, with Transcriber open, tap 
the question mark in the lower, right-hand corner of the screen. 

Tap for assistance

Selecting Typed Text
To edit or format typed text, you must select it first. Drag the stylus across 
the text you want to select. You can cut, copy, and paste text by tapping 
and holding the selected words and then tapping an editing command on 
the pop-up menu, or by tapping the command on the Edit menu.

Writing on the Screen
In any program that accepts writing, such as the Notes program, and in the 
Notes tab in Calendar, Contacts, and Tasks, you can use your stylus to 
write directly on the screen. Write the way you do on paper. You can edit 
and format what you have written and convert the information to text at a 
later time.

• Tap the Pen icon to switch to writing mode. This action displays lines 
on the screen to help you write. 

Tap to use your stylus like a pen

Note: Some programs that accept writing may not have the Pen icon. See 
related documentation to find out how to switch to writing mode.

Selecting the Writing
If you want to edit or format writing, you must select it first.
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1 Tap and hold the stylus next to the text you want to select until the 
insertion point appears.

2 Without lifting, drag the stylus across the text you want to select.

If you accidentally write on the screen, tap Tools > Undo and try again. 
You can also select text by tapping the Pen icon to deselect it and then 
dragging the stylus across the screen.

You can cut, copy, and paste written text in the same way you work with 
typed text: tap and hold the selected words and then tap an editing com-
mand on the pop-up menu, or tap the command on the Edit menu.

Converting Writing to Text
You can convert words you write in print or cursive to text by tapping 
Tools > Recognize. If a word is not recognized, it keeps its original form.

To convert only certain words, tap Pen to disable the writing function, tap 
twice over the word or phrase to highlight, then tap Tools > Recognize.

Select the text to convert, then tap Recognize 
on the pop-up menu

The writing is turned to text

If the conversion is incorrect, you can choose different words from a list of 
alternates or return to the original writing. To do so, tap and hold the 
incorrect word (tap one word at a time). On the pop-up menu, tap Alter-
nates. Tap the word use from the menu with a list of alternate words, or tap 
the writing at the top of the menu to return to the original writing. 

Tap to return to your original writing

Or tap the word you want to use
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Tips for getting good recognition:

• Write neatly.

• Write on the lines and draw descenders below the line. Write the cross of 
the “t” and apostrophes below the top line so they are not confused with 
the word above. Write periods and commas above the baseline.

• For better recognition, increase the zoom level to 300% by using the 
Tools menu. Recognition does not work well below a 150% zoom level.

• Write the letters of a word closely and leave big gaps between words so 
the CN2B Computer can easily tell where words begin and end.

• Hyphenated words, foreign words that use special characters such as 
accents, and some punctuation cannot be converted.

• If you add writing to a word to change it (such as changing a “3” to an 
“8”) after you attempt to recognize the word, the writing you add is not 
included if you attempt to recognize the writing again.

Drawing on the Screen
You can draw on the screen in the same way that you write on the screen. 
The difference between writing and drawing on the screen is how you select 
items and how they are edited. For example, you can resize selected draw-
ings, while you cannot resize writing.

Creating a Drawing
• After your first stroke, wait for a drawing box to appear around the area 

you marked. Subsequent strokes in or touching the drawing box become 
part of the drawing. Drawings that do not cross the borders of the box 
are considered writing. 

The drawing box indicates the boundary

Note: You may want to change the zoom level so that you can more easily 
work on or view your drawing. Tap Tools and then a zoom level.
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Selecting a Drawing
To edit or format a drawing, select it first. Tap and hold the stylus on the 
drawing until the selection handle appears. To select multiple drawings, 
deselect the Pen icon and then drag to select the drawings you want.

You can cut, copy, and paste selected drawings by tapping and holding the 
selected drawing and then tapping an editing command on the pop-up 
menu, or by tapping the command on the Edit menu. To resize a drawing, 
make sure the Pen icon is not selected, and drag a selection handle.

Recording a Message
In any program where you can write or draw on the screen, you can also 
capture thoughts, reminders, and phone numbers by recording a message. 

In the Inbox program, you can add a recording to an e-mail message. In 
Calendar, Tasks, and Contacts, you can include a recording in the Notes 
tab. In the Notes program, you can create a stand-alone recording or add a 
recording to an open note.

Creating a Recording
1 Hold the CN2B Computer microphone near your mouth or source of 

sound. Tap the red recording button and make your recording.

2 Tap the black stop recording button when finished. If you are recording 
in an open note, an icon appears in the note. If you are creating a stand-
alone recording, it appears in the note list.

3 To play a recording, tap the recording icon in the open note or tap the 
recording in the note list.

Note: To quickly create a recording, hold down the Record hardware icon. 
When you hear the beep, begin your recording. Release the icon when you 
are finished. The new recording is stored in the open note or as a stand-
alone recording if no note is open.

Playing a Recording
To play a recording, tap it in the list or tap its icon in the note. 

Indicates an embedded recording

Tap to show or hide the recording toolbar
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Using My Text
When using Inbox or MSN Messenger, use My Text to quickly insert pre-
set or frequently used messages into the text entry area. To insert a message, 
tap My Text and tap a message.

• To quickly add common messages, tap My Text, then tap a message.

• To edit a My Text message, tap Tools > Edit My Text Messages. Tap 
the message to edit and enter new text at the bottom of the screen. 

Tap to select a prewritten message

Finding and Organizing Information
The Find feature on your CN2B Computer helps you quickly locate infor-
mation. Tap Start > Find. Enter the text you want to find, select a data 
type, and then tap Go to initiate the search.
Note: To quickly find information that is taking up storage space on your 
CN2B Computer, select Larger than 64 KB in Type.

You can also use the File Explorer to find files on your CN2B Computer 
and to organize these files into folders. Tap Start > Programs > File 
Explorer. 

Tap the folder name to open it

Tap New Folder to create a new folder

Note: You can move files in File Explorer by tapping and holding the item 
to move, and then tapping Cut or Copy and Paste on the pop-up menu.
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Customizing Your CN2B Computer
You can customize your CN2B Computer by adjusting settings and install-
ing additional software.

Adjusting Settings
You can adjust settings to suit the way you work. To see available options, 
tap Start > Settings > either the Personal tab or the System tab located at 
the bottom of the screen. You might want to adjust the following: 

Personal tab System tab

Menus To customize what appears on the Start menu, and to enable a 
pop-up menu from the New icon.

Owner Information To enter your contact information.

Password To limit access to your CN2B Computer.

Today To customize the look and information displayed on the Today 
screen.

Clock To change the time or to set alarms.

Power To maximize battery life.

Adding or Removing Programs
Programs added to your CN2B Computer at the factory are stored in 
ROM (Read Only Memory). You cannot remove this software, and you 
cannot accidentally lose ROM contents. ROM programs can be updated 
using special installation programs with a *.XIP extension. All other pro-
grams and data files added to your CN2B Computer after factory installa-
tion are stored in RAM (Random Access Memory).

Install any program created for your CN2B Computer, as long as there is 
enough memory. The most popular place to find software for your CN2B 
Computer is on the Windows Mobile Web site (www.microsoft.com/win-
dowsmobile/resources/communities/default.mspx).
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Adding Programs Using ActiveSync
Install the appropriate software for your CN2B Computer on your desktop 
before installing it on your CN2B Computer.
1 Determine your CN2B Computer and processor type so that you know 

which version of the software to install. Tap Start > Settings > the Sys-
tem tab > About > the Version tab, then make a note of the information 
in Processor. 

2 Download the program to your desktop (or insert the CD or disk that 
contains the program). You may see a single *.XIP, *.EXE, or *.ZIP file, 
a SETUP.EXE file, or several versions of files for different CN2B Com-
puter types and processors. Be sure to select the program designed for the 
Windows Mobile and your CN2B Computer processor type.

3 Read any installation instructions, Read Me files, or documentation.

4 Connect your CN2B Computer and desktop.

5 Double-click the *.EXE file.

• If the file is an installer, the installation wizard begins. Follow the 
directions on the screen. Once the software is installed, the installer 
automatically transfers the software to your CN2B Computer.

• If the file is not an installer, an error message stating that the program 
is valid but it is designed for a different type of computer is displayed. 
Move this file to your CN2B Computer. If you cannot find any instal-
lation instructions for the program in the Read Me file or documenta-
tion, use ActiveSync Explore to copy the program file to the Program 
Files folder on your CN2B Computer. For more information on 
copying files using ActiveSync, see ActiveSync Help.

Once installation is complete, tap Start > Programs, and then the program 
icon to switch to it.
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Adding a Program Directly from the Internet
1 Determine your CN2B Computer and processor type so that you know 

which version of the software to install. Tap Start > Settings > the Sys-
tem tab > About > the Version tab, then make a note of the information 
in Processor.

2 Download the program to your CN2B Computer straight from the 
Internet using Pocket Internet Explorer. You may see a single *.XIP, 
*.EXE, or *.ZIP file, a SETUP.EXE file, or several versions of files for 
different CN2B Computer types and processors. Be sure to select the 
program designed for the Windows Mobile and your CN2B Computer 
processor type.

3 Read program installation instructions, Read Me files, or other docu-
mentation. Many programs provide installation instructions.

4 Tap the file, such as a *.XIP or *.EXE file to start the installation wizard. 
Follow the directions on the screen.

Adding a Program to the Start Menu
Tap Start > Settings > Menus > the Start Menu tab, and then the check 
box for the program. If you do not see the program listed, you can either 
use File Explorer on the CN2B Computer to move the program to the 
Start Menu folder, or use ActiveSync on the desktop to create a shortcut to 
the program and place the shortcut in the Start Menu folder.

Using File Explorer on the CN2B Computer

Tap Start > Programs > File Explorer, and locate the program (tap the 
folder list, labeled My Documents by default, and then My Device to see a 
list of all folders on the CN2B Computer). Tap and hold the program and 
tap Cut on the pop-up menu. Open the Start Menu folder located in the 
Windows folder, tap and hold a blank area of the window, and tap Paste on 
the pop-up menu. The program now appears on the Start menu. For more 
information on using File Explorer, see “Finding and Organizing Informa-
tion” on page 30.

Using ActiveSync on the desktop 
Use the Explorer in ActiveSync to explore your CN2B Computer files and 
locate the program. Right-click the program, and then click Create Short-
cut. Move the shortcut to the Start Menu folder in the Windows folder. 
The shortcut now appears on the Start menu. For more information, see 
ActiveSync Help.

Removing Programs
Tap Start > Settings > the System tab > Remove Programs.

If the program does not appear in the list of installed programs, use File 
Explorer on your CN2B Computer to locate the program, tap and hold the 
program, and then tap Delete on the pop-up menu.
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Microsoft ActiveSync
Visit the following Microsoft Web site for the latest in updates, technical 
information, and samples:

www.microsoft.com/windowsmobile/resources/communities/
default.mspx

Using Microsoft ActiveSync, you can synchronize the information on your 
desktop with the information on your CN2B Computer. Synchronization 
compares the data on your CN2B Computer with your desktop and 
updates both computers with the most recent information. For example:

• Keep Pocket Outlook data up-to-date by synchronizing your CN2B 
Computer with Microsoft Outlook data on your desktop.

• Synchronize Microsoft Word and Microsoft Excel files between your 
CN2B Computer and desktop. Your files are automatically converted to 
the correct format.

Note: By default, ActiveSync does not automatically synchronize all types 
of information. Use ActiveSync options to turn synchronization on and off 
for specific information types.

With ActiveSync, you can also:

• Back up and restore your CN2B Computer data.

• Copy (rather than synchronize) files between your CN2B Computer and 
desktop.

• Control when synchronization occurs by selecting a synchronization 
mode. For example, you can synchronize continually while connected to 
your desktop or only when you choose the synchronize command.

• Select which information types are synchronized and control how much 
data is synchronized. For example, you can choose how many weeks of 
past appointments you want synchronized.

Before you begin synchronization, install ActiveSync on your desktop from 
the Windows Mobile Companion CD. For more information on installing 
ActiveSync, see your Quick Start card. ActiveSync is already installed on 
your CN2B Computer.

After installation is complete, the ActiveSync Setup Wizard helps you con-
nect your CN2B Computer to your desktop, set up a partnership so you 
can synchronize information between your CN2B Computer and your 
desktop, and customize your synchronization settings. Your first synchroni-
zation process automatically begins when finished using the wizard.

After your first synchronization, look at Calendar, Contacts, and Tasks on 
your CN2B Computer. Notice that information you have stored in 
Microsoft Outlook on your desktop was copied to your CN2B Computer, 
and you did not have to type a word. Disconnect the CN2B Computer 
from your computer and you are ready to go!
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Once you have set up ActiveSync and completed the first synchronization 
process, you can initiate synchronization from your CN2B Computer. To 
switch to ActiveSync on your CN2B Computer, tap Start > ActiveSync. 
Note that if you have a wireless LAN card, you can synchronize remotely 
from your CN2B Computer.

For information about using ActiveSync on your desktop, start ActiveSync 
on your desktop, and then see ActiveSync Help. 

View connection status

Tap to connect and synchronize

Tap to stop synchronization

View synchronization status

For more information about ActiveSync on your CN2B Computer, switch 
to ActiveSync, then tap Start > Help.

Microsoft Pocket Outlook
Microsoft Pocket Outlook includes Calendar, Contacts, Tasks, Inbox, and 
Notes. You can use these programs individually or together. For example, 
you can use e-mail addresses stored in Contacts to address e-mail messages 
in Inbox.

Using ActiveSync, you can synchronize information in Microsoft Outlook 
or Microsoft Exchange on your desktop with your CN2B Computer. You 
can also synchronize this information directly with a Microsoft Exchange 
server. Each time you synchronize, ActiveSync compares the changes you 
made on your CN2B Computer and desktop or server and updates both 
computers with the latest information. For information on using Active-
Sync, see ActiveSync Help on the desktop.

You can switch to any program by tapping it on the Start menu.

Calendar: Scheduling Appointments and Meetings

To switch to Calendar on the CN2B Computer, tap Start > Calendar.

Use Calendar to schedule appointments, including meetings and other 
events. You can check your appointments in one of several views (Day, 
Week, Month, Year, and Agenda) and set Calendar to remind you of 
appointments with a sound or other method. Appointments for the day can 
display on the Today screen.
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If you use Outlook on your desktop, you can synchronize appointments 
between your device and desktop. 

Tap to go to Today

Tap to display or edit the appointment details

Synchronizing Calendar
Calendar items stored on your device can be synchronized with calendar 
items on your desktop or Microsoft Exchange Server. (Note you can only 
synchronize information directly with an Exchange Server if your company 
is running Microsoft Mobile Information Server 2002 or later.) Calendar 
synchronization is automatically selected in ActiveSync.

Calendar items entered on one computer are copied to the other during 
synchronization. Handwritten notes and drawings are saved as metafiles 
(pictures). For information on synchronization, see ActiveSync Help on the 
desktop.

Why Use Categories in the Calendar?
Use categories to group related tasks, contacts, and appointments. Then, 
use these groupings to quickly display only the information you want. For 
example, you can share your device with another by assigning appoint-
ments to a category with a special project’s name. You can then use this cat-
egory to filter Calendar and only display appointments for that project.
Note: In Month View, the day of an appointment assigned to the Holiday 
category appears in red. 

This day was assigned the Holiday category
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What’s an All Day Event?
An appointment can either be a normal appointment or an all day event, 
which lasts the full day or spans many days. Examples include a trade show, 
a vacation, or a seminar. You can also use all day events to schedule an 
annual event, such as a birthday or anniversary. In this case, change the Sta-
tus box to Free (you may need to scroll to see it) so that it does not show 
time as busy in your calendar. All day events do not occupy blocks of time 
in Calendar; they appear in banners at the top of the calendar.
Note: You cannot modify or create all-day events with attendees on the 
device. If you create all-day events with attendees on your desktop, use 
ActiveSync to copy such events to the device. Then, view them in Calendar. 
For more information on copying files, see ActiveSync Help. To use the 
device to schedule an appointment with attendees lasting all day, set type to 
“Normal,” then adjust the date and time appropriately. 

This describes the all-day event

What’s a Recurrence Pattern?
If you have an appointment or task that you do on a regular basis, such as a 
weekly team meeting or a monthly status report, enter the item once and 
set a recurrence pattern for it. If the default patterns in the list are not what 
you need, you can create your own pattern using the wizard. 

Select your recurrence pattern from this drop-down list

Select <Edit pattern...> to access the wizard to 
customize a recurrence
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Viewing Appointments
You can view appointments in one of several views (Agenda, Day, Week, 
and Month). In Agenda view, upcoming appointments are displayed in 
bold. To see detailed appointment information in any view, tap the 
appointment. To see a list of available actions for an appointment, tap and 
hold the appointment. Tap Start > Today to quickly see your appoint-
ments for the day. 

This displays the appointment in bold

Month view displays symbols to indicate the types of appointments you 
have on a given day. An upward triangle indicates a morning appointment; 
a downward triangle indicates an afternoon appointment. If you have 
appointments in the morning and afternoon, a solid square is displayed. If 
you have an all-day event not marked Free, a hollow square is displayed. 

This displays a morning appointment

This displays appointments both morning and afternoon

This displays an afternoon appointment

This displays an all-day event not marked Free

Creating or Changing an Appointment
To create an appointment, tap New. To select a new date from a pop-up 
calendar, tap the display date. To enter or select a new time, tap the display 
time. Enter the appointment details, and when finished, tap OK to return 
to the calendar.

If you are working in Day view, tap the time slot for the new appointment 
and then tap New to have the time automatically entered for you.
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To change an appointment, tap it in the calendar, then tap Edit. Change 
any appointment detail by tapping it and entering the new information.
Note: Tap the arrows to the right of the description and location boxes to 
choose from previous entries.

When entering a time, you can type military and abbreviated time forms, 
such as 2300 (becomes 11:00 PM), 913pm (becomes 9:13 PM), 911 
(becomes 9:11 AM), and 9p (becomes 9:00 PM). 

Tap to return to the calendar (appointment is saved
automatically)

Tap to choose from predefined text

Tap to choose from previously entered locations

Tap to choose a date and time

Use Notes to record information

Creating an All Day Event
To create an all day event, do the following:

1 Tap New.

2 Tap All Day, then select Yes. 

Tap to select whether this is an all-day event

Note: To change an all-day event, switch to Day or Agenda view, tap the 
event listed at the top of the calendar, then tap Edit. Change any appoint-
ment detail by tapping it and entering the new information.

You cannot modify or create all day events with attendees on the CN2B 
Computer. If you create all day events with attendees on your desktop, use 
ActiveSync to copy such events to the CN2B Computer. Then, view them 
in Calendar. For more information on copying files, see ActiveSync Help. 
To use the device to schedule an appointment with attendees lasting all 
day, set type to Normal, then adjust date and time accordingly.
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Setting a Reminder for an Appointment
Do the following to set a reminder for an appointment in the calendar:

1 Tap the appointment, then tap Edit to change the appointment.

2 Tap Reminder and select Remind me.

3 To change how many minutes before the appointment you are 
reminded, tap the minutes displayed, then select the new minutes from a 
drop-down or enter the new minutes. Tap minutes to change hours, 
days, or weeks. 

Tap whether to enable the reminder feature

Note: To automatically set a reminder for all new appointments, in the cal-
endar, tap Tools > Options, select Set reminders for new items, then tap 
the number and timeframe options to change the information given. 

Tap this to set reminders for new appointments 

To choose how you are reminded, for example by a sound, tap Start > Set-
tings > the Personal tab > the Sounds & Notifications icon.

Adding a Note to an Appointment
You can add written or typed notes and even recordings (if your device sup-
ports recordings) to an appointment. This is a good place for maps, draw-
ings, and other detailed information.

1 In the calendar, tap the appointment, then tap Edit.
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2 Tap the Notes tab to enter notes. For specific instructions, tap Start > 
Help > Notes to see Notes Help. 

Controls for the recorder

Use the stylus to write or draw information here

Tap to activate recorder
Tap to activate writing pad

Tap to activate onscreen keyboard

Note: To edit an existing note, tap the appointment in the calendar, tap 
Edit, then tap the Notes tab.

Making an Appointment Recurring
Do the following to make a recurring appointment:

1 In the calendar, tap the appointment, then tap Edit.

2 Tap Occurs and select a pattern from the list. Or, to create a new pat-
tern, tap <Edit pattern...>, and follow the steps in the wizard. 

Select your recurrence pattern from this list

Select <Edit pattern...> to access the wizard with
which to customize your recurrence

Assigning an Appointment to a Category
1 In the calendar, tap the appointment, then tap Edit.

2 Tap Categories.

3 On the Select tab, select the categories to which you want to assign the 
appointment.

4 To create a new category, tap the Add/Delete tab, enter the category 
name, then tap Add. The new category is automatically selected in the 
Select tab.
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5 Tap ok to return to the appointment. 

A check mark indicates a selected category

Note: To find an appointment assigned to a category, tap Tools > Catego-
ries and select the type of appointment that you want displayed. To show 
all appointments again, tap Tools > Categories and clear all categories.

Sending a Meeting Request
Use Calendar to schedule meetings with people who use Outlook or Pocket 
Outlook. When attendees receive a meeting request, they can accept or 
decline the meeting. If accepted, the meeting is added to their schedule, 
their response is sent back to you, and your calendar is updated.

Before sending a meeting request, enter e-mail addresses in Contacts Help 
and set up Inbox to send and receive messages. For more information on 
sending and receiving meeting requests, tap Start > Help > Calendar to see 
Calendar Help, and tap Start > Help > Inbox to see Inbox Help.

1 Tap New, then enter the meeting information.

2 Hide the onscreen keyboard, if needed, then tap Attendees. Only those 
contacts with e-mail addresses are displayed. Select the contacts you want 
to invite, then tap ok to return to the appointment.

3 Select other desired options and then tap ok.

4 Inbox automatically creates a meeting request and sends it to the attend-
ees the next time you synchronize with your desktop. Textual notes 
entered in the Notes tab (excluding writing or recordings) are sent also. 

A check mark indicates a selected attendee
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Note: If you are sending the meeting request through a connection to an 
ISP or the network, rather than through synchronization with your desk-
top, tap Tools > Options. From the Send meeting requests via drop-down 
list, tap the service to use to send the meeting request.

Finding an Appointment
There are two ways to find an appointment:

• Tap Start > Find, enter the appointment name, tap the Type arrow and 
select Calendar from the drop-down list, and then tap Go.

• In the calendar, tap Tools > Categories and select the type of appoint-
ment you want displayed. To show all appointments again, tap Tools > 
Categories and clear all categories. 

Enter a phrase or tap the list for existing phrases

Tap for a list of areas where to search this phrase

Tap these to see details

Note: In Find, you can tap the Find arrow to select from a list of items of 
previously searched items or phrases.

Deleting an Appointment
1 In the calendar, tap and hold the appointment.

2 On the pop-up menu, tap Delete Appointment. The next time you syn-
chronize, the appointment is also deleted from the desktop.

Changing Calendar Options
In the calendar, tap Tools > Options.

• To see appointment indicators, select icons to display in Show icons. 
You can choose to display indicators for such things as recurring 
appointments, appointments with notes, and appointments with 
reminders. Tap and hold an icon to see its name.
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• If you are having trouble reading the calendar, select Use large font. You 
may see less appointment information. 

Tap this to view larger text

The Show icons consist of:
Reminder, Recurs, Note, Location, Attendees, Private

Contacts: Tracking Friends and Colleagues

To switch to Contacts on the CN2B Computer, tap Start > Contacts.

Contacts maintains a list of your friends and colleagues so that you can eas-
ily find the information you are looking for, whether you are at home or on 
the road. You can enter both personal and business information.

If you use Microsoft Outlook on your desktop, you can synchronize con-
tacts between your CN2B Computer and your desktop. 

Select the category of contacts you want displayed

Tap and enter part of a name to quickly find it

Tap to see additional phone #s and email addresses

Tap to display or edit contact details

Tap and hold to display a pop-up menu

Tap to toggle between Name and Company views

Creating a Contact
1 Tap New, then use the input panel to enter a name and other contact 

information. Scroll down to see all available fields.

2 To assign the contact to a category, scroll to and tap Categories, then 
select a category from the list, which can display contacts by category.
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3 To add notes, tap the Notes tab. You can enter text, draw, or create a 
recording. For more information on creating notes, see “Notes: Captur-
ing Thoughts and Ideas” on page 52.

4 When finished, tap OK to return to the contact list. 

Scroll to see more fields

Use Notes to store additional information

Synchronizing Contacts
Contacts stored on your device can be synchronized with Outlook contacts 
stored on your desktop or with Mobile Information Server 2002 or later.

New items entered in a location are copied to another during synchroniza-
tion. Handwritten notes and drawings are saved as pictures when synchro-
nizing with the desktop, but are removed when synchronizing with a server.

For information on synchronization, see ActiveSync Help on the desktop.

Viewing Contacts
The contact list displays the contact name and the first primary phone 
number or e-mail address specified for that contact. Contacts are ordered 
by name of contact or company.

• Tap the default letter (home, w ork, mobile, or e-mail) to the right of the 
contact to see additional phone numbers and e-mail addresses.

• Use your up/down controls on your keypad to select a contact, then 
press the left/right controls on your keypad to change the default num-
ber, displayed as a letter to the right of the contact name.

• To see more contact information, tap the contact.

• To see a list of available actions for a contact via a pop-up menu, tap and 
hold the contact.

• To see a list of contacts employed by a specific company, tap View > By 
Company. Then, tap the desired company name.
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Note: You can change the appearance of the contact list by tapping Tools > 
Options. 

Indicates the default

Tap for phone #s, email addresses

Creating or Changing a Contact
• To create a contact, tap New. To enter notes, tap the Notes tab. When 

finished, tap ok to return to the contact list.

• To change a contact, tap it in the contact list, and then tap Edit. To can-
cel edits, tap Edit > Undo. When finished making changes, tap ok to 
return to the contact list.

Note: If you enter a name with more than two words, the middle word is 
recorded as a middle name. If your contact has a double first or last name, 
tap the Name arrow and enter the names in the proper boxes. 

Tap anywhere outside the box to return to details

Note: New contacts are added to the displayed category.

Adding a Note to a Contact
You can add written or typed notes and even recordings (if your device sup-
ports recordings) to a contact. Notes are handy for maps and drawings.

1 In the contact list, tap the contact.
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2 Tap the Notes tab. For specific instructions, tap Start > Help > Notes to 
see Notes Help. 

Controls for the recorder

Use the stylus to write or draw your information here

Tap to activate the recorder

Tap to activate the writing pad

Tap to activate the keyboard

Note: To edit an existing note, tap the contact, tap Edit, then tap the 
Notes tab.

Assigning a Contact to a Category
1 In the contact list, tap the contact, and then tap Edit.

2 Scroll to and tap Categories.

3 On the Select tab, check the categories to assign to the contact.

4 To create a new category, tap the Add/Delete tab, enter the category 
name, then tap Add. The new category is automatically checked in the 
Select tab.

5 Tap ok to return to the contacts. 

A check mark indicates a selected category

Copying a Contact
1 In the contact list, select the contact. For multiple contacts, tap and drag.

2 Tap Tools, and then select Copy Contacts.
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Sending a Message to a Contact
1 In the contact list, tap and hold the contact. To select multiple contacts, 

tap and drag. Then, tap and hold the selected contacts.

2 On the pop-up menu, select Send Email or Send SMS, depending upon 
the type of message to send. 

Note: To send an e-mail message, use an e-mail address configured for the 
contact. To send an SMS (Short Messaging Service) message, use an SMS 
number for the contact, which is usually the mobile phone number.

Finding a Contact
• Tap Start > Find, enter the contact name (first, last, or middle), phone 

number, or address, select Contacts for the type, then tap Go.

• From Contacts, start typing a contact name until you see it displayed on 
the screen. To show all contacts again, tap the text box at the top of the 
screen and clear the text, or tap the arrow to the right of the text box.

• In the contact list, tap the category list (labeled All Contacts by default) 
and tap the category to which you have assigned a contact. To show all 
contacts again, select All Contacts.

• To view the names of companies for which your contacts work, in the 
contact list, tap View > By Company. The number of contacts that work 
for that company is displayed to the right of the company name.
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Note: To quickly move through the contacts, tap a set of letters at the top. 
This takes you to the contact names beginning with those letters. 

Enter the first few letters of the contact in question here

Tap to jump to that portion of the contacts list

Deleting a Contact
1 In the contact list, tap and hold the contact. To select multiple contacts, 

tap and drag. Then, tap and hold the selected contacts.

2 On the pop-up menu, tap Delete Contact. The next time you synchro-
nize, the contact is deleted from the desktop also.

Adding a Contact to Speed Dial
You can create speed dials to call frequently-called numbers with a single 
tap. Before you can create a speed dial entry for a phone number, that num-
ber must already exist in Contacts.

1 From the Phone keypad, tap Speed Dial > New.

2 Tap the desired contact name and number.

3 In the Location field, tap the Up/Down arrows to select an available 
location to assign as the new speed dial entry. The first speed dial loca-
tion is reserved for your voice mail.

To delete a speed dial entry, go to the Speed Dial list, tap and hold the con-
tact name in the box to the right of the assigned speed dial number, then 
tap Delete.

Changing Contacts Options
In the contact list, tap Tools > Options.

• The area code and country/region for new contacts are automatically 
entered based on the information in Country/Region settings.

• If you are having trouble reading the contacts in the contact list, select 
Use large font.

• To increase the available space for displaying contacts in the list, clear 
Show ABC tabs.
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Clear this to view more contacts per screen

Enter the three-digit area code

Select from a drop-down list

Tasks: Keeping a To Do List

To switch to Tasks on your CN2B Computer, tap Start > Tasks.

Use Tasks to keep track of what you have to do. A variety of task informa-
tion can display on the Today screen. If you use Microsoft Outlook on 
your desktop, you can synchronize tasks between your device and desktop. 

Select the type of tasks to display

Select the list sort order
Assign tasks quickly here

Indicates high priority
Tap to display or edit

Tap, hold for a pop-up menu

Indicates low priority

Note: To change the way information is displayed in the list, tap Tools > 
Options.

Creating a Task
• To create a task, enter text in the Tap here to add a new task box at the 

top of the screen. If you do not see this box, tap Tools > Entry Bar.

• To create a task with detailed information, such as start and due dates, 
tap New. To enter notes, tap the Notes tab. 

You can enter a start date and due date or enter other information by 
first tapping the field. If the input panel is open, you need to hide it to 
see all available fields.
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You can enter text, draw, or create a recording. For more information on 
creating notes, see “Notes: Capturing Thoughts and Ideas” on page 52.

• To change a task, tap it in the task list, and then tap Edit.

• Using the onscreen keyboard, enter a description.

• To assign the task to a category, tap Categories and select a category 
from the list. In the task list, you can display tasks by category.

• When finished, tap ok to return to the task list. 
Tap to choose from predefined subjects

Use Notes to store additional information

Note: To create a task with only a subject, tap Entry Bar on the Tools 
menu. Then, tap Tap here to add a new task and enter the information.

Synchronizing Tasks
Tasks stored on your CN2B Computer can synchronize with Microsoft 
Outlook on your desktop. Task synchronization is automatically selected in 
ActiveSync.

New items entered on one computer are copied to the other during syn-
chronization. Handwritten notes and drawings are saved as metafiles (pic-
tures). For more information on synchronization, see ActiveSync Help on 
the desktop.
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Notes: Capturing Thoughts and Ideas

To switch to Notes on your CN2B Computer, tap Start > Notes.

Notes helps you quickly capture your ideas, notes, and thoughts. You can 
create a note using written and typed text, drawings, and recordings. You 
can also share your notes with others through e-mail, infrared, and synchro-
nization with your desktop. 

Tap to change the sort order of the list

Tap to open a note or play a recording

Tap and hold to display a pop-up menu

Tap to record

Tap to access the Recording toolbar

Note: To create documents with advanced formatting or templates, such as 
bulleted lists and tabs, use word processing software developed for your 
device, such as Pocket Word.

Creating a Note
To create your note, tap New, then write, draw, type, or record your infor-
mation. For information about using the input panel, writing and drawing, 
and creating recordings, see “Basic Skills” on page 21.

• Writing 
Using the stylus, write directly on the screen.

• Drawing 
Using the stylus, draw directly on the screen.

• Typing 
Using the input panel, enter typed text into the CN2B Computer. Do 
this by tapping keys on the onscreen keyboard or by using handwriting 
recognition software.

• Recording 
Create a stand-alone recording or embed a recording into a note.

Synchronizing Notes
Notes can be synchronized between your desktop and device either through 
notes synchronization or file synchronization. Notes synchronization syn-
chronizes the notes on the CN2B Computer with Outlook Notes on the 
desktop. File synchronization does all notes on the CN2B Computer with 
the My Documents folder for the CN2B Computer on the desktop.
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To synchronize notes through synchronization, first select the Notes infor-
mation type for synchronization in ActiveSync. The next time you synchro-
nize, all notes in My Documents and its subfolder on your device appear in 
Outlook Notes on your desktop. Notes that contain only text appear as reg-
ular notes in Outlook on your desktop, while notes containing written text 
or drawings appear in the device format. In addition, all notes in the Notes 
group in Outlook on the desktop appear in Notes on the device.

To synchronize your notes as files, in ActiveSync, select the Files informa-
tion type for synchronization and clear the Notes information type. When 
you select Files, the My Documents folder for the CN2B Computer is cre-
ated on your desktop. All .PWI files placed in the My Documents folder on 
your device and all .DOC files placed in the My Documents folder for the 
CN2B Computer on your desktop are synchronized. Password-protected 
files cannot be synchronized.

ActiveSync converts documents during synchronization. For information 
on synchronization or file conversion, see ActiveSync Help on the desktop.
Note: When you delete or change an item on either your desktop or CN2B 
Computer, the item is changed or deleted in the other location the next 
time you synchronize.

Note: If you synchronize your notes using file synchronization and then 
later decide to use notes synchronization, all of your notes are synchronized 
with Outlook on your desktop and no longer store in the My Documents 
folder for the CN2B Computer.

Inbox: Sending and Receiving E-mail Messages

To switch to Inbox on your CN2B Computer, tap Start > Inbox.

You can receive Internet e-mail messages and SMS messages in Inbox. 
Internet e-mail messages are sent by using an address you receive from your 
Internet service provider (ISP) or your employer. SMS messages are sent 
and received through your wireless phone service provider by using a phone 
number as the message address.

You can send and receive e-mail by synchronizing with your desktop, or by 
connecting to a Post Office Protocol 3 (POP3) or Internet Message Access 
Protocol 4 (IMAP4) mail server. You need to set up an e-mail account for 
each method that you use except for Microsoft ActiveSync, which is set up 
by default. The ActiveSync folder on your CN2B Computer stores mes-
sages that you send and receive through synchronization with a desktop. 
Account names appear as folders in the folder list (located on the left, under 
the navigation bar) in the Inbox message list.

With synchronization, messages are synchronized between the device Inbox 
and the PC Inbox by using ActiveSync and Microsoft Exchange or 
Microsoft Outlook. For more information, see “Synchronizing E-mail 
Messages” on page 54.
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Synchronizing E-mail Messages
After selecting Inbox for synchronization in ActiveSync, e-mail messages 
are synchronized as part of the general synchronization process. During 
synchronization:

• Messages are copied from the Inbox folder on your desktop or the 
Microsoft Exchange server to the Inbox folder on your CN2B Com-
puter. (Note that you can only synchronize information directly with an 
Exchange Server if your company is running Microsoft Mobile Informa-
tion Server 2002 or later.) By default, you receive messages from the last 
three days only, the first 100 lines of each new message, and file attach-
ments of less than 100 KB in size.

• Messages in the Outbox folder on your device are transferred to 
Exchange or Outlook and then sent from those programs.

• The messages on the two computers are linked. When you delete a mes-
sage on your CN2B Computer, it is deleted from your desktop the next 
time you synchronize.

• Messages in subfolders in other e-mail folders in Outlook are synchro-
nized only if they were selected for synchronization in ActiveSync.

For information on initiating Inbox synchronization or changing synchro-
nization settings, see ActiveSync Help on your desktop or select Start > Help 
> Connections to see Connections Help.

Managing E-mail Messages and Folders
Each e-mail account and SMS account has its own folder hierarchy with 
five default folders: Inbox, Outbox, Deleted Items, Drafts, and Sent Items. 
The messages you receive and send through the mail account are stored in 
these folders. You can also create additional folders within each hierarchy. 
The Deleted Items folder contains messages that were deleted on the 
device. The behavior of the Deleted Items and Sent Items folders depends 
on the Inbox options you have chosen.

The behavior of the folders you create depends on whether you are using 
ActiveSync, SMS, POP3, or IMAP4.

• If you use ActiveSync,  
e-mail messages in the Inbox folder in Outlook automatically synchro-
nize with your device. You can select to synchronize additional folders by 
designating them for ActiveSync. The folders you create and the mes-
sages you move are then mirrored on the server. For example, if you 
move two messages from the Inbox folder to a folder named Family, and 
you have designated Family for synchronization, the server creates a copy 
of the Family folder and copies the messages into that folder. You can 
then read the messages while away from your desktop.

• If you use SMS,  
messages are stored in the Inbox folder.
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• If you use POP3 
and you move e-mail messages to a folder you created, the link is broken 
between the messages on the device and their copies on the mail server. 
The next time you connect, the mail server sees that the messages are 
missing from the device Inbox and deletes them from the server. This 
prevents you from having duplicate copies of a message, but it also 
means that you no longer have access to messages that you move to fold-
ers created from anywhere except the CN2B Computer.

• If you use IMAP4, 
the folders created and the e-mail messages moved are mirrored on the 
server. Thus, messages are available to you anytime you connect to your 
mail server, whether it is from your CN2B Computer or desktop. This 
synchronization of folders occurs whenever you connect to your mail 
server, create new folders, or rename or delete folders when connected.

For all accounts except ActiveSync, you can access folder options by tap-
ping Tools > Manage Folders.

Connecting to a Mail Server
In addition to synchronizing e-mail messages with your desktop, you can 
send and receive e-mail messages by connecting to an e-mail server using a 
network card connected to your CN2B Computer. You need to set up a 
remote connection to a network or an ISP, and a connection to your e-mail 
server. For more information, see “Remote Access (Modems)” on 
page 100.

When you connect to the e-mail server, new messages are downloaded to 
the CN2B Computer Inbox folder, messages in the CN2B Computer Out-
box folder are sent, and messages that were deleted on the e-mail server are 
removed from the CN2B Computer Inbox folder.

Messages that you receive directly from an e-mail server are linked to your 
e-mail server rather than your desktop. When you delete a message on your 
CN2B Computer, it is also deleted from the e-mail server the next time you 
connect based on the settings selected in ActiveSync.

You can work online or offline. When working online, you read and 
respond to messages while connected to the e-mail server. Messages are sent 
as soon as you tap Send, which saves space on your CN2B Computer.

When working offline, once you have downloaded new message headers or 
partial messages, you can disconnect from the e-mail server and then decide 
which messages to download completely. The next time you connect, 
Inbox downloads the complete messages you have marked for retrieval and 
sends the messages you have composed.

Setting Up or Changing an Account
• To set up a POP3 or IMAP4 e-mail account, tap Accounts > New 

Account. Follow the instructions in the New Account Wizard.

• To set up an SMS account, tap Accounts > Accounts, and then tap 
SMS. Follow the instructions on the screen.
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To change options for an account, tap Accounts > Accounts, then tap the 
name of the account, and follow the instructions on the screen.

To delete an account, tap Accounts > Accounts, tap and hold the name of 
the account, then tap Delete.
Note: You can set up several e-mail accounts including your ActiveSync 
account, but you can set up, but not delete, only one SMS account.  
You cannot add a new account while connected. Tap Accounts > Discon-
nect to disconnect.

Downloading Messages from the Server
In Inbox, tap Accounts > Connect to open a connection to the Internet or 
your corporate network, depending on the account. For more information, 
tap Start > Help > Connections to see Connections Help.

1 Tap Accounts and ensure that the account you want to use is selected 
(marked by a bullet.)

2 Tap Connect. The messages on your CN2B Computer and e-mail server 
are synchronized: new messages are downloaded to the CN2B Inbox 
folder, messages in the CN2B Outbox folder are sent, and messages that 
were deleted from the server are removed from the CN2B Inbox. Tap a 
message in the message list to open it.

3 If you read a message and decide that you need the full copy, tap Edit > 
Mark for Download while in the message window. If you are in the mes-
sage list, tap and hold the message, and then tap Mark for Download. 
This also downloads message attachments if you selected those options 
when you set up the e-mail account. You can also choose to download 
full copies of messages by default.

4 When finished, tap Accounts > Disconnect.
Note: Receiving entire messages consumes storage memory.

Note: The size column in the message list displays the local size and server 
size of a message. Even when a message has downloaded fully, these num-
bers may differ because the size of a message can vary between the server 
and the device.

Composing and Sending Messages
1 In the message list, tap New.

2 To select an account, tap the From list and select “ActiveSync,” “SMS,” 
or the desired e-mail account.

3 Enter the e-mail address or SMS address of one or more recipients, sepa-
rating them with semicolons. To access addresses and phone numbers 
from Contacts, tap To.

4 Enter your message. To quickly add common messages, tap My Text 
and tap a desired message.
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5 To check spelling, tap Edit > Spell Check.

6 Tap Send. If you are working offline, the message is moved to the Out-
box folder and is sent the next time you connect. 

Tap to toggle header

Tap to access Recording toolbar

Tap to display the address book

Tap My Text to include prewritten messages

Note: If you are sending an SMS message and want to know if it was 
received, before sending the message, tap Edit > Options > Request SMS 
text message delivery notification.

You can directly call the sender of an SMS message by tapping the SMS 
icon, then selecting Call.

Note: Depending on the e-mail address options that you select, you can use 
a directory service in addition to your contact list to verify names.

Companion Programs
The companion programs consist of Microsoft Pocket Word, Microsoft 
Pocket Excel, Windows Media Player, and Microsoft Reader. To switch to 
a companion program on your CN2B Computer, tap Start > Programs.

Pocket Word
Pocket Word works with Microsoft Word on your desktop to give you 
access to copies of your documents. You can create new documents on your 
CN2B Computer, or you can copy documents from your desktop to your 
CN2B Computer. Synchronize documents between your desktop and your 
CN2B Computer to have up-to-date content in both locations.

Creating a Document
Use Pocket Word to create documents, letters, meeting minutes, etc. To 
create a new file, tap Start > Programs > Pocket Word > New for either a 
blank document or a template, depending on what you have selected under 
Tools > Options. Select an input mode from the View menu.
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You can open only one document at a time; when you open a second docu-
ment, you have to save the first. You can save a document you create or edit 
in formats such as Word (.DOC), Pocket Word (.PSW), Rich Text Format 
(.RTF), and Plain Text (.TXT).

Pocket Word contains a list of files stored on your CN2B Computer. Tap a 
file in the list to open it. To delete, make copies of, and send files, tap and 
hold a file in the list, then, select the action on the pop-up menu. 

Tap to change the sort order

Tap to open a document

Tap and hold an item to see a pop-up menu

You can enter information in Pocket Word in one of four modes (typing, 
writing, recording, and drawing), which are displayed on the View menu. 
Each mode has its own toolbar, which you can show and hide by tapping 
the Show/Hide Toolbar icon on the command bar.

You can change the zoom magnification by tapping View > Zoom, then 
select the percentage you want. Select a higher percentage to enter text and 
a lower one to see more of your document.

If you are opening a Word document created on a desktop, you may select 
View > Wrap to Window so that you can see the entire document.

To check spelling, select text, then tap Tools > Spell Check. To use your 
new document as a template, move the document to the Templates folder.

You can insert the data in a document. First, make sure that no drawings 
are selected, tap and hold anywhere on the document, then tap Insert Date 
from the pop-up menu.

Typing Mode
Using the input panel, enter typed text into the document. For more infor-
mation on entering typed text, see “Basic Skills” on page 21.

To format existing text and to edit text, first select the text. You can select 
text as you do in a Word document, using your stylus instead of the mouse 
to drag through the text you want to select. You can search a document to 
find text by tapping Edit > Find/Replace.
58 CN2B Mobile Computer User’s Manual



Chapter 2 —  Windows Mobile 2003
Tap and hold to see a pop-up menu

Tap to return to 
the list

Tap to change
format options

Tap to format text

Tap to toggle the toolbar

Writing Mode
In writing mode, use your stylus to write directly on the screen. Ruled lines 
are displayed as a guide, and the zoom magnification is greater than in typ-
ing mode to allow you to write more easily. For more information on writ-
ing and selecting writing, see “Basic Skills” on page 21. 

With Space icon selected, drag to insert space.
 An arrow appears showing the space direction and size

Tap to highlight the selected text

Pen icon
Space icon

Tap to select formatting options, such as pen weight

Note: If you cross three ruled lines in a single stylus stroke, the writing 
becomes a drawing, and can be edited and manipulated as described in 
“Drawing Mode” on page 60.

Note: Written words are converted to graphids (metafiles) when a Pocket 
Word document is converted to a Word document on your desktop.

Recording Mode
In recording mode, embed a recording into your document. Recordings are 
saved as .WAV files. For more information on recording, see “Basic Skills” 
on page 21.

For more information on using Pocket Word, tap Start > Help > Pocket 
Word to see Pocket Word Help.
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Drawing Mode
In drawing mode, use your stylus to draw on the screen. Grid lines appear 
as a guide. When you lift your stylus off the screen after the first stroke, a 
drawing box indicating the boundaries of the drawing appears. Every subse-
quent stroke within or touching the drawing box becomes part of the draw-
ing. For more information on drawing and selecting drawings, see “Basic 
Skills” on page 21. 

Resize an object by dragging the selection handles

Tap to select formatting options, such as fill color

Tap to see choices

Pen icon

Synchronizing Pocket Word Documents
Pocket Word documents can be synchronized with Word documents on 
your desktop. To synchronize files, first select the Files information type for 
synchronization in ActiveSync. When you select Files, the My Documents 
folder for the CN2B Computer is created on your desktop. Place all files 
you want to synchronize with the device in this folder. Password-protected 
files cannot be synchronized.

All Pocket Word files stored in My Documents and its subfolders are syn-
chronized with the desktop. ActiveSync converts documents during syn-
chronization. 

For more information on synchronization or file conversion, see ActiveSync 
Help on the desktop.
Note: When you delete a file on either your desktop or your CN2B Com-
puter, the file is deleted in the other location the next time you synchronize.

Pocket Excel
You can create and edit workbooks and templates in Microsoft Pocket 
Excel as you do in Microsoft Excel on your desktop. Pocket Excel work-
books are usually saved as .PXL files, and also in .XLS format.

When you close a workbook, it is automatically named and placed in the 
Pocket Excel workbook list. You can attach a password to a workbook to 
help ensure privacy.
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Creating a Workbook
Use Pocket Excel to create workbooks, such as expense reports and mileage 
logs. To create a new file, tap Start > Programs > Pocket Excel > New. A 
blank workbook appears. Or, if you have selected a template for new work-
books in the Tools > Options dialog, that template appears with appropri-
ate text and formatting already provided. You can open only one workbook 
at a time; when you open a second workbook, save the first. You can save a 
workbook you create or edit in a variety of formats, including Pocket Excel 
(.PXL) and Excel (.XLS). You can also save a workbook as a template by 
moving the workbook to the Templates folder.

Pocket Excel contains a list of the files stored on your CN2B Computer. 
Tap a file in the list to open it. To delete, make copies of, and send files, tap 
and hold a file in the list. Then select the appropriate action from the pop-
up menu.

Pocket Excel provides fundamental spreadsheet tools, such as formulas, 
functions, sorting, and filtering. Tap View > Toolbar to see the toolbar. 

Cell contents appear here as you tab through them

Tap to zoom

Tap to enter a formula

Note: If your workbook contains sensitive information, you can protect it 
with a password. To do so, open the workbook, tap Edit > Password. 
Every time you open the workbook, enter a password, preferably one that is 
easy for you to remember but hard for others to guess.

Tips for Working in Pocket Excel
Note the following when working in large worksheets in Pocket Excel:

• View in full-screen mode to see as much of your worksheet as possible. 
Tap View > Full Screen. To exit full-screen mode, tap Restore.

• Tap View > Zoom and select a percentage so that you can easily read the 
worksheet.

• Show and hide window elements. Tap View and then tap the elements 
you want to show or hide.

• Freeze panes on a worksheet to keep certain rows and columns visible as 
you work. Select the cells, then tap View > Freeze Panes to freeze them. 
Tap View > Unfreeze Panes to undo this process.
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• Split panes to view different areas of a large worksheet. Tap View > Split. 
Then drag the split bar to where you want it. To remove the split, tap 
View > Remove Split.

• Show and hide rows. To hide a row, select a cell in the row you want to 
hide. Then tap Format > Row > Hide. To show a hidden row, tap Tools 
> Go To, and then type a reference that is in the hidden row. Then tap 
Format > Row > Unhide.

• Do the same to show and hide columns. To hide a column, select a cell 
in the column you want to hide. Then tap Format > Column > Hide. 
To show a hidden column, tap Tools > Go To, and then type a reference 
that is in the hidden column. Then tap Format > Column > Unhide.

For more information on using Pocket Excel, tap Start > Help > Pocket 
Excel to see Pocket Excel Help.

MSN Messenger
MSN Messenger on your CN2B Computer provides the same chat envi-
ronment as MSN Messenger on your desktop. These features include: 

• Seeing who is online

• Sending and receiving instant messages

• Having an instant message conversation with a group of contacts

• Telling contacts that you are unavailable

• Blocking contacts from seeing your status or sending you messages

To use MSN Messenger, you need a Microsoft Passport account, or a 
Microsoft Exchange e-mail account that your employer provides. Once you 
have one of these accounts, do the following:

1 Set up a connection on your CN2B Computer, such as a wireless con-
nection, that enables you to connect to the Internet.

2 Set up an account in MSN Messenger.

3 Sign in to MSN Messenger.
Note: To set up a free Hotmail account, go to www.hotmail.com. 
To set up a Microsoft Passport account, go to www.passport.com. 
To set up an Exchange account, see your network administrator.

For more information on using MSN Messenger, tap Start > Help > MSN 
Messenger to see MSN Messenger Help.
To switch to MSN Messenger, tap Start > Programs > MSN Messenger.

Setting Up an Account
Before you can use MSN Messenger, you must set up the instant messaging 
accounts to use. For MSN Messenger Service, you must have a Microsoft 
Passport or Hotmail account. For Exchange Instant Messaging, you must 
have an Exchange account.
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1 Create a connection for your device. To use MSN Messenger Service, set 
up a connection to the Internet; to use Exchange Instant Messaging, set 
up a connection to your corporate network. See “Remote Access 
(Modems)” on page 100 for more information on getting connected.

2 In MSN Messenger, tap Tools > Options > the Accounts tab.

3 Select either Enable MSN Messenger Service, or Enable Exchange 
Instant Messaging, or both.

4 Enter your sign-in name and password for the selected accounts. Your 
sign-in name is usually in the username@domain.com form.

5 If you selected both accounts, under Sign in using this account first, 
select which account to sign in to first. 

Signing In and Out
• To sign in, tap anywhere on the screen and follow the directions.

• To sign out, tap Tools > Sign Out.

• To sign in upon connecting, tap Tools > Options > General and select 
the Run this program upon connection box.

• Signing in to an Exchange account may take several minutes depending 
upon your connection speed. Reducing the number of Exchange con-
tacts decreases your sign-in time.
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Working with Contacts
The MSN Messenger window shows all of your messenger contacts at a 
glance, divided into Online and Not Online categories. From this view, 
while connected, you can chat, send e-mail, block the contact from chat-
ting with you, or delete contacts from your list using the pop-up menu. 

Tap a contact to start a chat

Tap and hold to display a pop-up menu

To add a contact, tap Tools > Add a Contact and follow the directions on 
the screen. To delete a contact, tap and hold the contact’s name, then tap 
Delete Contact from the pop-up menu. To see others online without being 
seen, tap Tools > My Status > Appear Offline. 

Managing Contacts
To be alerted each time you are added to a contact list, tap Tools > 
Options > the Privacy tab.

• To block a contact from seeing your status and sending you messages, 
tap the contact and tap the right arrow. This moves the contact to the 
My Block List.

• To unblock a contact, tap the contact and tap the left arrow. This moves 
the contact to the My Allow List.

• To receive an alert when someone adds you to their contacts list, select 
Alert me when I am added to a Passport contact list.

• To see who has you listed as a contact, tap View. 
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Sending a Message
• Tap a contact to whom you want to send a message. Enter your message 

in the text entry area at the bottom of the screen and tap Send. To 
quickly add common messages, tap My Text and tap a desired message.

• To invite another contact to an ongoing chat, tap Tools > Invite and tap 
a contact.

• To see who is already chatting or to switch between chats, tap Chats. 

Enter a message here

Tap to send a message

Windows Media Player for Windows Mobile

Use Microsoft Windows Media Player for Windows Mobile to play digital 
audio and video files that are stored on your CN2B Computer or on a net-
work. To switch to Windows Media Player on your CN2B Computer, tap 
Start > Windows Media. 

Use Microsoft Windows Media Player on your desktop to copy digital 
audio and video files to your CN2B Computer. You can play Windows 
Media and MP3 files on your Windows Mobile. 

Monitors the progress of the current track

Tap to adjust volume

Tap to skip to the next song
Tap to play a previous song

Tap to start, pause, or stop a song

For more information about using Windows Media Player for Windows 
Mobile, tap Start > Help > Windows Media Player.
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Microsoft Reader
Use Microsoft Reader to read eBooks on your CN2B Computer. Down-
load books to your desktop from your favorite eBook Web site. Then, use 
ActiveSync to copy the book files to your activated CN2B Computer. The 
books appear in the Reader Library, where you can tap them in the list to 
open them. Each book consists of a cover page, an optional table of con-
tents, and the pages of the book. You can:

• Page through the book by using the Up/Down control on your CN2B 
Computer or by tapping the page number on each page.

• Annotate the book with highlighting, bookmarks, notes, and drawings.

• Search for text and look up definitions for words.
The Guidebook contains the information needed to use the software. To 
open the Guidebook, tap Help on the Reader command bar. Or, on a book 
page, tap and hold the book title, and then tap Help on the pop-up menu.

To switch to Microsoft Reader, tap Start > Programs > Microsoft Reader.

 

Getting Books on Your CN2B Computer
You can download book files from the Web. Just visit your favorite eBook 
retailer and follow the instructions to download the book files.

Sample books and a dictionary are also included in the “\Extras\MSReader” 
path on the Windows Mobile Companion CD.

Use ActiveSync to download the files from your desktop to your activated 
mobile computer described in the Read Me file in the “\MSReader” folder.

Using the Library
The Library is your Reader home page; it displays a list of all books stored 
on your CN2B Computer or storage card. To open the Library:

1 On the Reader command bar, tap Library.

2 On a book page, tap the book title, then tap Library on the menu.

3 To open a book, tap its title in the Library list. 

Tap these to navigate

Tap to scroll through the list

Tap to open a bookTap to select a sort order

to other parts of the
Reader
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Reading a Book
Each book consists of a cover page (which includes navigation options), an 
optional table of contents, and the pages of the book.

The first time you open a book, go to the first page or to the table of con-
tents, if there is one. Subsequently, whenever you open the book, you are 
automatically taken to the last page read.

With the text, each book page includes a page number and book title. You 
can also page through a book by using the Up/Down/Left/Right controls 
on your CN2B Computer. 

Tap to select a 
navigational option

Tap the text for a pop-up menu

Using Reader Features
Reading a book electronically gives you several options not available with 
paper books. These options are available from any book page.

Select text by dragging across the text on the page. Then, tap an option on 
the pop-up menu, as described here:

Searching for Text Find text in a book by tapping Find on the pop-up menu. Enter the word you want to 
search for, and tap the desired Find option. Reader highlights found text on the page. To 
close Find, tap outside the box. To return to your original page, tap the title and then tap 
Return on the pop-up menu.

Copying Text You can copy text from books that support this feature into any program that accepts text. 
On a book page, select the text you want to copy. Then, tap Copy Text on the pop-up 
menu. The text can be pasted into the program of your choice.

Adding Bookmarks When you add a bookmark to a book, a color-coded bookmark icon appears in the right 
margin. You can add multiple bookmarks to a book. Then, from anywhere in the book, 
tap the bookmark icon to go to the bookmarked page.

Highlighting Text When you highlight text, it appears with a colored background.

Attaching Notes to Text When you attach a note to text, you enter the text in a notepad that appears on top of the 
book page. A Note icon displays in the left margin. To show or hide the note, tap the icon.

Adding Drawings When you add a drawing, a Drawing icon appears in the bottom, left corner of the page, 
and drawing tools appear across the bottom of the page. Draw by dragging your stylus.

Annotations Index To see a list of a book’s annotations, including bookmarks, highlights, text notes, and 
drawings, tap Annotations Index on the book’s cover page. You can tap an entry in the list 
to go to the annotated page.
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Removing a Book
When you finish reading a book, you can delete it to conserve space on 
your CN2B Computer. If a copy of the book is stored on your desktop, you 
can download it again at any time.

To remove a book from your CN2B Computer, tap and hold the title in 
the Library list, and then tap Delete on the pop-up menu.

Pocket Internet Explorer
Use Microsoft Pocket Internet Explorer to view Web or WAP pages in 
either of these ways:

• During synchronization with your desktop, download your favorite links 
and mobile favorites that are stored in the Mobile Favorites subfolder in 
Internet Explorer on the desktop.

• Connect to an ISP or network and browse the Web. To do this, create 
the connection first, as described in “Remote Access (Modems)” on 
page 100.

When connected to an ISP or network, you can also download files and 
programs from the Internet or intranet.

To switch to Pocket Internet Explorer on your CN2B Computer, tap Start 
> Internet Explorer.

 

The Mobile Favorites Folder
Only items stored in the Mobile Favorites subfolder in the Favorites folder 
in Internet Explorer on your desktop are synchronized with your CN2B 
Computer. This folder was created automatically with ActiveSync installed.

Favorite Links
During synchronization, the list of favorite links in the Mobile Favorites 
folder on your desktop is synchronized with Pocket Internet Explorer on 
your CN2B Computer. Both computers are updated with changes made to 
either list each time you synchronize. Unless you mark the favorite link as a 
mobile favorite, only the link is downloaded to your CN2B Computer. 
Connect to your ISP or network to view the content. 

1 In ActiveSync on your desktop, click Tools > Options, and select 
“Favorites” from the Mobile Device list. For more information on using 
ActiveSync, see ActiveSync Help on the desktop.

2 In Internet Explorer on your desktop, save or move favorite links to the 
Mobile Favorites subfolder in the Favorites list via Favorites > Organize 
Favorites. For more information on using Internet Explorer, see Internet 
Explorer Help on the desktop.

3 Connect your CN2B Computer to your desktop. If synchronization 
does not start automatically, in ActiveSync on your desktop, click Sync.
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Mobile Favorites
If you are using Microsoft Internet Explorer 5.0 or later on your desktop, 
you can download mobile favorites to your CN2B Computer. Synchroniz-
ing mobile favorites downloads Web content to your CN2B Computer so 
that you can view pages while disconnected from your ISP and desktop.

Use the Internet Explorer plug-in installed with ActiveSync to create 
mobile favorites quickly. To create a mobile favorite:

1 In ActiveSync on your desktop, click Tools > Options, and select 
“Favorites” from the Mobile Device list. For more information on using 
ActiveSync, see ActiveSync Help on the desktop.

2 In Internet Explorer 5.0 or greater on your desktop, browse to the page 
you want to view offline, then click Tools > Create Mobile Favorite.

3 To change the link name, enter a new name in the Name box.

4 In the Update box, select a desired update schedule to keep the page in 
the Mobile Favorites folder up to date. You can also update content by 
clicking Tools > Synchronize in Internet Explorer.

5 To save the link in a subfolder of Mobile Favorites, click Create In and 
select the desired subfolder.

6 Click OK. Internet Explorer downloads the latest version of the page to 
your desktop.

7 To download the pages that are linked to the mobile favorite you just 
created, in Internet Explorer on the desktop, right-click the mobile 
favorite, then click Properties. On the Download tab, specify the num-
ber of links deep you want to download. To conserve CN2B Computer 
memory, go only one level deep.

8 Connect your CN2B Computer to your desktop. If synchronization 
between your CN2B Computer and desktop does not start, in Active-
Sync on your desktop, click Sync. 

Mobile favorites take up storage memory on your CN2B Computer. To 
minimize the amount of memory used:

• In the settings for the Favorites information, type in ActiveSync options, 
turn off pictures and sounds, or stop some mobile favorites from being 
downloaded to the CN2B Computer. For more information, see Active-
Sync Help.

• Limit the number of downloaded linked pages. In Internet Explorer on 
the desktop, right-click the mobile favorite you want to change and then 
Properties. In the Download tab, specify “0” or “1” for the number of 
linked pages you want to download.
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Using AvantGo Channels
AvantGo is a free interactive service that gives you access to personalized 
content and thousands of popular Web sites. You subscribe to AvantGo 
channels directly from your CN2B Computer, then synchronize your 
CN2B Computer and desktop, or connect to the Internet to download the 
content. Visit the AvantGo website for information. Tap the Add or 
Remove link to add or remove channels. Do the following to synchronize 
an AvantGo channel:

1 In Pocket Internet Explorer on your CN2B Computer, tap  to dis-
play your list of favorites.

2 Tap the AvantGo Channels link.

3 Tap Activate.

4 Follow instructions on the screen. Synchronize the CN2B Computer 
with the desktop, then tap My Channels to complete the setup.

5 When synchronization is complete, tap the AvantGo Channels link in 
your list of favorites to see a few of the most popular channels. 

Using Pocket Internet Explorer
You can use Pocket Internet Explorer to browse mobile favorites and chan-
nels that were downloaded to your CN2B Computer without connecting 
to the Internet. You can also connect to the Internet through an ISP or a 
network connection and browse the Web. 

Refresh icon Home icon

Viewing Mobile Favorites and Channels
1 Tap the Favorites icon to display your list of favorites.

2 Tap the page you want to view.
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Tap to view a favorite

Tap to add or delete a folder or favorite link

The page that was downloaded the last time you synchronized with your 
desktop opens. If the page is not on your CN2B Computer, the favorite is 
dimmed. Synchronize with your desktop again to download the page to 
your CN2B Computer, or connect to the Internet to view the page.

Browsing the Internet
1 Set up a connection to your ISP or corporate network using Connec-

tions, as described in “Remote Access (Modems)” on page 100.

2 To connect and start browsing, do one of the following:

• Tap the Favorites icon, and then tap the favorite you want to view.

• Tap View > Address Bar. In the address bar that appears at the top of 
the screen, enter the Web address you want to visit and then tap Go. 
Tap the arrow to choose from previously entered addresses.

Note: To add a favorite link while using the CN2B Computer, go to the 
page you want to add, tap and hold on the page, and tap Add to Favorites.
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There are multiple ways to get an application to your CN2B Mobile Com-
puter; like there are multiple ways to package the application for delivery.
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Packaging an Application
Use any of these methods to package an application for installation:

• For very simple applications, the application itself might be the only file 
that needs to be delivered.

• It could be a directory structure that contains the application, supporting 
files like ActiveX controls, DLLs, images, sound files, and data files.

• Or, you could package an application via a CAB file.

Consider any of the following when choosing a location into which to store 
your application:

• In the basic CN2B Computer, there are two built-in storage options: the 
Object Store and the Persistent Storage Manager (PSM). The Object 
Store is RAM that looks like a disk. Anything copied here is deleted 
when a cold-boot is performed on the CN2B Computer. The PSM is an 
area of storage which is embedded in a section of the system’s FLASH 
memory. This storage area is not erased during a cold-boot. It may, how-
ever, be erased during the reflashing process. In addition to storing appli-
cations and data files, you do have the option to store a persistent registry 
to the PSM region.

• If the optional Secure Digital storage card is in the system, then consider 
this card the primary location for placing an applications install files. 
This storage card creates the “\Storage Card” folder.

• Use the small nonvolatile Flash File Store region to hold CAB files that 
rebuild the system at cold-boot or install applications from a CAB file 
into the Flash File Store so they are “ready-to-run” when a cold-boot is 
performed. Since the FLASH in the system has a limited number of 
write cycles, do not use the Flash File Store for excessive writing pur-
poses; however, reading is okay.

Files copied to any of these locations are safe when a cold-boot is performed 
on a CN2B Computer — providing the AutoRun system is installed in the 
appropriate location You can find this system in the CN2B Management 
Tools portion. Copying a CAB file to the “\CabFiles” folder on one of 
these cards automatically extracts that CAB file on every cold-boot to 
ensure that your system is properly set up (see page 83).

Installing Applications
Consider any of these options to get the package to the preferred location 
on your CN2B Computer: Microsoft ActiveSync (page 75), FTP Server 
(page 76), Secure Digital storage cards (page 76), Wavelink Avalanche 
(page 76), SmartSystems™ Console (page 77), or Registry (page 77).
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Using Microsoft ActiveSync
Note: These instructions assume the CN2B Management Tools were 
installed on your desktop.

The Microsoft ActiveSync tool is located on the CN2B Companion CD. See 
Chapter 2, “Windows Mobile 2003” for information about this tool as 
provided by Microsoft Corporation.

This can be a serial, USB, or InfraRed ActiveSync connection. Files can be 
copied using File Explorer on a desktop or a laptop computer. This is usu-
ally good when updating few CN2B Computers.

These instructions assume that Microsoft ActiveSync was installed onto 
your desktop and is up and running. If not, go to Chapter 2, “Windows 
Mobile 2003” for an URL from which to download the latest application.

1 Connect your CN2B Computer to your desktop computer via an Active-
Sync cable.

2 Wait for a “Connected” message to appear in the Microsoft ActiveSync 
application to signal a connection to the CN2B Computer. If necessary, 
select File > Get Connected to initiate a connection. 

3 Click Explore to access the Mobile Device folder on your unit.

4 From your desktop, select Start > Windows Explorer, then browse the 
“C:\Intermec\CN2B Mgmt Tools\CabFiles” path for any CAB files 
needed for your CN2B Computer. Select the appropriate file, right-click 
the file for a pop-up menu, then select Copy.

5 Within the Mobile Device directory, go to the directory where you want 
the files located on the CN2B Computer, do a right-click for a pop-up 
menu, then select Paste.

6 When all of the files are pasted, perform a warm-boot on the CN2B 
Computer. When the computer reboots, wait for the LED on the top 
left of your keypad to stop blinking. Tap Start > Programs > File 
Explorer to locate the newly copied executable files, then tap these files 
to activate their utilities.
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Using the FTP Server
The CN2B Computer has a built-in FTP Server that connects to a network 
via 802.11b/g or WAN (Wireless Access Network). This allows connec-
tions to the CN2B Computer to perform file transfers or computer man-
agement functions. Another benefit is you can create FTP scripts to 
automate the process of copying files to the CN2B Computer. This option 
is good for when a large number of CN2B Computers need updating. See 
Chapter 7, “Programming” for information.

Copying a Secure Digital Storage Card
Use these steps to install an application using a Secure Digital storage card:

1 Suspend the CN2B Computer, remove the battery from the CN2B 
Computer, then remove its Secure Digital storage card. 

Secure Digital 
storage card

2 Using a Secure Digital card reader connected to your desktop PC, insert 
the Secure Digital card into your card reader.

3 Create a “\CabFiles” directory on the Secure Digital card, then copy 
(build into cabfiles) your application, data files, and all required DLLs 
and drivers into this directory.

4 Remove the Secure Digital card from your card reader and reinstall it 
into the CN2B Computer.

5 Perform a warm-boot on the CN2B Computer to install these files.

Using Wavelink Avalanche
You can use the Wavelink Avalanche device management system to install 
applications on all of your wireless CN2B Computers.

The wireless CN2B Computer ships with the Avalanche Enabler already 
loaded on it. The Avalanche Enabler is configured to activate automatically 
(typically on a warm boot).
Note: If you manually activate the Avalanche Enabler on the CN2B Com-
puter, you may be prompted for a password when you exit the Avalanche 
Enabler. The default password is leave.

When the Avalanche Enabler is activated, the CN2B Computer attempts to 
connect to the Avalanche Agent. When the CN2B Computer connects to 
the Agent, the Agent determines whether an update is available and imme-
diately starts the software upgrade, file transfer, or configuration update.
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To use Avalanche to remotely manage the CN2B Computer

1 Install software packages and updates for the CN2B Computer using the 
Avalanche Management Console. For help using the console, see the 
online help.

2 Schedule the CN2B Computer updates or manually initiate an update 
using the Avalanche Management Console. 

For information on using Wavelink Avalanche, contact your local Intermec 
representative or visit the Wavelink web site at www.wavelink.com.

Using the SmartSystems Console
You can use the SmartSystems Console to drag-and-drop Intermec applica-
tions onto your CN2B Computers. The CN2B Computer ships with the 
SmartSystems client loaded on it. The console is part of SmartSystems 
Foundation and is available from the Intermec web site. To download 
SmartSystems Foundation, go to www.intermec.com/idl and open the 
Device Management page.

To use SmartSystems Console to install an application

1 Download your application file from the Intermec web site and unzip it 
on your desktop.

2 From the SmartSystems Console, drag-and-drop the application onto 
each CN2B Computer discovered in your network.

For information on using the SmartSystems Console, see its online help.

Replicating Settings Using the Registry
The following information updates the registry on your CN2B Computer, 
confirms the registry update, then copies the information onto other CN2B 
Computers in your network.

If you are using DHCP, no changes are necessary.

If using Static IP, the new CN2B Computer has the IP address of the origi-
nal CN2B Computer because the copied registry includes this information. 
When you change the IP address using the Intermec Settings applet, the 
information is lost when a warm-boot is performed, and the original IP 
address is used. 

Load the REGFLUSH.CAB file to install the Registry Save application, run 
this application, then perform a warm-boot to keep the new IP address.

To install the Registry Save application after a cold-boot is performed, 
change the properties of the REGFLUSH.CAB file to that of read-only. 
Using ActiveSync, copy the CAB file to the “Flash File Store\Persistent 
Copy\CabFiles” folder on the CN2B Computer, then perform a cold-boot 
to load this file.
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Deleting the Old Registry File
1 On the original CN2B Computer, select Start > Programs > File 

Explorer, then tap My Device > Flash File Store. Scroll down to the bot-
tom of the list of files and folders, press and hold your stylus in the white 
area beneath for a pop-up menu, then select View All Files. 

2 Look for a “registry” file. If one exists, select to highlight that file, press 
and hold for a pop-up menu, select Delete, then Yes to remove this file. 

3 Select Start > Settings > the System tab > the Utilities icon > the Regis-
try Save tab, then check Enable Registry Storage to enable the registry 
save flag. Tap ok to close, then close the Settings. 

4 Select Start > Registry Save, then tap ok when told the registry is saved. 
78 CN2B Mobile Computer User’s Manual



Chapter 3 —  Installing Applications
Confirming the New Registry File
To confirm whether the new registry file exists, do the following:
1 On the CN2B Computer, select Start > Programs > File Explorer, then 

tap My Device > Flash File Store. Press and hold your stylus in the white 
area beneath for a pop-up menu, then select View All Files. 

2 The new registry file should be on the root of the Flash File Store folder 
with today’s date. 

Updating Other Computers in Your Network
These instructions assume you have Windows XP on your desktop.

1 Connect your CN2B Computer to your desktop using Microsoft Active-
Sync and a cradle. Make sure the ActiveSync application on your desk-
top is up and running and connected to your CN2B Computer.

2 On your desktop, select Start > Settings > Control Panel, double-click 
Folder Options, then click the View tab. 
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3 Beneath “Hidden files and folders,” check Show hidden files and fold-
ers, then click OK to close.  

4 Remove the CN2B Computer from the cradle, and put another CN2B 
Computer in its place. The ActiveSync application on your desktop 
should connect to the new unit. 

5 Follow the instructions for “Deleting the Old Registry File” on page 78, 
put the new registry file in the root of the Flash File Store folder on the 
new CN2B Computer, enable the registry save flag via the Utilities 
applet, perform a warm-boot. and make sure these settings are saved.

Updating the System Software
When you upgrade your CN2B Computer, you are updating the operating 
system (OS) and the Persistent Storage Manager (PSM) files.

The PSM files are stored in the Flash File Store region, and deliver Inter-
mec value-added functionality such as data collection, unit configuration 
and diagnostics, and Intermec’s wireless security suite.

You need to download the latest upgrade files from the Intermec web site to 
your desktop PC.

1 Start your web browser and go to the Intermec web site at www.inter-
mec.com/wm2003.

2 Click the PPC 2003 OS link, fill out the appropriate information, then 
click Submit Information. Click OK to continue.

3 Click the link and download the .zip file to your PC.
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4 Follow the steps in one of the next sections:

• If you are using a Secure Digital card to upgrade the CN2B Com-
puter, see below.

• If you are using the SmartSystems Console to upgrade the CN2B 
Computer, see “Using the SmartSystems Console to Upgrade the 
CN2B Computer” on page 82.

Using a Secure Digital Card to Upgrade the CN2B Computer
To use a Secure Digital card to upgrade the CN2B Computer, you need a 
Secure Digital card reader and a Secure Digital card formatted as FAT
Note: The CN2B Computer currently supports Delkin Devices Secure 
Digital cards only. Intermec cannot guarantee that other Secure Digital 
cards will work with the CN2B Computer.

.

1 Suspend the CN2B Computer, remove the battery from the CN2B 
Computer, then remove its Secure Digital storage card. 

Secure Digital 
storage card

2 Place the Secure Digital storage card in your desktop PC card drive, then 
copy all required upgrade files to the storage card.

3 Remove the Secure Digital card from your desktop, reinstall it into the 
CN2B Computer, and insert the CN2B Computer into a dock con-
nected to external power.

4 Press the Reset button inside the stylus holder to perform a cold-boot. 
Do not use force or a sharp object when pressing the Reset button, or you may 
damage the Reset button. 

Press to reset

5 When the Bootloader Menu shows “complete,” remove the Secure Digi-
tal card, insert the battery, then install the battery door. Press the Reset 
button again to load the new operating system.
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Note: The upgrade will fail if the CN2B Computer is not connected to 
external power. For help, see “Accessories” on page 16.

When the CN2B Computer finishes booting, you may use it. You have 
reset the CN2B Computer to its default configuration. You need to set the 
date and time and to set its network communications parameters to rees-
tablish communications with the other devices in the wireless network.

Using the SmartSystems Console to Upgrade the CN2B Computer
You can use the SmartSystems Console to upgrade the operating system on 
your CN2B Computer. The console is part of SmartSystems Foundation 
and is available from the Intermec web site via the Intermec Developer 
Library (IDL). Before you can upgrade your computer, you need:

• the SmartSystems Foundation. To download SmartSystems Foundation, 
go to www.intermec.com/idl and open the Device Management page.

• the device upgrade .exe file. This file is available from the Intermec web 
site at www.intermec.com. Go to Service & Support > Downloads. 
Make sure the file you select is for your language.

1 Install SmartSystems Foundation on your desktop PC, then open the 
console.

2 Make sure the console and CN2B Computers are on the same subnet.

3 Make sure your CN2B Computers are either in a CN2B Communica-
tions Dock or charging dock, or that power management is disabled.

4 Download the device upgrade .exe file to your desktop PC.

5 Double-click the .exe file on your desktop PC. An InstallShield applica-
tion starts and walks you through the process of extracting the upgrade 
files in the default location.

Note: Do not change the default location where InstallShield extracts the 
files. The SmartSystems Console requires the files be in this location.

6 From the SmartSystems Console, locate the device upgrade to install.

7 Drag-and-drop the device upgrade onto each CN2B Computer you 
want to upgrade. The SmartSystems Console will tell you that it is 
installing the upgrade on your CN2B Computer.

Once the upgrade is done downloading to your CN2B Computer, your 
CN2B Computer replaces the operating system and then automatically 
performs a cold boot. Progress messages do appear on the CN2B screen.
The SmartSystems Console will show your CN2B Computer as offline 
(note the red stop sign) until the device reboots and reconnects to the system.
82 CN2B Mobile Computer User’s Manual

http://www.intermec.com
http://www.intermec.com/idl


Chapter 3 —  Installing Applications
Migrating from Another Computer
As you migrate from another mobile computer to a CN2B Computer, you 
need to consider the following: When converting an application to run on 
the CN2B Computer, most APIs should work. Below are a few exceptions:

• The other computer may use the “\SDMMC Disk” folder for nonvola-
tile storage. You may need to change the application to store data onto 
the “Storage Card” folder instead of the “\SDMMC Disk” folder if a 
Secure Digital storage card is present in the system.

• If the application uses the RegFlushKey() API, it must first verify that 
the proper media is available in the system.

• Keyboard remapping is available on the CN2B Computer should you 
need to map these keys like that of the original computer (see page 182).

• Targeting the ARM (SA1110) processor which creates applications that 
run on the CN2B Computer requires the Windows Mobile 2003 SDK.

Installing Cabinet Files
CAB files (short form of “cabinet” files) are compressed folders as defined by 
Microsoft. A “cabinet” file is a single file, usually suffixed with .CAB, that 
stores compressed files in a file library. A compressed file can be spread over 
several cabinet files. During installation, the setup application decom-
presses the files stored in a cabinet and copies them to the user’s system.

For the CN2B Computer, CAB files register DLLs, create shortcuts, mod-
ify registry entries, and run custom setup programs. Tap a CAB file to 
extract that file or place the CAB file on one of the approved storage devices 
in the “\CabFiles” folder, then perform a warm-boot on the CN2B Com-
puter.

There are two methods available to extract a CAB file:

• Tap a CAB file to extract it. With this method, the CAB file is automat-
ically deleted when the extraction process is successful, unless the CAB 
file is set with the read-only attribute.

• Use AUTOCAB to extract all files when a cold-boot is performed on the 
CN2B Computer. See the Software Tools User’s Manual for information.
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This chapter includes information about the different networks supported 
by the CN2B Mobile Computer, and ways to configure and manage those 
networks. Note that the CN2B Mobile Computer automatically installs the 
appropriate software for radio or phone use when the unit is turned on.

Below are the main topics of this chapter:

• Personal Area Networks (page 86)

• Local Area Networks (page 92)

• Wide Area Networks (page 100)

• Remote Access (Modems) (page 100)

• Management (page 108)
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Personal Area Networks
"Bluetooth" is the name given to a technology standard using short-range 
radio links, intended to replace cables connecting portable and fixed elec-
tronic devices. The standard defines a uniform structure for a range of 
devices to communicate with each other with minimal user effort. Its key 
features are robustness, low complexity, low power, and low cost. The tech-
nology offers wireless access to LANs, the mobile phone network, and the 
internet for a host of home appliances and mobile computer interfaces.

Wireless Printing can also be done with Microsoft APIs, including Blue-
tooth extensions for Winsock, and Bluetooth virtual COM ports. Informa-
tion about other Bluetooth software is in the Bluetooth Resource Kit and 
the Bluetooth Resource Kit User's Guide via the Intermec Developer Library 
(IDL), which is available as a download from the Intermec web via 
www.intermec.com/idl. See your Intermec representative for information.

About the Application
Bluetooth is not started automatically by default after a cold-boot is per-
formed. To run Bluetooth, tap Start > Settings > the Connections tab > 
the Bluetooth icon. The CN2B Computer retains the Bluetooth state when 
warm-boots are performed, for example:

• If Bluetooth is active, and a warm-boot was performed, the CN2B Com-
puter boots up with the Bluetooth state activated and Bluetooth virtual 
COM ports (such as printing) registered. However, you must reactivate 
connections, as the system does not do these automatically.

• If Bluetooth is inactive, and a warm-boot was performed, the CN2B 
Computer boots up with Bluetooth deactivated.

Mode
The default tab activates or deactivates Bluetooth. When Bluetooth is acti-
vated, the CN2B Computer discovers and connects to remote devices. 
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Wireless Printing
Use this tab to print via Bluetooth devices. Tap Device Discovery to dis-
cover (or scan) for remote Bluetooth devices. When the CN2B Computer 
is finished scanning, any newly discovered devices appear in the upper 
Devices box.

Tap Clear Devices to remove the list from the Devices box.

To print to a Bluetooth device, select any of the devices listed in the 
Devices box, then tap Connect. Once connected, the selected device moves 
to the lower Connected box. 

To view connection information or register a COM port for a device, from 
the lower Connected box, select a device, then tap Properties. See “Proper-
ties” below for information.

When done printing to a device, select that device in the Connected box, 
then tap Disconnect. This moves the device in question back to the upper 
Devices box. 

Properties
Select a COM Port from the Choose COM Port box to register for this 
device, then check Enable Wireless Printing to complete the COM port 
registration. To change your COM port selection, clear (uncheck) the 
Enable Wireless Printing box, select a new COM port, then check Enable 
Wireless Printing again. Choose COM Port items already in use are 
grayed out.

When you enable Wireless Printing, a status message is shown near the bot-
tom of the screen to confirm your action. To print a test page to your 
printer, tap Print Test Page.

Check Default to set this printer to identify the assigned COM Port as the 
WPPort in the registry. See the Bluetooth Resource Kit User’s Guide for more 
details on WPPort.
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Tap ok to return to the Wireless Printing page. 

File Transfer
Use this page to enable your unit to receive files from another Bluetooth 
device, or from any device that supports this function. 

Connecting with Bluetooth
Note: While these instructions apply to many Bluetooth devices, these 
instructions use the Nokia 3650 for example purposes.

Before you connect to the network, make sure Bluetooth is enabled on your 
CN2B Computer so you can discover and connect to remote devices.
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Tap Start > Settings > the Connections tab > the Bluetooth icon. Tap On 
to activate Bluetooth, then tap ok to exit the applet. 

Also make sure Bluetooth is enabled on your mobile phone. For example, 
with the Nokia 3650, go to its menu, select Connect > Bluetooth, then set 
My phone’s visibility to “Shown to all.”

Do the following to establish a Bluetooth connection between your CN2B 
Computer and your mobile phone, then establishing a dial-up networking 
session with your wireless network. Once connected, you should be able to 
browse Internet websites and use other online resources from your CN2B 
Computer.
1 Tap Start > Settings > the Connections tab > the Connections icon, 

then tap Add a new modem connection. 
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2 Enter a name for the connection, such as “Nokia.” In the Select a 
modem list, select “Bluetooth,” then tap Next to continue. 

3 Tap New... if the phone is not listed in the known devices. Make sure 
your Bluetooth device is turned on before you start the search. 

4 When the discovery of devices is complete, select your Bluetooth device, 
then tap Next to continue. 
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5 Enter the correct Device PIN on both the Bluetooth device and the 
CN2B Computer, then tap Next to continue. 

6 Enter a name for the device if needed, then tap Finish. 

7 After bonding completes, select your Bluetooth device from the list of 
bonded devices, then tap Next. 
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8 Enter the appropriate number as it should be dialed for your Bluetooth 
connection, then tap Next to continue. 

9 Enter the user name, password, and domain required for your Bluetooth 
device, then tap Finish. 

Now you can establish a connection to your network via the Internet 
Explorer application. To disconnect, tap the Connectivity icon in the top 
menu bar, then select Disconnect.

Local Area Networks
By default, the CN2B Computer comes with a 802.11b/g radio and Blue-
tooth. The CN2B Computer is capable of supporting 802.11i security 
requirements.

The CN2B Computer is a versatile mobile computer that you can easily 
add to your wired or wireless data collection network. You can connect 
your CN2B Computer to your network using:

• USB communications

• 802.11b/g radio communications
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Configuring USB Communications
You can place the CN2B in the CN2B Modem Dock or the CN2B Com-
munications Dock to transfer data to and receive data from another device 
using USB communications. The USB cable, communications dock, and 
modem dock are sold separately. For more information on accessories and 
how to order them, see “Accessories” on page 16.

To use USB communications with your CN2B Computer

1 Connect the CN2B Communications Dock to the USB port of the 
other device using an appropriate USB cable.

2 Make sure that your USB device is configured for USB communications.

3 Insert the CN2B Computer into the CN2B Communications Dock.

4 Turn on the CN2B Computer.

Configuring 802.11b/g Radio Communications
Make sure all components with antennas are at least 30 cm (1 ft) apart 
when power is applied. Failure to comply could result in equipment 
damage.

The wireless CN2B has an internal 802.11b/g radio to transfer data using 
wireless communications. This manual assumes you have already set up 
your wireless communications network, including your access points. If 
you are using a UDP Plus network, you also need to have your Intermec 
Application Server communicating with a host computer.

Your CN2B Computer supports TCP/IP and UDP Plus.

Configuring the Network Parameters for a TCP/IP Network
In a TCP/IP network, the CN2B Computer communicates with a host 
computer directly using TCP/IP. The access point acts as a bridge to allow 
communications between the wired and wireless networks.

1 Configure the infrastructure mode, network name (SSID), host IP 
address, and IP settings (if not using DHCP) on each CN2B Computer 
in the network.

2 Configure security. For help, see “Configuring Your Wireless Network” 
on page 197.

Configuring the Network Parameters for a UDP Plus Network
In a UDP Plus network, the CN2B Computer communicates with a host 
computer through the Intermec Application Server. The Intermec Applica-
tion Server translates UDP Plus packets on the wireless network into  
TCP/IP packets on the wired network and vice versa. The access point acts 
as a bridge to allow communications between wired and wireless networks.

1 Configure the network name (SSID), controller IP address, IP settings 
(if not using DHCP), and controller port (set to 5555) on each CN2B 
Computer in the network.
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2 Configure security. For help, see “Configuring Your Wireless Network” 
on page 197.

The easiest way to configure the network parameters on the CN2B Com-
puter is to use the Intermec Settings applet. For help, see “Intermec Set-
tings Applet” on page 192.

Network Adapters
The CN2B Computer has the 802.11b/g radio and wireless printing. It 
does not have an external antenna. Other radios are not supported. See the 
Developer’s Support web site for information on network adapters.

Wireless 802.11 Communications
When “Wireless 802.11” is selected via the NDISTRAY pop-up menu, 

the Wireless 802.11 antenna icon (shown to the left) appears in the Win-
dows system tray. 

To configure wireless 802.11 communications on the CN2B Computer, 
tap Start > Settings > the System tab > the Wireless Network icon. Go to 
Appendix A, “Configurable Settings” for information.
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No Networking
When “No networking” is selected via the NDISTRAY pop-up menu, 

the disconnected icon (shown to the left) appears in the Windows system 
tray. 

Network Selection APIs
These APIs change the network adapter configuration programmatically. 
Both drivers support the same IOCTL function numbers for loading and 
unloading the drivers. Go to Chapter 7, “Programming” to see the APIs.

Network Connections
Tap Start > Settings > the Connections tab > the Connections icon > the 
Advanced tab > Network Card > the Network Adapters tab to access the 
network connections for this unit, then tap ok when finished. 
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Creating a Wireless Network Connection
Microsoft Corporation’s wireless network configuration tool is called 
“Wireless Zero Config.” Intermec recommends that you use the Wireless 
Network applet instead as it offers more security choices and exhibit better 
roaming behavior. Go to page 195 for information about the Wireless Net-
work applet.

Networks already configured are preferred networks and are listed in Wire-
less networks. You can connect to only preferred networks or search for and 
connect to any available network.

A wireless network can be added either when the network is detected, or 
manually by entering settings information. To determine if authentication 
information is needed, see your network administrator.
1 Tap Start > Settings > the Connections tab > the Connections icon. 

2 Tap the Advanced tab > Network Card > the Wireless tab > Add New. 

3 Tap the General tab, then enter a network name. If the network was 
detected, the network name is entered and cannot be changed.

From Connects to, select to what your network is to connect. If you 
select “Work,” you can do a vpn connection or use proxy servers. If you 
select “The Internet,” you can connect directly to the internet.
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To connect to an ad-hoc connection, select This is a device-to-device 
(ad-hoc) connection. 

4 Tap the Network Key tab, then do the following:

To Disable Authentication

a Set Authentication to either “Open” if WEP keys are not required; or 
“Shared” when WEP keys are required for association.

b Set Data Encryption to “Disabled.” 

To Enable WEP Encryption

a Set Authentication to either “Open” if WEP keys are not required; or 
“Shared” when WEP keys are required for association.

b Set Data Encryption to “WEP.”

c To change the network key, clear The Key is provided for me auto-
matically box, then enter the new Network key and select the appro-
priate Key index.
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Note: The following information applies when you have Enable 
Microsoft’s Wireless Zero Config checked via the Wireless Network 
applet (see page 195).

To Enable WPA Authentication 
Set Authentication to “WPA” (page 197) and Data Encryption to 
“WEP” (page 197) or “TKIP” (page 196). 

To Enable WPA Authentication Using a Preshared Key 
Set Authentication to “WPA-PSK” (page 197), Data Encryption to 
“WEP” (page 197) or “TKIP” (page 196), and enter the new Network 
key. 
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5 Tap the 802.1x tab, select either “PEAP” or “Smart Card or Certificate” 
for the EAP type, then tap Properties to adjust its settings. 

6 Tap ok to return to the Configure Wireless Network screen.

7 From the Networks to access drop-down list, select “All Available,” 
“Only access points,” or “Only computer-to-computer” depending on 
the type of networks to which you connect.

To connect only to networks you have already configured, clear Auto-
matically connect to non-preferred networks.

Tap ok to close this screen. 

Note: If you select to automatically connect to non-preferred networks, 
your device detects new networks and provide you the opportunity to con-
figure them.

AutoIP/DHCP
Automatic Private IP Addressing (AutoIP) is enabled by default in Win-
dows Mobile 2003. To remain compatible with other versions of Pocket 
PC, this setting needs to be enabled. You can configure the registry settings 
in HKEY_LOCAL_MACHINE\Comm\NETWLAN1\TcpIp to set the required 
AutoIP/DHCP behavior.
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AutoInterval, AutoMask, AutoSubnet, AutoIP, and AutoSeed are other 
registry keys that can modify the behavior of AutoIP. You can find the 
appropriate settings and behavior of each of these keys in Microsoft Help.

When a TCP/IP client cannot find a DHCP server, it generates an AutoIP 
address from the 169.254.xxx.xxx block. The client then tries to check for a 
DHCP server every 15 seconds and if a DHCP server is found, the client 
drops the AutoIP address and uses the address from the DHCP server.

In the MSDN Windows CE documentation available out on the Microsoft 
Developer Network web site (www.msdn.com), see “Automatic Client 
Configuration” for more information on AutoIP.

To disable AutoIP, set the AutoCfg registry entry to “0.” If a DHCP server 
cannot be found, instead of using AutoIP, the system will display the 
“Unable to obtain a server assigned IP address” message.
Note: If you try to disable AutoIP using a CAB file to set the registry value 
for AutoIP, remember to set the EnableDHCP value to “1” to keep DHCP 
enabled.

Note: For more attempts a DHCP client makes to get a DHCP address, 
use the DhcpRetryDialogue and DhcpMaxRetry registry settings.

Note: Change the AutoInterval registry key value to make the client retry 
more often to obtain a DHCP address.

Wide Area Networks
The CN2B Computer does not support wide area networks.

Remote Access (Modems)
You can set up connections to the Internet and corporate network at work 
to browse the Internet or intranet, send and receive e-mail and instant mes-
sages, and synchronize information using ActiveSync. Connections can be 
made using a wireless network.

Your CN2B Computer has two groups of connection settings: My ISP and 
My Work Network. Use My ISP settings to connect to the Internet. Use 
My Work Network settings to connect to any private network.

• My ISP: Once connected, you can send and receive e-mail messages by 
using Inbox and view Web or WAP pages by using Pocket Internet 
Explorer. The communication software for creating an ISP connection is 
already installed on your CN2B Computer. Your service provider pro-
vides the software needed to install other services, such as paging and fax 
services. If this is the method you want to use, see “Connecting to an 
Internet Service Provider (ISP)” on page 101.
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• My Work Network: Connect to the network at your company or organi-
zation where you work. Once connected, you can send and receive e-
mail messages by using Inbox, view Web or WAP pages by using Pocket 
Internet Explorer, and synchronize with your desktop. If this is the 
method you want to use, see “Connecting to Work” on page 103.

Connecting to an Internet Service Provider (ISP)
You can connect to your ISP, and use the connection to send and receive e-
mail messages and view Web or WAP pages.

Obtain your ISP dial-up access telephone number, user name, and pass-
word from your ISP. Some ISPs require information in front of the user 
name, such as MSN/username.
To view additional information for any screen in the wizard or while 
changing settings, tap the Help icon.

1 Tap Start > Settings > the Connections tab > the Connections icon. In 
My ISP, tap Add a new modem connection. 

2 Enter a name for the connection, such as “ISP Connection.” 

If using an external modem connected to your CN2B Computer with a 
cable, select “Hayes Compatible on COM1” from the Select a modem 
list. Tap Next to continue. 
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3 Enter the access phone number, then tap Next. 

4 Enter the user name, password, and domain (if provided by an ISP or 
your network administrator), then tap Finish. 

5 Tap the Advanced tab from the Connections screen, then tap Select 
Location to specify your current location. These settings apply to all con-
nections. Tap Use dialing rules, tap OK, then tap Edit to continue. 

6 Specify your current phone type. If your phone type is pulse dialing, 
check the Pulse dialing box. If your type is tone dialing (as most phone 
lines are), then clear the Pulse dialing box. Continue to tap ok to close 
each page and return to the Settings page.
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To start the connection, start using one of the following programs. Once 
connected, you can:

• Send and receive e-mail messages by using Inbox. Before you can use 
Inbox, you need to provide the information it needs to communicate 
with the e-mail server.

• Visit Web and WAP pages by using Pocket Internet Explorer. For more 
information, see “Pocket Internet Explorer” on page 68.

• Send and receive instant messages with MSN Messenger. For more 
information, see “MSN Messenger” on page 62.

Note: To change modem connection settings in My ISP, tap Manage 
existing connections. Select the desired modem connection, tap Settings, 
and follow the instructions on the screen.

Connecting to Work
If you have access to a network at work, you can send e-mail messages, view 
intranet pages, synchronize your CN2B Computer, and possibly access the 
Internet. You can connect to work by creating a modem connection via a 
RAS (Remote Access Server) account. Before you can create this modem 
connection, your network administrator needs to set up a RAS account for 
you. Your network administrator may also give you Virtual Private Net-
work (VPN) settings.
Note: To change modem connection settings in My Work Network, tap 
Manage existing connections. Select the desired modem connection, tap 
Edit, and follow the instructions on the screen.

To view additional information for any screen in the wizard or while 
changing settings, tap the Help icon.
CN2B Mobile Computer User’s Manual 103



Chapter 4 — Network Support
1 Tap Start > Settings > the Connections tab > the Connections icon. In 
My Work Network, tap Add a new modem connection. 

2 Enter a name for the connection, such as “Company Connection.” In 
the Select a modem list, select your modem type, then tap Next to con-
tinue. If your modem type does not appear, try reinserting your CN2B 
Computer into your CN2B Modem Dock.

• If using an external modem connected to your CN2B Computer with 
a cable, select “Hayes Compatible on COM1.”

• If using any type of external modem, select the modem by name. If a 
listing does not exist for your external modem, select “Hayes Compat-
ible on COM1.”

• Wireless connections can be made via a mobile phone network or 
GPRS. If using a mobile phone network to connect, select “Cellular 
Line.” If using GPRS, tap “Cellular Line (GPRS).” 

3 Enter the access phone number, using some of the following guidelines. 
If you know part of the phone number changes frequently as you travel, 
create dialing rules to avoid creating numerous modem connections for 
the same phone number. For more information, tap Use Dialing Rules.

• Enter the phone number exactly as you want it dialed. For example, if 
you call from a business complex or hotel that requires a nine before 
dialing out, enter “9” in front of the phone number.
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• Enter the APN provided by your mobile phone service provider.

• When using dialing rules, phone numbers are entered differently. To 
use additional numbers, such as a “9” to dial from an office complex 
or hotel, you must use additional dialing rules or change dialing pat-
terns. See “Create Dialing Rules” via the online help for information.

a In the Country/Region box, enter the appropriate code when dialing 
internationally. For more information, contact an operator at your 
local phone company.

b In the Area code box, enter the area code, if needed.

c Enter the main phone number, then tap Next to continue. 

4 Enter the user name, password, and domain (if provided by an ISP or 
your network administrator). If a domain name was not provided, try 
the connection without entering a domain name, then tap Finish. 

Creating a VPN Server Connection to Work
A VPN connection helps you to securely connect to servers, such as a cor-
porate network, via the Internet. Ask your network administrator for the 
user name, password, domain name, TCP/IP settings, and host name or IP 
address of the VPN server.
To view additional information for any screen in the wizard or while 
changing settings, tap the Help icon.
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Note: To change existing settings in My Work Network, tap Manage 
existing connections > the VPN tab. Select the desired VPN connection, 
tap Settings, and follow the instructions on the screen.

1 Tap Start > Settings > the Connections tab > the Connections icon. 
Tap Add a new VPN server connection beneath My Work Network to 
initiate this procedure. 

2 In Name, enter a name for the connection, such as a company’s name.

In Host name/ IP, enter the VPN server name or IP address. 

Next to VPN type, select the type of authentication to use with your 
device: “IPSec/L2TP” or “PPTP.” If you are not sure which option to 
choose, ask your network administrator. Tap Next to continue. 

3 Select the type of authentication. If you select A pre-shared key, enter 
the key provided by your network administrator.
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4 Enter your user name, password, and domain name as provided by your 
ISP or network administrator. If a domain name was not provided, try 
the connection without entering a domain name. 

5 You should not need to change any Advanced settings. Instances where 
to change advanced settings include the server to which you are connect-
ing does not use dynamically-assigned addresses, and you need to enter 
your TCP/IP settings; or to change server DNS or WINS settings.

To change advanced settings, tap Advanced. Otherwise, tap Finish. 
Insert necessary equipment, such as a network card, into the device, and 
use a desired program to automatically begin connecting.

Ending a Connection
• When connected via modem or VPN, tap the Connectivity icon on the 

navigation bar, then tap Disconnect.

• When connected via cable or cradle, detach your device.

• When connected via Infrared, move away from other computers.

• When connected via a wireless network, switch off the connection.
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Management
Use the following tool and information to configure and manage your net-
work. You can also contact your Intermec representative for support.

SmartSystems™ Foundation Console (www.intermec.com/SmartSystems)
This tool, available as a free download from Intermec, includes a manage-
ment console that provides a default method to configure and manage 
Intermec devices “out-of-the-box,” without the purchase of additional soft-
ware licenses. This is for anyone who must configure and deploy multiple 
devices or manage multiple licenses.

Use the Intermec Settings applet to gather, view, and update device config-
uration settings within the SmartSystems Foundation. Information about 
the settings you can configure with the Intermec Settings applet is in the 
Intermec Computer Command Reference Manual (P/N: 073529) available 
online at www.intermec.com.

Information about the SmartSystems Foundation is available as an online 
help within the SmartSystems Console application. Select SmartSystems > 
Help in the console to access the manual.

See the Data Collection Resource Kit in the IDL for information about 
data collection functions. The IDL is available as a download from the 
Intermec web site at www.intermec.com/idl. Contact your Intermec repre-
sentative for more information. 
Tap Start > Settings > the System tab > the Intermec Settings icon, then 
tap to expand the SmartSystems Information option. 

SNMP Configuration on the Mobile Computer
In short, SNMP is an application-layer protocol that uses the exchange of 
management information between network devices. The CN2B Computer 
is such an SNMP-enabled device. Use SNMP to control and configure the 
CN2B Computer anywhere on an SNMP-enabled network.

The CN2B Computer supports four proprietary Management Information 
Bases (MIBs) and Intermec provides SNMP support for MIB-II through 
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seven read-only MIB-II (RFC1213-MIB) Object Identifiers (OIDs). Note 
that you can query these seven OIDs through an SNMP management station.

Management Information Base
The Management Information Base is a database that contains information 
about the elements to be managed. The information identifies the manage-
ment element and specifies its type and access mode (Read-Only, Read-
Write). MIBs are written in ASN.1 (Abstract Syntax Notation.1) — a 
machine independent data definition language. Note: Elements to manage 
are represented by objects. The MIB is a structured collection of such objects. 

You will find the following MIB files either in the CN2B Management 
Tools or on the web via www.intermec.com:

• INTERMEC.MIB 
Defines the root of the Intermec MIB tree.

• ITCADC.MIB 
Defines objects for Automated Data Collection (ADC).

• ITCSNMP.MIB 
Defines objects for Intermec SNMP parameters and security methods, 
such as an SNMP security IP address.

• ITCTERMINAL.MIB 
Defines objects for parameters, such as key clicks.

Object Identifiers
Each object has a unique identifier called an OID, which consist of a 
sequence of integer values represented in dot notation. Objects are stored in 
a tree structure and OIDs are assigned based on the position of the object 
in the tree. For example, the internet OID is equal to 1.3.6.1. Seven MIB 
OIDs are shown in the following table:

MIB Object Identifiers

MIB-II Item OID Group or Table Description

ifNumber 1.3.6.1.2.1.2.1.0 Interfaces Group Indicates the number of adapters 
present in the system. For the 
CN2B Computer, if one adapter 
is present in the system, then 
ifNumber = 1 and ifIndex = 1.

ifIndex 1.3.6.1.2.1.2.2.1.1.ifIndex Interfaces Table (ifTable) A unique value for each interface. 
The value ranges between 1 and 
the value of ifNumber.

ifDescr 1.3.6.1.2.1.2.2.1.2.ifIndex Interfaces Table (ifTable) A textual string containing infor-
mation about the interface.

ifType 1.3.6.1.2.1.2.2.1.3.ifIndex Interfaces Table (ifTable) An integer containing informa-
tion about the type of the inter-
face. It is equal to 1 for Other.
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Configuring with SNMP
The community string allows an SNMP manager to manage the CN2B 
Computer with a specified privilege level. The default read-only or read/
write community string is “public” and “private.” See the specific configu-
ration parameter for its OID.

1 Configure CN2B Computers for RF or Ethernet communications.

2 Determine the OID (Object Identifier) for the parameter to change. The 
Intermec base OID is 1.3.6.1.4.1.1963.

3 Use your SNMP management station to get and set variables that are 
defined in the Intermec MIBs. You can set the traps, identification, or 
security configuration parameters for SNMP.

ipAdEntAddr 1.3.6.1.2.1.4.20.1.1.IpAddress IP address Table 
(ipAddrTable)

The IP address to which this 
entry’s addressing information 
pertains (same as CN2B IP 
address), where IP Address is the 
valid non-zero IP address of the 
CN2B Computer.

ipAdEntIfIndex 1.3.6.1.2.1.4.20.1.2.IpAddress IP address Table 
(ipAddrTable)

Index value that uniquely identi-
fies the interface that this entry is 
applicable (same as ifIndex).

ipAdEntNetMask 1.3.6.1.2.1.4.20.1.3.IpAddress IP address Table 
(ipAddrTable)

The subnet mask associated with 
the IP address of this entry (same 
as Subnet Mask).

MIB Object Identifiers

MIB-II Item OID Group or Table Description
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The CN2B Mobile Computer works with the following printers from 
Intermec. Contact an Intermec representative for information about these 
printers.

• 6820 Portable or Fixed Mount 80-Column Printer

• PB20 2” Belt-Mount Printer 
with a Bluetooth compatible module from Socket Communications

• PB40 4” Belt-Mount Printer 
with a Bluetooth compatible module from Socket Communications

• PB42 4” Printer
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Printing ASCII
The methods for printing using Pocket PC at this time are as follows:

• Add port drivers to print ASCII directly to the port.

• Use LinePrinter ActiveX Control from the Printing Resource Kit via the 
Intermec Developer Library (IDL) available as a download from the 
Intermec webs site at www.intermec.com/idl. Contact your Intermec 
representative for more information.

• Via wireless printing - see the Bluetooth Resource Kit User’s Guide for more 
information.

Directly to a Port
Printing directly to the port sends RAW data to the printer. The format of 
this data depends upon your application and the printer capabilities.

You must understand the printer commands available for your specific 
printer. Generally, applications just send raw ASCII text to the printer. 
Since you are sending data to the printer from your application directly to 
the port you are in complete control of the printers operations. This allows 
you to do line printing (print one line at a time) rather than the page format 
printing offered by the GDI approach. It is also much faster since data does 
not have to be converted from one graphics format to the other (display to 
printer). Most Intermec printers use Epson Escape Sequences to control 
print format operations.

These commands are available in documentation you receive with your 
printers or from technical support. Win32 APIs are required to print 
directly to the port.

Directly to a Generic Serial Port
To print directly to a generic serial port printer (non-Intermec printers):

• Use CreateFile() to open ports — COM1 can open on most devices.

• Use WriteFile() to send data directly to the printer.

• Use CloseHandle() when you are finished printing to close the port.

NPCP Printer Driver
The NPCP printer communications driver (NPCPPORT.DLL) is a 
Stream Device Driver built into the operating system. The driver supports 
only NPCP communications to and from the 6820 Printers over a selected 
serial port.

All applications use WIN32 API functions to access the drivers. Basic oper-
ations are easily implemented by applications through the CreateFile(), 
WriteFile(), ReadFile(), DeviceIOControl(), and CloseHandle() Win32 
APIs.
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Operations to upgrade printer modules, perform printer diagnostics, and 
get printer configuration are performed largely via DeviceIOControl() 
functions.

About NPCP
NPCP (Norand® Portable Communications Protocol) is a proprietary pro-
tocol that provides session, network, and datalink services for Intermec 
mobile computers in the Intermec LAN environment used with printers 
and data communications.

NPCP Driver Installation and Removal
Use LPT9: for the NPCP printer device and COM1 for the last parameter. 
COM1 is the connection available via the CN2B Computer.

Applications use the RegisterDevice() function to install the driver. Dereg-
isterDevice() uninstalls the device driver and frees memory space when the 
driver is not required. Use the HANDLE returned by RegisterDevice() as 
the parameter to DeregisterDevice().

Use the RegisterDevice() function call as demonstrated below. Specify the 
full path name to the driver starting at the root for the RegisterDevice() 
function to work properly. The last parameter to RegisterDevice() is a 
DWORD that represents the name of the port for the NPCP stream driver 
to use. Build this parameter on the stack if it is not to be paged out during 
the call. The first parameter “LPT” (Device Name) and the second parame-
ter “9” (index), indicate the name of the registered device, such as LPT9. 
This is used in the CreateFile() function call.

Install() 
{ 
HANDLE hDevice; 
TCHAR port[6]; 
port[0] = TCHAR(‘C’); 
port[1] = TCHAR(‘O’); 
port[2] = TCHAR(‘M’); 
port[3] = TCHAR(‘1’); 
port[4] = TCHAR(‘:’); 
port[5] = TCHAR(0); 
hDevice = RegisterDevice ( (TEXT(”LPT”), 9,  
TEXT(“\\STORAGE CARD\\WINDOWS\\NPCPPORT.dll”), (DWORD)port); 
}

Opening the NPCP Driver
The application opens the NPCP driver by using the CreateFile() function. 
The call can be implemented as follows. The first parameter “LPT9:” must 
reflect the device name and index used in the RegisterDevice() function call 
and will fail for any of the following reasons:

hFile = CreateFile(_T(”LPT9:”), GENERIC_WRITE | 
GENERIC_READ, 0, NULL, OPEN_ALWAYS, FILE_ATTRIBUTE_NORMAL, 
NULL);
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• The port associated with the device during RegisterDevice() is in use.

• The NPCP device is already open.

• The share mode is not set to zero. The device cannot be shared.

• Access permissions are not set to GENERIC_WRITE | 
GENERIC_READ. Both modes must be specified.

Closing the NPCP Driver
Using the CloseHandle() (hFile) function closes the NPCP driver. Where 
hFile is the handle returned by the CreateFile() function call.

• TRUE = the device is successfully closed.

• FALSE = an attempt to close NULL HANDLE or an already closed 
device.

Reading from the NPCP Driver
Reading of the NPCP printers is not supported since all responses from the 
printer are the result of commands sent to the printer. DeviceIoControl() 
functions are provided where data is to be received from the printer.

Writing to the NPCP Driver
All Print data can be sent to the printer using the WriteFile() function. The 
print data written to the driver must contain the proper printer commands 
for formatting. If the function returns FALSE, the NPCP error may be 
retrieved using IOCTL_NPCP_ERROR. See the description on the next 
page.

NPCP Driver I/O Controls
An application uses the DeviceIoControl() function to specify an printer 
operation to perform. Certain I/O controls are required to bind and close 
communication sessions with the printer, and must be completed before 
any other commands to the driver can execute properly.

The function returns TRUE to indicate the device successfully completed 
its specified I/O control operation, otherwise it returns FALSE. The follow-
ing I/O control codes are defined:

#define IOCTL_NPCP_CANCEL 
CTL_CODE(FILE_DEVICE_SERIAL_PORT,0x400,METHOD_BUFFERED,FILE_ANY_ACCESS)

#define IOCTL_NPCP_BIND 
CTL_CODE(FILE_DEVICE_SERIAL_PORT,0x401,METHOD_BUFFERED,FILE_ANY_ACCESS)

#define IOCTL_NPCP_CLOSE 
CTL_CODE(FILE_DEVICE_SERIAL_PORT,0x402,METHOD_BUFFERED,FILE_ANY_ACCESS)

#define IOCTL_NPCP_ERROR 
CTL_CODE(FILE_DEVICE_SERIAL_PORT,0x403,METHOD_BUFFERED,FILE_ANY_ACCESS)

#define IOCTL_NPCP_FLUSH 
CTL_CODE(FILE_DEVICE_SERIAL_PORT,0x404,METHOD_BUFFERED,FILE_ANY_ACCESS)
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#define IOCTL_NPCP_IOCTL 
CTL_CODE(FILE_DEVICE_SERIAL_PORT,0x405,METHOD_BUFFERED,FILE_ANY_ACCESS)

#define IOCTL_NPCP_PRTVER 
CTL_CODE(FILE_DEVICE_SERIAL_PORT,0x406,METHOD_BUFFERED,FILE_ANY_ACCESS) 

• IOCTL_NPCP_CANCEL 
This cancels all printing at the printer. It flushes the printer buffers and 
re initializes the printer to its default state. No parameters are required.

• IOCTL_NPCP_BIND 
This command is required before any data is sent or received by the 
printer. Once the driver is opened, the application must bind the com-
munications session with the printer before any data can be sent or 
received by the printer. If an error occurs during the bind, the applica-
tion may use IOCTL_NPCP_ERROR to get the current extended error 
code. No parameters are required.

• IOCTL_NPCP_CLOSE 
This command closes the current session with the printer. This function 
always returns TRUE. No parameters are required.

• IOCTL_NPCP_ERROR 
This command returns the extended NPCP error code in PL/N format. 
The word returned will contain the PL/N compatible error code in the 
low byte and completion flags in the high byte. If the frame that 
returned an error was not received correctly by the printer the 
FRAME_NOT_ACKED bit is set in the high byte. This operation 
always returns TRUE. An output buffer of at least two bytes is required. 
See “NPCP Error Codes” on page 116.

• IOCTL_NPCP_FLUSH 
This command allows the application to poll the printer for errors while 
the report is completing the print process at the printer. If an error 
occurs during the polling process, the operation will return FALSE and 
the application can get the extended error code by using 
IOCTL_NPCP_ERROR. No parameters are required.

NPCP Printer Communications
All NPCP printer communications should be based on the following flow:

1 Use CreateFile(); to open the printer driver.

2 Use IOCTL_NPCP_BIND to bind a session with the printer; 
IOCTL_NPCP_ERROR to check for errors on the bind to ensure suc-
cess; and IOCTL_NPCP_CANCEL to cancel outstanding print jobs.

3 Use IOCTL_NPCP_FLUSH to poll the printer to free up printer buffer 
resources. Use IOCTL_NPCP_FLUSH to poll the printer’s status. If an 
error is reported by the IOCTL, then use IOCTL_NPCP_ERROR to 
get the error and determine the correct recovery procedure.
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4 Use WriteFile(); to write your data to the printer. Check for errors and 
that all data were written. Use IOCTL_NPCP_ERROR to get the 
extended error. If the error is critical in nature, use 
IOCTL_NPCP_CLOSE, followed by CloseFile(), to end the communi-
cations session. Start a new session, beginning with step 1 to ensure 
proper printing. For noncritical errors display the error and retry the 
operation.

5 After all data is sent to the printer, ensure that the printer continues to 
print the report properly by polling the printer’s status. Use 
IOCTL_NPCP_FLUSH to poll the printer’s status. If an error is 
reported by the IOCTL, then use IOCTL_NPCP_ERROR to get the 
error and determine the correct recovery procedure.

Sample Code
See sample code in the “\CN2B Dev Tools\Installable Drivers\Port Driv-
ers\Npcp\NPCPPrint\” directory for more details on printing, printer com-
munications and error code handling.

NPCP Error Codes
Call the IOCTL_NPCP_ERROR I/O control function to receive PL/N 
compatible error codes. Applications must decide how to act upon the data 
returned.

// Definition of NPCP communications Errors and Printer Errors 
#define PNRDY (BYTE)102 // link not ready error 
#define RXTMO (BYTE)104 // link no receive error 
#define TXTMO (BYTE)106 // link no transmit error 
#define BADADR (BYTE)111 // frame address error 
#define GAPERR (BYTE)112 // link gap error (timeout) in receive data 
#define LSRPE (BYTE)113 // frame parity error on length field 
#define IFTS (BYTE)120 // session layer - invalid frame this state 
#define NS_NE_VR (BYTE)121 // session layer sequence error 
#define NR_NE_VS (BYTE)122 // session layer sequence error 
#define MAC_CRCERR (BYTE)124 // MAC CRC error 
#define RLENERR (BYTE)123 // MAC too much data received 
#define FRMERR (BYTE)200 // Frame Reject  
#define FRMERR_IF (BYTE)201 // Frame Reject - Invalid Frame 
#define FRMERR_NR (BYTE)202 // Frame Reject - NR Mismatch 
#define FRMERR_NS (BYTE)203 // Frame Reject - NS Mismatch 
#define NDMERR (BYTE)204 // Normal Disconnect mode error 
#define BINDERR (BYTE)210 // bind error  
#define IPLDUR (BYTE)221 // invalid presentation layer response 
#define HEADJAM (BYTE)222 // printer head jam 
#define PAPEROUT (BYTE)223 // printer paper out 
#define LOWVOLTS (BYTE)224 // printer low voltage  
#define HIVOLTS (BYTE)225 // printer over voltage 
#define LOWBAT (BYTE)226 // printer low battery  
#define COVEROFF (BYTE)227 // printer cover off error 
#define HEADFAULT (BYTE)228 // printer head short or driver short error 
#define PFFAULT (BYTE)229 // paper feed motor fault. 
#define FRAME_NOT_ACKED 0x8000 // frame was not received by printer and need to 
be resent.
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O’Neil Printer Driver
The DTR printer communications driver is a Stream Device Driver named 
ONEIL.DLL.

All applications use WIN32 API functions to access drivers. Basic opera-
tions are easily implemented by applications through the CreateFile(), 
WriteFile(), DeviceIOControl() and CloseHandle() Win32 APIs.

The driver supports communications to PB20, PB40, and PB42 printers 
over a selected serial port.

DTR Driver Installation and Removal
Your application must install the device driver by using the RegisterDe-
vice() function. The driver name is ONEIL.DLL. We recommend that you 
use “DTR” for the Device Name parameter, “1” for the Device Driver 
index parameter, and use any of the following strings for the last parameter:

• NULL (==0) Defaults to COM1 @ 9600

• “COM1” only COM port specified defaults to 9600

• “COM1:9600” sets to COM port and specified bit rate

• “COM1:19200” sets to COM port and specified bit rate

Use the HANDLE returned by RegisterDevice() as the parameter to Dereg-
isterDevice(). The correct usage of the RegisterDevice() function call is 
demonstrated below. You may use DeregisterDevice() to uninstall the 
driver.

Install() 
{ 
 
HANDLE hDevice; 
TCHAR port[6]; 
port[0] = TCHAR(‘C’); 
port[1] = TCHAR(‘O’); 
port[2] = TCHAR(‘M’); 
port[3] = TCHAR(‘1’); 
port[4] = TCHAR(‘:’); 
port[5] = TCHAR(0); 
hDevice = RegisterDevice ( (TEXT(”DTR”), 1, TEXT(”\\WINDOWS\\ONEIL.DLL”), 
(DWORD)port); 
 
}

Opening the DTR Driver
The application opens the DTR driver by using the CreateFile() function. 
The call can be implemented as follows:

hFile = CreateFile(_T(”DTR1:”), GENERIC_WRITE, 0, NULL, 
OPEN_ALWAYS, FILE_ATTRIBUTE_NORMAL, NULL);
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The first parameter “DTR1:” must reflect the device name and index used 
in the RegisterDevice() function call.

The function call will fail for any of the following reasons:

• The port associated with the device during RegisterDevice() is currently 
in use.

• The DTR device is already open.

• The share mode is not set to zero. The device cannot be shared.

• Access permissions are not set to GENERIC_WRITE.

Closing the DTR Driver
Using the CloseHandle() (hFile) function closes the DTR driver. Where 
hFile is the handle returned by the CreateFile() function call.

• TRUE indicates the device is successfully closed.

• FALSE indicates an attempt to close a NULL HANDLE or an already 
closed device.

Writing to the DTR Driver
You can use the WriteFile() function to send all Print data to the printer. 
The print data being written must contain the proper formatting printer 
commands.

DTR Printer Communications
All DTR printer communications should be based on the following flow:

1 Use CreateFile() to open the printer driver.

2 Use WriteFile() to write your data to the printer. Check for errors and 
that all data were written.

3 Use CloseHandle() to close the driver.
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Configuring PB42 Printers Via Intermec Settings
Tap Start > Settings > the System tab > the Intermec Settings icon to 
access the applet. Tap (+) to expand the Printers option, then tap (+) to 
expand the PB42 Settings option and make your adjustments. 
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6Scanner Support

The CN2B Mobile Computer is available with linear imaging technologies, 
such as the APS Linear Imager, which includes the EV10 Scan Engine. 

The APS Imager reads 1D symbologies and PDF417 bar codes. Linear 
imaging using Vista Scanning technologies reads low-contrast bar codes, 
laminated bar codes, and bar codes displayed on CRT or TRT displays. 
This imaging uses harmless LEDs for illumination and does not require any 
warning labels. Vista Scanning is more reliable than lasers as it is a com-
pletely solid state with no moving parts or oscillating mirrors.

An ImageDemo application shows the more common features of the 
CN2B Computer imager. See the ImageDemo User’s Guide for information.
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Scanner Control and Data Transfer
Note: To use these methods, enable the Data Collection functionality on 
the CN2B Computer using the bootloader configuration menu.

The Data Server and associated software provide several ways to manipulate 
scanner control and data transfer between the scanner subsystem and user 
applications:

• Automatic Data Collection COM Interfaces: 
These COM interfaces allow user applications to receive bar code data, 
and configure and control the bar code reader engine.

• ITCAxBarCodeReaderControl functions: 
These ActiveX controls allow user applications to collect bar code data 
from the scanner, to configure the scanner, and to configure audio and 
visual notification when data arrives. 

• ITCAxReaderCommand functions: 
Use these ActiveX controls to modify and retrieve configuration infor-
mation using the reader interface commands. 

• Scanning EasySet bar code labels: 
You can use the EasySet bar code creation software from Intermec to 
print configuration labels. Scan the labels to change the scanner configu-
ration and data transfer settings.

Use the Intermec EasySet software to print configuration labels you can 
scan to change your configuration settings. For more information, see 
the EasySet online help. EasySet is available from the Intermec Data 
Capture web site.

For more information, see the Data Collection Resource Kit in the Inter-
mec Developer Library (IDL), which is available as a download from the 
Intermec web site at www.intermec.com/idl. Contact your Intermec repre-
sentative for more information.

Data Collection Configuration
You can configure scanner settings for the CN2B Computer via the Inter-
mec Settings applet. From the CN2B Computer, tap Start > Settings > the 
System tab > the Intermec Settings icon. See the Intermec Computer Com-
mand Reference Manual (P/N: 073529) for information about the settings 
you can configure with this applet. This online manual is available from the 
Intermec web site at www.intermec.com.
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Internal Scanners
The Intermec Internal Scanner feature allows Automatic Data Collection 
(ADC) by accepting data from the COM1 port and wedging it into the 
keyboard interface. You can enable or disable this feature from the Today 
screen on the CN2B Computer.

Do the following from the Intermec Settings applet. Information about the 
settings you can configure with this applet is described in the Intermec 
Computer Command Reference Manual. The online manual is available from 
the Intermec web site at www.intermec.com.
1 From the CN2B Computer, tap Start > Settings > the System tab > the 

Intermec Settings icon. 

2 Tap the Data Collection option, then tap (+) to expand Internal Scan-
ner. This sample screen is for the EV10 scanner model. 

Linear Imager Settings
Depending on what is selected as the scanner model, image settings, decode 
security, and virtual wedge are configured from the Intermec Settings 
applet. See the the Intermec Computer Command Reference Manual, avail-
able from the Intermec web site at www.intermec.com, for more informa-
tion about each enabled option.
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Internal Scanner Supported Symbologies
The EV10 Scanner supports these symbologies:

Code 39, UPC/EAN, Code 128, Interleaved 2 of 5, Code 93, Codabar, 
Standard 2 of 5, MSI, Plessey, Code 11, Matrix 2 of 5, Telepen, RSS, 
Vest Code 39, ISBT 128, Code 93i

The EV10 also supports the following stacked symbologies:

PDF 417, Micro PDF, Macro PDF, Codablock, RSS

Reading Distances
Typical reading distances are done in an office environment using office 
lights (4 lux). Minimum distances are measured in the dark (0 lux). Both 
reading distances are provided in respective scan engine integration guides. 
Contact your Intermec representative for more information.

Below are the minimum standard reading distances for the CN2B Com-
puters built with the EV10 integrated scan engine. When correctly 
mounted, an exit window reduces reading distances by about 4%.

EV10 Minimum Reading Distances with 0.04” Setbacks

Symbology Bar Code Content Density Minimum 
Distances

Maximum 
Distances

Code 39 RESO 0.100 MM 
R 0.125 MM 
0.25 
.5 
R1MM

0.1mm/ 4 mil 
0.125 mm/ 5 mil 
0.25 mm/ 10 mil 
0.5 mm/ 20 mil 
1 mm/ 40 mil

6.25 cm/ 4.26” 
9.80 cm/ 3.86” 
5.99 cm/ 2.36” 
3.96 cm/ 1.56” 
7.53 cm/ 2.96”

13.87 cm/ 5.46” 
16.92 cm/ 6.66” 
23.77 cm/ 9.36” 
30.89 cm/ 12.16” 
39.78 cm/ 15.66”

UPC/EAN 120010010100 0.33 mm/ 13 mil 4.98 cm/ 1.96” 25.81 cm/ 10.16”

PDF417 10 mil 
15 mil

0.254 mm/ 10 mil 
0.381 mm/ 15 mil

9.80 cm/ 3.86” 
7.77 cm/ 3.06”

16.92 cm/ 6.66” 
18.95 cm/ 7.46”
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7Programming

The following programming information pertains to the CN2B Mobile 
Computer:

• Creating CAB Files  (page 126)

• Customization and Lockdown  (page 140)

• FTP Server  (page 141)

• Kernel I/O Controls  (page 150)

• Network Selection APIs  (page 161)

• Notifications  (page 181)

• Reboot Functions  (page 182)

• Remapping the Keypad  (page 182)
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Creating CAB Files
The Windows CE operating system uses a .CAB file to install an applica-
tion on a Windows CE-based device. A .CAB file is composed of multiple 
files that are compressed into one file. Compressing multiple files into one 
file provides the following benefits:

• All application files are present.

• A partial installation is prevented.

• The application can be installed from several sources, such as a desktop 
computer or a Web site.

Use the CAB Wizard application (CABWIZ.EXE) to generate a .CAB file 
for your application.

Creating Device-Specific CAB Files
Do the following to create a device-specific .CAB file for an application, in 
the order provided:

1 Create an .INF file with Windows CE-specific modifications (see below).

2 Optional Create a SETUP.DLL file to provide custom control of the 
installation process (page 136).

3 Use the CAB Wizard to create the .CAB file, using the .INF file, the 
optional SETUP.DLL file, and the device-specific application files as 
parameters (page 139).

Creating an .INF File
An .INF file specifies information about an application for the CAB Wiz-
ard. Below are the sections of an .INF file:

[Version]
This specifies the file creator, version, and other relevant information.

Required? Yes

• Signature: “signature_name” 
“$Windows NT$”

• Provider: “INF_creator” 
The company name of the application, such as “Microsoft.”

• CESignature 
“$Windows CE$”

Example
[Version] 
Signature = “$Windows NT$” 
Provider = “Intermec” 
CESignature = “$Windows CE$”
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[CEStrings]
This specifies string substitutions for the application name and the default 
installation directory.

Required? Yes

• AppName: app_name 
Name of the application. Other instances of %AppName% in the .INF 
file are replaced with this string value, such as RP32.

• InstallDir: default_install_dir 
Default installation directory on the device. Other instances of %Install-
Dir% in the .INF file are replaced with this string value. Example: 
\SDMMC_Disk\%AppName%

Example
[CEStrings] 
AppName=“Game Pack” 
InstallDir=%CE1%\%AppName%

[Strings]
This section is optional and defines one or more string keys. A string key 
represents a string of printable characters.

Required? No

• string_key: value 
String of letters, digits, or other printable characters. Enclose value in 
double quotation marks ““”” if the corresponding string key is used in an 
item that requires double quotation marks. No string_keys is okay.

Example
[Strings] 
reg_path = Software\Intermec\My Test App

[CEDevice]
Describes the targeted application platform. All keys are optional. If a key is 
nonexistent or has no data, Windows CE does not perform any checking 
with the exception being UnsupportedPlatforms. If the UnsupportedPlatforms 
key exists but no data, the previous value is not overridden.

Required? Yes

• ProcessorType: processor_type 
The value that is returned by SYSTEMINFO.dwProcessorType.For 
example, the value for the ARM CPU is 2577

• UnsupportedPlatforms: platform_family_name 
This lists known unsupported platform family names. If the name speci-
fied in the [CEDevice.xxx] section is different from [CEDevice], both 
platform_family_name values are unsupported for the microprocessor 
specified by xxx. The unsupported platform family names list is 
appended to the previous list. Application Manager does not display the 
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application for an unsupported platform. Also, a user is warned during 
the setup process if the .CAB file is copied to an unsupported device.

Example
[CEDevice] 
UnsupportedPlatforms = pltfrm1 ; pltfrm1 is unsupported 
[CEDevice.SH3] 
UnsupportedPlatforms = ; pltfrm1 is still unsupported

• VersionMin: minor_version 
Numeric value returned by OSVERSIONINFO.dwVersionMinor. The 
.CAB file is valid for the currently connected device if the version of this 
device is greater than or equal to VersionMin.

• VersionMax: major_version 
Numeric value returned by OSVERSIONINFO.dwVersionMajor. The 
.CAB file is valid for the currently connected device if the version of this 
device is less than or equal to VersionMax.

• BuildMin: build_number 
Numeric value returned by OSVERSIONINFO.dwBuildNumber. The 
.CAB file is valid for the currently connected device if the version of this 
device is greater than or equal to BuildMin.

• BuildMax: build_number 
Numeric value returned by OSVERSIONINFO.dwBuildNumber. The 
.CAB file is valid for the currently connected device if the version of this 
device is less than or equal to BuildMax.

Example
This shows three [CEDevice] sections: one giving basic information for any 
CPU and two specific to the SH3 and the MIPS microprocessors.

[CEDevice] ; A “template” for all platforms 
UnsupportedPlatforms = pltfrm1; Does not support pltfrm1 
 
; The following specifies version 1.0 devices only. 
VersionMin = 1.0 
VersionMax = 1.0 
 
[CEDevice.ARM]; Inherits all [CEDevice] settings 
; This will create a .CAB file specific to ARM devices. 
ProcessorType = 2577; ARM .cab file is valid for ARM microprocessors. 
UnsupportedPlatforms = ; pltfrm1 is still unsupported 
 
; The following overrides the version settings so that no version checking is 
performed. 
VersionMin = 
VersionMax = 
 
[CEDevice.MIPS] ; Inherits all [CEDevice] settings 
; This will create a .CAB file specific to “MIPS” devices. 
ProcessorType = 4000; MIPS .CAB file is valid for MIPS microprocessor. 
UnsupportedPlatforms =pltfrm2; pltfrm1, pltfrm2 unsupported for MIPs .CAB 
file.
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Note: To create the two CPU-specific .CAB files for the SETUP.INF file 
in the previous example, run the CAB Wizard with the “/cpu arm mips” 
parameter.

[DefaultInstall]
This describes the default installation of your application. Note that under 
this section, you will list items expanded upon later in this description.

Required? Yes

• Copyfiles: copyfile_list_section 
Maps to files defined later in the .INF file, such as Files.App, Files.Font, 
and Files.Bitmaps.

• AddReg: add_registry_section 
Example: RegSettings.All

• CEShortcuts: shortcut_list_section 
String that identifies one more section that defines shortcuts to a file, as 
defined in the [CEShortcuts] section.

• CESetupDLL: setup_DLL 
Optimal string that specifies a SETUP.DLL file. It is written by the 
Independent Software Vendor (ISV) and contains customized functions 
for operations during installation and removal of the application. The 
file must be specified in the [SourceDisksFiles] section.

• CESelfRegister: self_reg_DLL_filename 
String that identifies files that self-register by exporting the DllRegis-
terServer and DllUnregisterServer Component Object Model (COM) 
functions. Specify these files in the [SourceDiskFiles] section. During 
installation, if installation on the device fails to call the file’s exported 
DllRegisterServer function, the file’s exported DllUnregisterServer 
function is not called during removal.

Example
[DefaultInstall] 
AddReg = RegSettings.All 
CEShortcuts = Shortcuts.All

[SourceDiskNames]
This section describes the name and path of the disk on which your appli-
cation resides.

Required? Yes

• disk_ordinal: disk_label,,path 
1=,“App files” , C:\Appsoft\RP32\... 
2=,“Font files”,,C:\RpTools\... 
3=,“CE Tools” ,,C:\windows ce tools...

• CESignature: “$Windows CE$”
CN2B Mobile Computer User’s Manual 129



Chapter 7 — Programming
Example
[SourceDisksNames]; Required section  
1 = ,“Common files”,,C:\app\common; Using an absolute path 
[SourceDisksNames.SH3] 
2 = ,“SH3 files”,,sh3; Using a relative path 
[SourceDisksNames.MIPS] 
2 = ,“MIPS files”,,mips; Using a relative path

[SourceDiskFiles]
This describes the name and path of the files in which your application 
resides.

Required? Yes

• filename: disk_number[,subdir] 
RPM.EXE  = 1,c:\appsoft\... 
WCESTART.INI = 1 
RPMCE212.INI = 1 
TAHOMA.TTF  = 2

Note: [,subdir] is relative to the location of the INF file.

Example
[SourceDisksFiles]; Required section 
begin.wav = 1  
end.wav = 1  
sample.hlp = 1  
[SourceDisksFiles.SH3]  
sample.exe = 2; Uses the SourceDisksNames.SH3 identification of 2. 
[SourceDisksFiles.MIPS]  
sample.exe = 2; Uses the SourceDisksNames.MIPS identification of 2.

[DestinationDirs]
This describes the names and paths of the destination directories for the 
application on the target device. Note Windows CE does not support directory 
identifiers.

Required? Yes

• file_list_section:0,subdir 
String that identifies the destination directory. The following list shows 
the string substitutions supported by Windows CE. Use these only for 
the beginning of the path. \ 
%CE1% \Program Files 
%CE2% \Windows 
%CE3% \My Documents 
%CE4% \Windows\Startup 
%CE5% \My Documents 
%CE6% \Program Files\Accessories 
%CE7% \Program Files\Communication 
%CE8% \Program Files\Games 
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%CE9% \Program Files\Pocket Outlook 
%CE10% \Program Files\Office 
%CE11% \Windows\Start Menu\Programs 
%CE12% \Windows\Start Menu\Programs\Accessories 
%CE13% \Windows\Start Menu\Programs\Communications 
%CE14% \Windows\Start Menu\Programs\Games 
%CE15% \Windows\Fonts 
%CE16% \Windows\Recent 
%CE17% \Windows\Start Menu 
%InstallDir% 
Contains the path to the target directory selected during installation. It is 
declared in the [CEStrings] section 
%AppName% 
Contains the application name defined in the [CEStrings] section.

Example
[DestinationDirs]  
Files.Common  = 0,%CE1%\My Subdir; \Program Files\My Subdir  
Files.Shared  = 0,%CE2%; \Windows

[CopyFiles]
This section, under the [DefaultInstall] section, describes the default files 
to copy to the target device. Within the [DefaultInstall] section, files were 
listed that must be defined elsewhere in the INF file. This section identifies 
that mapping and may contain flags.

Required? Yes

• copyfile_list_section: destination_filename,[source_filename] 
The source_filename parameter is optional if it is the same as 
destination_filename.

• copyfile_list_section: flags 
The numeric value that specifies an action to do while copying files. The 
following table shows values supported by Windows CE.

Flag Value Description

COPYFLG_WARN_IF_SKIP 0x00000001 Warn user if skipping a file is attempted after error.

COPYFLG_NOSKIP 0x00000002 Do not allow a user to skip copying a file.

COPYFLG_NO_OVERWRITE 0x00000010 Do not overwrite files in destination directory.

COPYFLG_REPLACEONLY 0x00000400 Copy the source file to the destination directory only if 
the file is already in the destination directory.

CE_COPYFLG_NO_DATE_DIALOG 0x20000000 Do not copy files if the target file is newer.

CE_COPYFLG_NODATECHECK 0x40000000 Ignore date while overwriting the target file.

CE_COPYFLG_SHARED 0x80000000 Create a reference when a shared DLL is counted.
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Example
[DefaultInstall.SH3]  
CopyFiles = Files.Common, Files.SH3  
[DefaultInstall.MIPS]  
CopyFiles = Files.Common, Files.MIPS

[AddReg]
This section, under the [DefaultInstall] section, is optional and describes 
the keys and values that the .CAB file adds to the device registry. Within 
the [DefaultInstall] section, a reference may have been made to this sec-
tion, such as “AddReg=RegSettings.All”. This section defines the options 
for that setting.

Required? No

• add_registry_section:registry_root_string 
String that specifies the registry root location. The following list shows 
the values supported by Windows CE.

• HKCR Same as HKEY_CLASSES_ROOT

• HKCU Same as HKEY_CURRENT_USER

• HKLM Same as HKEY_LOCAL_MACHINE

• add_registry_section:value_name 
Registry value name. If empty, the “default” registry value name is used.

• add_registry_section:flags 
Numeric value that specifies information about the registry key. The fol-
lowing table shows the values that are supported by Window CE.

Flag Value Description

FLG_ADDREG_NOCLOBBER 0x00000002 If the registry key exists, do not overwrite it. Can be used 
with any of the other flags in this table.

FLG_ADDREG_TYPE_SZ 0x00000000 REG_SZ registry data type.

FLG_ADDREG_TYPE_MULTI_SZ 0x00010000 REG_MULTI_SZ registry data type. Value field that 
follows can be a list of strings separated by commas.

FLG_ADDREG_TYPE_BINARY 0x00000001 REG_BINARY registry data type. Value field that fol-
lows must be a list of numeric values separated by com-
mas, one byte per field, and must not use the 0x 
hexadecimal prefix.

FLG_ADDREG_TYPE_DWORD 0x00010001 REG_DWORD data type. The noncompatible format 
in the Win32 Setup .INF documentation is supported.

Example
AddReg = RegSettings.All  
 
[RegSettings.All]  
HKLM,%reg_path%,,0x00000000,alpha; <default> = “alpha” 
HKLM,%reg_path%,test,0x00010001,3; Test = 3  
HKLM,%reg_path%\new,another,0x00010001,6; New\another = 6
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[CEShortCuts]
This section, a Windows CE-specific section under the [DefaultInstall] 
section, is optional and describes the shortcuts that the installation applica-
tion creates on the device. Within the [DefaultInstall] section, a reference 
may have been made to this section, such as “ShortCuts.All”. This section 
defines the options for that setting.

Required? No

• shortcut_list_section:shortcut_filename 
String that identifies the shortcut name. It does not require the .LNK 
extension.

• shortcut_list_section:shortcut_type_flag 
Numeric value. Zero or empty represents a shortcut to a file; any non-
zero numeric value represents a shortcut to a folder.

• shortcut_list_section:target_file_path 
String value that specifies the destination location. Use the target file 
name for a file, such as MyApp.exe, that must be defined in a file copy 
list. For a path, use a file_list_section name defined in the [Destination-
Dirs] section, such as DefaultDestDir, or the %InstallDir% string.

• shortcut_list_section:standard_destination_path 
Optional string value. A standard %CEx% path or %InstallDir%. If no 
value is specified, the shortcut_list_section name of the current section or 
the DefaultDestDir value from the [DestinationDirs] section is used.

Example
CEShortcuts = Shortcuts.All  
[Shortcuts.All]  
Sample App,0,sample.exe; Uses the path in DestinationDirs. Sample App,0,sam-
ple.exe,%InstallDir%; The path is explicitly specified.

Sample .INF File
[Version]; Required section  
Signature = “$Windows NT$”  
Provider = “Intermec Technologies Corporation”  
CESignature = “$Windows CE$” 
 
;[CEDevice] 
;ProcessorType =  
 
[DefaultInstall]; Required section  
CopyFiles = Files.App, Files.Fonts, Files.BitMaps, Files.Intl, Files.Tele-
comNcsCE, Files.Windows, Files.Import, Files.Export, Files.Work, Files.Data-
base, Files.WinCE AddReg = RegSettings.All ;CEShortcuts = Shortcuts.All 
 
[SourceDisksNames]; Required section  
1 = ,“App files” ,,c:\appsoft\...  
2 = ,”Font files” ,,c:\WinNT\Fonts  
3 = ,”CE Tools”  ,,c:\windows ce tools\wce400\700ie\mfc\lib\x86  
 
[SourceDisksFiles]; Required section  
rpm.exe   = 1,C:\Appsoft\program\wce400\WCEX86Rel700  
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wcestart.ini = 1  
rpmce212.ini = 1  
intermec.bmp = 1  
rpmlogo.bmp = 1  
rpmname.bmp = 1  
import.bmp  = 1  
export.bmp  = 1  
clock.bmp  = 1  
printer.bmp = 1  
filecopy.bmp = 1  
readme.txt  = 1  
lang_eng.bin = 1  
rpmdata.dbd = 1,database\wce1  
tahoma.ttf  = 2  
mfcce212.dll = 3  
olece212.dll = 3  
olece211.dll = 1,c:\windows ce tools\wce400\NMSD61102.11\mfc\lib\x86 
rdm45wce.dll = 1,c:\rptools\rdm45wce\4_50\lib\wce400\wcex86rel  
picfmt.dll  = 1,c:\rptools\picfmt\1_00\wce400\wcex86rel6110  
fmtctrl.dll = 1,c:\rptools\fmtctrl\1_00\wce400\wcex86rel6110  
ugrid.dll  = 1,c:\rptools\ugrid\1_00\wce400\wcex86rel6110  
simple.dll  = 1,c:\rptools\pspbm0c\1_00\wce400\wcex86rel  
psink.dll = 1,c:\rptools\psink\1_00\wce400\WCEX86RelMinDependency  
pslpwce.dll =1,c:\rptools\pslpm0c\1_00\wce400\WCEX86RelMinDependency  
npcpport.dll = 1,c:\rptools\cedk\212_03\installable drivers\printer\npcp  
;dexcom.dll  = 1,c:\rptools\psdxm0c\1_00\x86  
ncsce.exe  = 1,c:\rptools\ncsce\1_04  
nrinet.dll  = 1,c:\rptools\ncsce\1_04  
 
[DestinationDirs];Required section  
;Shortcuts.All = 0,%CE3%  ; \Windows\Desktop  
Files.App= 0,%InstallDir%  
Files.DataBase= 0,%InstallDir%\DataBase  
Files.BitMaps= 0,%InstallDir%\Bitmaps  
Files.Fonts= 0,%InstallDir%\Fonts  
Files.Intl= 0,%InstallDir%\Intl  
Files.TelecomNcsCE= 0,%InstallDir%\Telecom\NcsCE  
Files.Windows= 0,%InstallDir%\Windows  
Files.Import= 0,%InstallDir%\Import  
Files.Export= 0,%InstallDir%\Export  
Files.Work= 0,%InstallDir%\Work 
Files.WinCE= 0,\storage_card\wince 
 
[CEStrings]; Required section  
AppName = Rp32  
InstallDir = \storage_card\%AppName%  
 
[Strings]; Optional section  
;[Shortcuts.All]  
;Sample App,0,sample.exe; Uses the path in DestinationDirs.  
;Sample App,0,sample.exe,%InstallDir%; The path is explicitly specified. 
 
[Files.App]  
rpm.exe,,,0  
rpm.ini,rpmce212.ini,,0  
mfcce212.dll,,,0  
olece212.dll,,,0  
olece211.dll,,,0  
rdm45wce.dll,,,0  
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picfmt.dll,,,0  
fmtctrl.dll,,,0  
ugrid.dll,,,0  
simple.dll,,,0  
psink.dll,,,0  
pslpwce.dll,,,0  
npcpport.dll,,,0  
;dexcom.dll,,,0 
 
[Files.DataBase] 
rpmdata.dbd,,,0 
 
[Files.Fonts]  
tahoma.ttf,,,0 
 
[Files.BitMaps]  
intermec.bmp,,,0  
rpmlogo.bmp,,,0  
rpmname.bmp,,,0  
import.bmp,,,0  
export.bmp,,,0  
clock.bmp,,,0  
printer.bmp,,,0  
filecopy.bmp,,,0 
 
[Files.Intl]  
lang_eng.bin,,,0 
 
[Files.TelecomNcsCE]  
ncsce.exe,,,0  
nrinet.dll,,,0  
 
[Files.Windows] 
readme.txt,,,0 
 
[Files.Import] 
readme.txt,,,0 
 
[Files.Export] 
readme.txt,,,0 
 
[Files.Work] 
readme.txt,,,0 
 
[Files.WinCE] 
wcestart.ini,,,0 
 
[RegSettings.All]  
HKLM,”SOFTWARE\Microsoft\Shell\AutoHide”,,0x00010001,1; Autohide the taskbar 
HKLM,”SOFTWARE\Microsoft\Shell\OnTop”,,0x00010001,0; Shell is not on top 
HKLM,”SOFTWARE\Microsoft\Clock”,SHOW_CLOCK,0x00010001,0 
; Clock is not on taskbar
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Using Installation Functions in SETUP.DLL
SETUP.DLL is an optional file that enables you to perform custom opera-
tions during installation and removal of your application. The following list 
shows the functions that are exported by SETUP.DLL.

Install_Init Called before installation begins. Use this function to check the application version when reinstall-
ing an application and to determine if a dependent application is present.

Install_Exit Called after installation is complete. Use this function to handle errors that occur during applica-
tion installation.

Uninstall_Init Called before the removal process begins. Use this function to close the application, if the applica-
tion is running.

Uninstall_Exit Called after the removal process is complete. Use this function to save database information to a file 
and delete the database and to tell the user where the user data files are stored and how to reinstall 
the application.

Note: Use [DefaultInstall] > CESelfRegister (page 129) in the .INF file 
to point to SETUP.DLL.

After the CAB File Extraction
Cab files that need to cause a warm reset after cab extraction need to create 
the __RESETMEPLEASE__.TXT file in the “\Windows” directory. The 
preferred method to create this file is within the DllMain portion of the 
SETUP.DLL file. It looks like this:

#include <windows.h> 
#include <Tlhelp32.h> 
#include <winioctl.h> 
#include <ce_setup.h>   // in the public SDK dir 
 
#define IOCTL_TERMINAL_RESET CTL_CODE (FILE_DEVICE_UNKNOWN,FILE_ANY_ACCESS, 
2050, METHOD_NEITHER) 
 
BOOL APIENTRY DllMain( HANDLE h, DWORD reason, LPVOID lpReserved ) 
{ 
return TRUE; 
} // DllMain 
 
 
//************************************************************************ 
// $DOCBEGIN$ 
// BOOL IsProcessRunning( TCHAR * pname ); 
// 
// Description: Get process table snapshot, look for pname running. 
// 
// Arguments: pname - pointer to name of program to look for. 
// for example, app.exe. 
// 
// Returns: TRUE - process is running. 
//          FALSE - process is not running. 
// $DOCEND$ 
//************************************************************************ 
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BOOL IsProcessRunning( TCHAR * pname )  
{ 
HANDLE hProcList; 
PROCESSENTRY32 peProcess; 
DWORD thDeviceProcessID; 
TCHAR lpname[MAX_PATH]; 
 
if ( !pname || !*pname ) return FALSE; 
 
_tcscpy( lpname, pname ); 
_tcslwr( lpname ); 
 
hProcList = CreateToolhelp32Snapshot( TH32CS_SNAPPROCESS, 0 ); 
 
if ( hProcList == INVALID_HANDLE_VALUE ) { 
return FALSE; 
} // end if 
 
memset( &peProcess, 0, sizeof(peProcess) ); 
peProcess.dwSize = sizeof(peProcess); 
 
if ( !Process32First( hProcList, &peProcess ) ) { 
CloseToolhelp32Snapshot( hProcList ); 
return FALSE; 
} // end if 
 
thDeviceProcessID = 0; 
 
do { 
_tcslwr( peProcess.szExeFile ); 
 
if ( _tcsstr( peProcess.szExeFile, lpname ) ) { 
thDeviceProcessID = peProcess.th32ProcessID; 
break; 
} // end if 
} while ( Process32Next( hProcList, &peProcess ) ); 
 
if ( ( GetLastError() == ERROR_NO_MORE_FILES ) && ( thDeviceProcessID == 0 ) ) 
{ 
CloseToolhelp32Snapshot( hProcList ); 
return FALSE; 
} // end if 
 
CloseToolhelp32Snapshot( hProcList ); 
return TRUE; 
} // IsProcessRunning 
 
codeINSTALL_INIT Install_Init( 
HWND hwndParent, 
BOOL fFirstCall,  
BOOL fPreviouslyInstalled,  
LPCTSTR pszInstallDir )  
{ 
return codeINSTALL_INIT_CONTINUE; 
} 
 
codeINSTALL_EXIT Install_Exit ( 
HWND hwndParent,  
LPCTSTR pszInstallDir,  
CN2B Mobile Computer User’s Manual 137



Chapter 7 — Programming
WORD cFailedDirs,  
WORD cFailedFiles,  
WORD cFailedRegKeys,  
WORD cFailedRegVals,     
WORD cFailedShortcuts )  
{ 
HANDLE h; 
TCHAR srcfile[MAX_PATH]; 
TCHAR dstfile[MAX_PATH]; 
 
if (cFailedDirs || cFailedFiles || cFailedRegKeys ||  
cFailedRegVals || cFailedShortcuts) 
return codeINSTALL_EXIT_UNINSTALL; 
 
if ( IsProcessRunning( L”autocab.exe” ) ) 
{ 
h = CreateFile( L”\\Windows\\__resetmeplease__.txt”, 
(GENERIC_READ | GENERIC_WRITE), 0, NULL, CREATE_ALWAYS, 
FILE_ATTRIBUTE_HIDDEN, NULL ); 
 
if ( h != INVALID_HANDLE_VALUE ) 
CloseHandle( h ); 
else 
{ 
// Couldn’t create the file.  If it failed because the file already exists, it 
is not fatal.  
// Otherwise, notify user of the inability to reset the device and they will 
have to 
// perform it manually after all of the installations are complete. 
} // end if 
} 
else 
{ 
DWORD dret; 
 
h = CreateFile( L”SYI1:”,  
(GENERIC_WRITE | GENERIC_READ), 0, NULL, OPEN_EXISTING, 
FILE_ATTRIBUTE_NORMAL, NULL ); 
 
// Force a warm start NOW. 
if ( h != INVALID_HANDLE_VALUE ) 
{ 
DeviceIoControl( h, IOCTL_TERMINAL_RESET, NULL, 0, NULL, 0, &dret, NULL); 
 
// Won’t return, but we’ll show clean up anyway 
CloseHandle( h ); 
} 
else 
{ 
// Couldn’t access SYSIO. Notify user. 
} // end if 
} // end if 
 
return codeINSTALL_EXIT_DONE; 
} 
 
codeUNINSTALL_INIT  
Uninstall_Init( 
HWND hwndParent,  
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LPCTSTR pszInstallDir ) { 
 
// TODO: Perform the reverse of INSTALL_INIT here 
return codeUNINSTALL_INIT_CONTINUE; 
} 
 
codeUNINSTALL_EXIT  
Uninstall_Exit(HWND hwndParent) { 
 
// TODO: Perform the reverse of INSTALL_EXIT here 
return codeUNINSTALL_EXIT_DONE; 
} 

The system software looks for the following directory structure and files on 
the installed media card whether it be a Secure Digital card or embedded 
flash file system. No other folders need exist.

\2577\autorun.exe 
\2577\autorun.dat 
\2577\autocab.exe 
\2577\autocab.dat 
\cabfiles\*.cab

Creating CAB Files with CAB Wizard
After you create the .INF file and the optional SETUP.DLL file, use the 
CAB Wizard to create the .CAB file. The command-line syntax for the 
CAB Wizard is as follows:

cabwiz.exe “inf_file” [/dest dest_directory] [/err error_file] [/cpu cpu_type 
[cpu_type]] 

A batch file, located in <program> directory, with the following com-
mands, works well:

cabwiz.exe c:\appsoft\<program>\<inf_file_name> 
cd \appsoft\<program> 

“inf_file” The SETUP.INF file path.

dest_directory The destination directory for the .CAB files. If no directory is specified, the .CAB files are created in 
the “inf_file” directory.

error_file The file name for a log file that contains all warnings and errors that are encountered when the .CAB 
files are compiled. If no file name is specified, errors are displayed in message boxes. If a file name is 
used, the CAB Wizard runs without the user interface (UI); this is useful for automated builds.

cpu_type Creates a .CAB file for each specified microprocessor tag, which is a label used in the Win32 
SETUP.INF file to differentiate between different microprocessor types. The /cpu parameter, fol-
lowed by multiple cpu_type values, must be the last qualifier in the command line.
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Example
This example creates .CAB files for the ARM and MIPS microprocessors, 
assuming the Win32 SETUP.INF file contains the ARM and MIPS tags:

cabwiz.exe “c:\myfile.inf” /err myfile.err /cpu arm mips

Note: CABWIZ.EXE, MAKECAB.EXE, and CABWIZ.DDF (Windows 
CE files available on the Windows CE Toolkit) must be installed in the 
same directory on the desktop computer. Call CABWIZ.EXE using its full 
path for the CAB Wizard application to run correctly.

Troubleshooting the CAB Wizard
To identify and avoid problems that might occur when using the CAB 
Wizard, follow these guidelines:

• Use %% for a percent sign (%) character when using this character in an 
.INF file string, as specified in Win32 documentation. This does not 
work under the [Strings] section.

• Do not use .INF or .CAB files created for Windows CE to install appli-
cations on Windows-based desktop platforms.

• Ensure the MAKECAB.EXE and CABWIZ.DDF files, included with 
Windows CE, are in the same directory as CABWIZ.EXE.

• Use the full path to call CABWIZ.EXE.

• Do not create a .CAB file with the MAKECAB.EXE file included with 
Windows CE. You must use CABWIZ.EXE, which uses 
MAKECAB.EXE to generate the .CAB files for Windows CE.

• Do not set the read-only attribute for .CAB files.

Customization and Lockdown
Pocket PC (Windows Mobile) is a hardware specification created by 
Microsoft Corporation. Devices that wish to carry the Pocket PC logo must 
meet the minimum hardware requirements set in the Pocket PC specifica-
tion. Manufacturers are free to add extra hardware functionality.

Pocket PC devices also use a specialized version of the CE operating system. 
This operating system is built from Windows CE 4.2 but contains custom-
izations, most notably the lack of a desktop and the addition of the Today 
Screen.

To carry the Pocket PC logo, all devices must be tested at an Independent 
Test Laboratory. The ITL testing is done based on Microsoft requirements. 
The test lab then reports the findings back to Microsoft Corporation and 
Intermec. If the CN2B Computer passed all tests, Intermec is allowed to 
ship the device with the Pocket PC logo. Each time the operating system is 
modified, Intermec must resubmit to ITL testing.
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This means we cannot change the operating system much and still be a 
Pocket PC device. For example, if we remove Word from the Start menu, 
the device would fail ITL testing and we would not be able to ship devices 
with the Pocket PC logo.

Although many customers want a Pocket PC device, some customers would 
prefer that their users not have access to all of the Pocket PC features. Inter-
mec cannot customize the operating system in any way but a custom appli-
cation can:

• Delete items from the Start menu and Programs folder. These items are 
just shortcuts in the file system so the application is not really being 
deleted. Cold booting the device brings these items back so the applica-
tion will need to be run on every cold boot.

• Use the RegFlushKey() API to save a copy of the registry to a storage 
device. See the CN2B Management Tools portion for more information 
on how to do this. Saving a copy of the registry restores most system set-
tings in a cold boot situation.

• Use the SHFullScreen() API in conjunction with other APIs to make the 
application take up the entire display and prevent the start menu from 
being available.

• Remap keys and disable keys on the keypad.

• Create a custom SIP.

• Make changes to the registry to configure the device.

Should you want your CN2B Computer to display a full screen, keep in 
mind that your computer is Pocket-PC certified by Microsoft Corporation. 
Check out resources on programming for the Pocket PC, using the follow-
ing links. These give full instructions on how to display full screen.

• Instructions on how to create a full screen application for eVC++ appli-
cations using an SHFullScreen() API: 
support.microsoft.com/support/kb/articles/Q266/2/44.asp

• Instructions on how to create a full screen application for eVB applica-
tions also using the SHFullScreen() API: 
support.microsoft.com/support/kb/articles/Q265/4/51.asp

FTP Server
FTP support is provided through the FTP Server application FTP-
DCE.EXE (MS Windows CE Versions) which is provided as part the base 
system.

FTPDCE is the Internet File Transfer Protocol (FTP) server process. The 
server can be invoked from an application or command line. Besides servic-
ing FTP client requests the FTP Server also send a “network announce-
ment” to notify prospective clients of server availability.
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Note: You should consult the RFC959 specification for proper use of some 
of these commands at the following URL:

• www.ietf.org/rfc/rfc959.txt for the text version, or

• www.w3.org/Protocols/rfc959/ for an html version.

Do the following to send commands:

1 Start an FTP client and connect to the device FTP server.

2 Log in with “intermec” as the user name and “cr52401” for the pass-
word.

3 From the FTP client, send the command.

4 Wait for a response.

Synopsis
ftpdce [ options ]

Options

–Aaddr (where addr is in the form of a.b.c.d) Sets the single target address to which to send the network 
announcement. Default is broadcast.

–Bbyte Sets the FTP data block size. Smaller sizes may be useful over slower links. Default is 65536.

–Cname Sets the device name. Used by Intermec management software.

–Fvalue Disables the default Intermec account. A value of “0” disables the account. Default is “1”. Note that 
disabling the default account without providing a working access control list on the server will 
result in a device that will not accept any FTP connections.

–Hsec Sets the interval between network announcements in seconds.“0” turns the network announce-
ment off. Default is 30 seconds.

–Iaddr (where addr is in the form of a.b.c.d) Sets the preferred 6920 Communications Server (optional).

–Llog (where log is either “0” or “1”) Sets the state of logging. Default is 0 (disabled).

–Nsec Specifies the number of seconds to wait before initially starting FTP server services.

–Pport Sets the UDP port on which the network announcement are sent. Default port is 52401.

–Qport Sets the port on which the FTP Server will listen for connections. Default port is 21.

–Rdir Sets the FTP mount point to this directory. Default is the root folder of the object store.

–Tscrip Sets the script name for the 6920 Communications Server to process.

–Uurl Sets the default URL for this device.

–Z“parms” Sets extended parameters to be included in the network announcement.
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Configurable Parameters Via the Registry Editor
The following parameters receive default values during the installation of 
the Intermec FTP Server components. A few of the parameters are visible in 
the registry by default, but most must be created to modify the default 
behavior of the FTP server.

BlockSize
Setting this parameter configures the Intermec FTP Server to transmit and 
receive Ethernet packets using the specified data block size. By default, the 
FTP server transmits and receives data using a 64K data block size. Adjust-
ing this value may be useful in certain wireless TCP/IP installations.

Key HKLM\Software\Intermec\IFTP

Value Type REG_DWORD - data block size, in bytes.

Valid Range 0x100-0x10000 (256-65536 decimal).

Default 65536

DeviceName
This parameter configures the Intermec FTP Server to include the specified 
device name in the Intermec Device Network Announcement (IDNA). 
Adjusting this value may be useful in assigning a symbolic name to this 
device for asset tracking.

Key HKLM\Software\Intermec\IFTP

Value Type REG_SZ

Valid Range None.

Default None.

DeviceURL
This parameter configures the Intermec FTP Server to transmit the speci-
fied URL in the IDNA. This can be used by Intermec management soft-
ware for asset management.

Key HKLM\Software\Intermec\IFTP

Value Type REG_SZ

Valid Range None.

Default None.
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IDNATarget
This parameter configures the Intermec FTP Server to transmit the IDNA 
to a specific destination instead of a general UDP broadcast. This parame-
ter is useful on networks that do not allow UDP broadcasts to be routed 
between subnets. The use of this parameter restricts the reception of the 
IDNA to the target destination only.

Key HKLM\Software\Intermec\IFTP

Value Type REG_SZ

Valid Range None.

Default None.

ManifestName
This parameter configures the Intermec FTP Server to transmit the speci-
fied manifest name in the IDNA. This parameter is used by the Intermec 
6920 Communications Server for communication transactions. See 6920 
Communications Server documentation for proper use of this parameter.

Key HKLM\Software\Intermec\IFTP

Value Type REG_SZ

Valid Range None.

Default iftp.ini

PauseAtStartup
This configures the Intermec FTP Server to sleep for the specified number 
of seconds before making the FTP service available on the device.

Key HKLM\Software\Intermec\IFTP

Value Type REG_DWORD - stored in seconds.

Valid Range None.

Default 0

Root
This parameter configures the Intermec FTP Server to set the root of the 
FTP mount point to the specified value. Note that this must map to an exist-
ing directory or you will not be able to log into the FTP Server.

Key HKLM\Software\Intermec\IFTP

Value Type REG_SZ

Valid Range None.

Default \
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Transferring Files Over TCP/IP Networks
The File Transfer Protocol (FTP) server transfers files over TCP/IP net-
works. The FTPDCE.EXE program is a version that does not display a 
window, but can run in the background.

FTPDCE is the Internet File Transfer Protocol (FTP) server process. The 
server can be invoked from an application or command line. Besides servic-
ing FTP client requests, the FTP Server also sends a “network announce-
ment” to notify prospective clients of server availability.

The FTP Server currently supports the following FTP requests:

CDUP Changes to the parent directory of the current working directory.

CWD Changes working directory.

DELE Deletes a file.

HELP Gives help information.

LIST (This FTP request is the same as the ls -lgA command). Gives list files in a directory. 

MKD Makes a directory.

MODE (Always Uses Binary). Specifies data transfer mode.

NLST (Not supported) Gives a name list of files in directory (this request is the same as the ls command).

NOOP Does nothing.

PASS Specifies a password.

PWD Prints the current working directory.

QUIT Terminates session.

RETR Retrieves a file.

RMD Removes a directory.

RNFR Specifies rename-from file name.

RNTO Specifies rename-to file name.

STOR Stores a file.

SYST Shows the operating system type of server system.

TYPE (Binary transfers only.) Specifies the data transfer type with the Type parameter.

USER Specifies user name.

XCUP (Not Normally Used) Changes the parent directory of the current working directory. 

XCWD (Not Normally Used) Changes the current directory.

XMKD (Not Normally Used) Creates a directory.

XPWD (Not Normally Used) Prints the current working directory.

XRMD (Not Normally Used) Removes a directory.
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SITE The following extended OEM commands are supported by the SITE request. For Microsoft FTP clients, 
you can send site commands by preceding the command with “quote” such as “quote site status.”

ATTRIB Gets or sets the attributes of a given file. (SITE ATTRIB)

Usage: QUOTE SITE ATTRIB [+R | -R] [+A | -A ] [+S | -S] [+H | -H] [[path] 
filename] 
+ Sets an attribute. 
– Clears an attribute. 
R Read-only file attribute. 
A Archive file attribute. 
S System file attribute. 
H Hidden file attribute. 
To retrieve the attributes of a file, only specify the file. The server 
response will be: 200-AD SHRCEIX filename

To retrieve the attributes of a file, only specify the file. The server response will be:  
200-AD SHRCEIX filename

If the flag exists in its position shown above, it is set. Also, in addition to the values 
defined above, there is also defined: 
C  Compressed file attribute. 
E  Encrypted file attribute. 
I  INROM file attribute. 
X  XIP file attribute (execute in ROM, not shadowed in RAM).

BOOT Reboots the server OS. This will cause the system on which the server is executing to 
reboot. The FTP Server will shut down cleanly before reboot. All client connections will 
be terminated. Cold boot is default except for the PocketPC build in which the default is 
warm boot. (SITE BOOT)

Usage: QUOTE SITE BOOT [WARM | COLD]

COPY Copies a file from one location to another. (SITE COPY)

Usage: QUOTE SITE COPY [source] [destination]

Example: QUOTE SITE COPY ‘\Storage Card\one.dat’ 
‘\Storage Card\two.dat’

EXIT Exits the FTP Server. This command will shut down the FTP Server thus terminating all 
client connections. (SITE EXIT)

Usage: QUOTE SITE EXIT

HELP Gives site command help information. (SITE HELP)

Usage: QUOTE SITE HELP [command]

KILL Terminates a running program. (SITE KILL)

Usage: QUOTE SITE KILL [program | pid]
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The remaining FTP requests specified in RFC 959 are recognized, but not 
implemented.

The banner returned in the parenthetical portion of its greeting shows the 
version number of the FTP Server as well as the MAC address, serial num-
ber and operating system of the machine hosting the server.

The FTP Server supports browsing from the latest Netscape and Microsoft 
web browsers. Drag-and-drop capability is available using this environ-
ment.

LOG Opens or closes the program log. (SITE LOG)

Usage: QUOTE SITE LOG [open [filename]| close]

PLIST Lists the running processes (SITE PLIST)

Usage: QUOTE SITE PLIST

RUN Starts a program running. If the program to run has spaces in path or filename, wrapping 
the name with single quotes is required.

Usage: QUOTE SITE RUN [program]

Example: QUOTE SITE RUN ‘\Storage Card\app.exe’

STATUS Returns the current settings of the FTP Server. MAC, serial number, model, IP address, 
network announcement information as well as OS memory usage are returned. (SITE 
STATUS)

Usage: QUOTE SITE STATUS

TIMEOUT Toggles idle timeout between 120 to 1200 seconds (2 to 20 minutes). If this timer 
expires with no activity between the client and the server, the client connection will be 
disconnected. If the optional seconds argument is supplied, the server will set the con-
nection timeout to the number of seconds specified. Default is 120 seconds or 2 minutes. 
(SITE TIMEOUT)

Usage: QUOTE SITE TIMEOUT [seconds]

EKEY Gives site command electronic key information. (SITE HELP)

Usage: QUOTE SITE EKEY [command]

EVAL Gives site command electronic value information. (SITE HELP)

Usage: QUOTE SITE EVAL [command]

GVAL Gives site command general value information. (SITE HELP)

Usage: QUOTE SITE GVAL [command]

PVAL Gives site command value information. (SITE HELP)

Usage: QUOTE SITE PVAL [command]
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The FTPDCMDS subdirectory contains commands to use from the web 
browser. 

• Click EXITME.BIN to execute a SITE EXIT command. 

• Click REBOOTME.BIN to execute SITE BOOT command. 

• Use the GET command on these files to have the FTP Server execute 
these commands.

• Security: 
A customer configurable access control list may be installed on the 
CN2B Computer. This list will allow customers to restrict access via 
the FTP Server to users they wish and is in addition to default Inter-
mec accounts that are disabled using the -F0 option at runtime.

The access control list is named FTPDCE.TXT and is placed in the 
same directory on the CN2B Computer as the FTPDCE.EXE server. 
The FTP Server encrypts this file to keep the information safe from 
unauthorized users. This file is encrypted when the FTP Server is 
started so a file that is placed onto the CN2B Computer after the FTP 
Server starts will require a restart of the FTP Server to take effect.

The format of the FTPDCE.TXT is as follows:

FTPDCE:user1!passwd1<cr><lf>user2!passwd2<cr><lf>user3!pas
swd3<cr><lf>...

Note: The user accounts and passwords are case-sensitive. Once the access 
control list is encrypted on the CN2B Computer, the FTP Server hides this 
file from users. Once an access control list is installed on the CN2B Com-
puter, a new one is not accepted by the FTP Server until the previous one is 
removed. Encrypted access control lists are not portable between CN2B 
Computers.

Stopping the FTP Server from Your Application
To allow application programmers the ability to programmatically shut 
down the FTP Server, the FTP Server periodically tests to see if a named 
event is signaled. The name for this event is “ITC_IFTP_STOP” (no 
quotes).

For examples on how to use events, consult the Microsoft Developer Net-
work Library at www.msdn.com. The MSDN Library is an essential 
resource for developers using Microsoft tools, products, and technologies. 
It contains a bounty of technical programming information, including 
sample code, documentation, technical articles, and reference guides.
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Autostart FTP
This automatically starts the FTP Server (FTPDCE.EXE) when the CN2B 
Computer is powered on. This is provided with the NDISTRAY program 
(the Network Driver Interface Specification tray application), which dis-
plays the popup menu that currently allows you to load and unload the net-
work drivers. Tap the antenna icon in the System Tray of the Today screen 
(a sample antenna icon is shown below) for this pop-up menu. 

Antenna

The default is to start the FTP Server at boot time, unless the following reg-
istry entry is defined and set to “0” which disables AutoFTP. “1” enables 
the AutoFTP. The entry can be set from the NDISTRAY pop-up menu by 
selecting either AutoFTP On or AutoFTP Off.

HKEY_LOCAL_MACHINE\Software\Intermec\Ndistray\StartupIFTP

These new entries are located below the selections to load the network driv-
ers. If the StartupIFTP registry key is not defined, the FTP Server is loaded 
by default, to provide “out-of-the-box” capability for customers who want 
to begin loading files to the CN2B Computer without prior configuration.
Note: If a network driver is unloaded using the NDISTRAY pop-up menu, 
and the FTP Server is running, the FTP Server is stopped.

On a resume, if AutoFTP is enabled and the FTP Server is running, it is 
stopped and restarted. NDISTRAY uses a helper application named RESE-
TIFTP to implement the restart on resume feature. 

To do an AutoFTP Installation Check:

1 Ensure the FTP Server is running “out-of-the-box” the first time.

2 Tap Start > Today to access the Today screen, then tap the antenna icon 
in the System Tray to bring up the NDISTRAY pop-up menu. Select 
AutoFTP Off to disable AutoFTP. Perform a warm-boot and confirm 
the FTP Server is not running. 
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3 Tap Start > Today to access the Today screen, then tap the antenna icon 
in the System Tray to bring up the NDISTRAY pop-up menu. Select 
AutoFTP On to enable AutoFTP, reboot, confirm it is running. 

4 Unload the network driver when the FTP Server is running and confirm 
that it is not running any more.

5 Load the FTP Server, establish a connection, then suspend and resume. 
The server should still run, but the FTP connection to the client should 
be dropped.

Kernel I/O Controls
This describes the KernelIoControl() functions available to application pro-
grammers. Most C++ applications need to prototype the function as the 
following to avoid link and compile errors.

extern “C” BOOL KernelIoControl(DWORD dwIoControlCode, LPVOID lpInBuf, DWORD 
nInBufSize, LPVOID lpOutBuf, DWORD nOutBufSize, LPDWORD lpBytesReturned);

IOCTL_HAL_GET_DEVICE_INFO
This IOCTL returns either the platform type or the OEMPLATFORM 
name based on an input value.

Syntax
BOOL KernelIoControl( IOCTL_HAL_GET_DEVICE_INFO, LPVOID 
lpInBuf, DWORD nInBufSize, LPVOID lpOutBuf, DWORD 
nOutBufSize, LPDWORD lpBytesReturned );

Parameters
lpInBuf Points to a DWORD containing either the SPI_GETPLATFORMTYPE or 

SPI_GETOEMINFO value.

lpInBufSize Must be set to sizeof(DWORD).

lpOutBuf Must point to a buffer large enough to hold the return data of the function. If 
SPI_GETPLATFORMTYPE is specified in lpInBuf, then the “PocketPC\0” Unicode string is 
returned. If SPI_GETOEMINFO is specified in lpInBuf, then the “Intermec 700\0” Unicode 
string is returned.

nOutBufSize The size of lpOutBuf in bytes. Must be large enough to hold the string returned.

lpBytesReturned The actual number of bytes returned by the function for the data requested.

Return Values
Returns TRUE if function succeeds. Returns FALSE if the function fails. 
GetLastError() may be used to get the extended error value.
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IOCTL_HAL_ITC_READ_PARM

Usage
#include “oemioctl.h”

Syntax
BOOL KernelIoControl( IOCTL_HAL_ITC_READ_PARM,LPVOID 
lpInBuf,DWORD nInBufSize,LPVOID lpOutBuf,DWORD 
nOutBufSize,LPDWORD lpBytesReturned );

Parameters
lpInBuf Points to this structure. See “ID Field Values” below. 

struct PARMS {  
BYTE id; 
BYTE ClassId; 
};

nInBufSize Must be set to the size of the PARMS structure.

lpOutBuf Must point to a buffer large enough to hold the return data of the function. If this field is set to 
NULL and nOutBufSize is set to zero when the function is called the function will return the 
number bytes required by the buffer.

nOutBufSize The size of lpOutBuf in bytes.

lpBytesReturned Number of bytes returned by the function for the data requested.

Return Values
Returns TRUE if function succeeds. Returns FALSE if the function fails. 
GetLastError() may be used to get the error value. Either 
ERROR_INVALID_PARAMETER or 
ERROR_INSUFFICIENT_BUFFER may be returned when this function 
is used to get the error.

ID Field Values
The id field of the PARMS structure may be one of the following values:

ID Field Values 

ITC_NVPARM_SERIAL_NUM 
This IOCTL returns the serial number of the device in BCD format. Six bytes are returned in the buffer pointed to by 
the lpOutBuffer parameter.

ITC_NVPARM_MANF_DATE 
This IOCTL returns the device date of manufacture in the BCD YYYY/MM/DD format. Four bytes are returned in 
the buffer pointed to by the lpOutBuffer parameter.

ITC_NVPARM_SERVICE_DATE 
This IOCTL returns the device’s date of last service in BCD YYYY/MM/DD format. Four bytes are returned in the 
buffer pointed to by the lpOutBuffer parameter.

ITC_NVPARM_DISPLAY_TYPE 
This returns the device’s display type. One byte is returned in the buffer pointed to by the lpOutBuffer parameter.
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ITC_NVPARM_ECN 
This IOCTL returns ECNs applied to the device in a bit array format. Four bytes are returned in the buffer pointed to 
by the lpOutBuffer parameter.

ITC_NVPARM_CONTRAST 
This IOCTL returns the device default contrast setting. Two bytes are returned in the buffer pointed to by the lpOut-
Buffer parameter.

ITC_NVPARM_MCODE 
This IOCTL returns the manufacturing configuration code for the device. Sixteen bytes are returned in the buffer 
pointed to by the lpOutBuffer parameter.

ITC_NVPARM_VERSION_NUMBER 
This IOCTL returns the firmware version for various system components. These values for the ClassId field of the 
PARMS structure are allowed when ITC_NVPARM_VERSION_NUMBER is used in the id field: 
•VN_CLASS_KBD  Returns a five-byte string, including null terminator, that contains an ASCII value which repre-
sents the keypad microprocessor version in the system.Format of the string is x.xx with a terminating null character. 
•VN_CLASS_ASIC  Returns a five-byte string, including null terminator, that contains an ASCII value which repre-
sents the version of the FPGA firmware in the system.Format of the string is x.xx with a terminating null character. 
•VN_CLASS_BOOTSTRAP  Returns a five-byte string, including null terminator, that contains an ASCII value 
which represents the version of the Bootstrap Loader firmware in the system.Format of the string is x.xx with a termi-
nating null character.

ITC_NVPARM_INTERMEC_SOFTWARE_CONTENT 
This IOCTL reads the manufacturing flag bits from the nonvolatile data store that dictates certain software parame-
ters. A BOOLEAN DWORD is returned in the buffer pointed to by lpOutBuffer that indicates if Intermec Content is 
enabled in the XIP regions. TRUE indicates that it is enabled. FALSE indicates that it is not enabled.

ITC_NVPARM_WAN_RI 
This reads the state of the WAN ring indicator flag. A BOOLEAN DWORD is returned in the buffer pointed to by 
lpOutBuffer that indicates the polarity of the WAN RI signal. TRUE indicates active high. FALSE indicates active low.

ITC_NVPARM_INTERMEC_DATACOLLECTION_SW 
This IOCTL reads the state of the data collection software enabled flag. A BOOLEAN DWORD is returned in the 
buffer pointer to by lpOutBuffer that indicates the data collection software is to install at boot time. FALSE indicates 
the data collection software should not install.

ITC_NVPARM_INTERMEC_DATACOLLECTION_HW 
This IOCTL reads the data collection hardware flags. A BYTE is returned in the buffer pointer to by lpOutBuffer that 
indicates the type of data collection hardware installed. The maximum possible value returned is 
ITC_DEVID_SCANHW_MAX. 
•ITC_DEVID_SCANHW_NONE  No scanner hardware is installed. 
•ITC_DEVID_INTERMEC_EVIO  EVIO linear imager is installed. 
The high bit indicates whether the S6 scanning engine is installed. The bit mask for this is 
ITC_DEVID_S6ENGINE_MASK. A nonzero value indicates that the S6 scanning engine is installed.

ITC_NVPARM_80211_INSTALLED 
This IOCTL reads the state of the 802.11b/g radio installed flag. A BOOLEAN DWORD is returned in the buffer 
pointed to by lpOutBuffer. TRUE indicates that the 802.11b/g radio is installed. FALSE indicates that no 802.11b/g 
radio is installed.

ITC_NVPARM_80211_RADIOTYPE 
This IOCTL reads the 802.11b/g radio ID installed by manufacturing. A BYTE is returned in the buffer pointer to by 
lpOutBuffer that indicates the type of 802.11b/g radio hardware installed. The maximum possible value returned is 
ITC_DEVID_80211RADIO_MAX. The current definitions are: 
•ITC_DEVID_80211RADIO_NONE  No 802.11b/g radio installed. 
•ITC_DEVID_80211RADIO_INTEL_2011B  Intel 2011B radio installed.

ID Field Values (continued)
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IOCTL_HAL_ITC_WRITE_SYSPARM
Describes and enables the registry save location.

Usage
#include “oemioctl.h”

Syntax
BOOL KernelIoControl( IOCTL_HAL_ITC_WRITE_SYSPARM,LPVOID 
lpInBuf,DWORD nInBufSize, LPVOID lpOutBuf, DWORD 
nOutBufSize, LPDWORD lpBytesReturned );

Parameters
lpInBuf A single byte that may be one of the id values. See the following “ID Field Values” table.

nInBufSize Must be set to the size of the lpInBuf in bytes.

lpOutBuf Must point to a buffer large enough to hold the data to be written to the nonvolatile data store.

nOutBufSize The size of lpOutBuf in bytes.

lpBytesReturned The number of bytes returned by the function.

Return Values
Returns TRUE if function succeeds. Returns FALSE if the function fails. 
GetLastError() may get the error value. When this function gets the error, 
either ERROR_INVALID_PARAMETER or 
ERROR_INSUFFICIENT_BUFFER is returned.

ITC_NVPARM_BLUETOOTH_INSTALLED 
This IOCTL reads the state of the Bluetooth radio installed flag. A BOOLEAN DWORD is returned in the buffer 
pointed to by lpOutBuffer. TRUE indicates that the Bluetooth radio is installed. FALSE indicates that no Bluetooth 
radio is installed.

ITC_NVPARM_SERIAL2_INSTALLED 
This IOCTL reads the state of the serial 2 (COM2) device installed flag. A BOOLEAN DWORD is returned in the 
buffer pointed to by lpOutBuffer. TRUE indicates that the serial 2 device is installed. FALSE indicates that no serial 2 
device is installed.

ITC_NVPARM_SIM_PROTECT_HW_INSTALLED 
This IOCTL reads the state of the SIM card protection hardware installed flag. A BOOLEAN DWORD is returned in 
the buffer pointed to by lpOutBuffer. TRUE indicates that the SIM card protection hardware is installed. FALSE indi-
cates that no SIM card protection hardware is installed.

ITC_NVPARM_SIM_PROTECT_SW_INSTALLED 
This IOCTL reads the state of the SIM card protection software installed flag. A BOOLEAN DWORD is returned in 
the buffer pointed to by lpOutBuffer. TRUE indicates that the SIM card protection software is installed. FALSE indi-
cates that no SIM card protection software is installed.

ITC_NVPARM_SIM_PROTECT_SW_INSTALLED 
This IOCTL reads the state of the SIM card protection software installed flag. A BOOLEAN DWORD is returned in 
the buffer pointed to by lpOutBuffer. TRUE indicates that the SIM card protection software is installed. FALSE indi-
cates that no SIM card protection software is installed.

ID Field Values (continued)
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ID Field Values
The id field of lpInBuf may be one of the following values:

ID Field Values 

ITC_REGISTRY_SAVE_ENABLE 
This function enables or disables the save registry to non–volatile media feature of the RegFlushKey() function. lpOut-
Buf must be set to zero (FALSE) if the feature is to be disabled or one (TRUE) if the feature is to be enabled.

ITC_ WAKEUP_MASK 
This IOCTL sets a bit mask that represents the mask for the five programmable wakeup keys. The I/O key is not a pro-
grammable wakeup key. By default it is always the system resume key and all other keys are set to disable key wakeup. 
A zero in a bit position masks the wakeup for that key. A one in a bit position enables wakeup for that key. lpOutBuf 
must point to a buffer that contains a byte value of a wakeup mask consisting of the OR’ed constants as defined in 
OEMIOCTL.H. Only the following keys are programmable as wakeup events. 
#define SCANNER_TRIGGER1 
#define SCANNER_LEFT2 
#define SCANNER_RIGHT4 
#define GOLD_A18 
#define GOLD_A20x10

IOCTL_HAL_GET_DEVICEID
This IOCTL returns the device ID. There are two types of device IDs sup-
ported, which are differentiated based on the size of the output buffer. The 
UUID is returned if the buffer size is set to  
sizeof(UNIQUE_DEVICEID), otherwise the oldstyle device ID is returned.

Usage
#include “pkfuncs.h” 
#include “deviceid.h”

Syntax
BOOL KernelIoControl( IOCTL_HAL_GET_DEVICEID,LPVOID 
lpInBuf,DWORD nInBufSize,LPVOID lpOutBuf,DWORD 
nOutBufSize,LPDWORD lpBytesReturned );

Parameters
lpInBuf Should be set to NULL. STRICT_ID settings are not supported.

lpInBufSize Should be set to zero.

lpOutBuf Must point to a UNIQUE_DEVICEID structure as defined by DEVICEID.H if the UUID is to 
be returned.

nOutBufSize The size of the UNIQUE_DEVICEID in bytes if the UUID is to be returned. A DEVICE_ID as 
defined by PKFUNCS.H is returned if the size in bytes is greater than or equal to 
sizeof(DEVICE_ID).

lpBytesReturned The number of bytes returned by the function.

Return Values
Returns TRUE if function succeeds. Returns FALSE if the function fails. 
GetLastError() may be used to get the extended error value.
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IOCTL_HAL_GET_OAL_VERINFO
Returns the HAL version information of the Pocket PC image.

Usage
#include “oemioctl.h”

Syntax
BOOL KernelIoControl( IOCTL_HAL_GET_OAL_VERINFO,LPVOID 
lpInBuf,DWORD nInBufSize,LPVOID lpOutBuf,DWORD 
nOutBufSize,LPDWORD lpBytesReturned );

Parameters
lpInBuf Should be set to NULL.

lpInBufSize Should be set to zero.

lpBytesReturned Returns sizeof(PVERSIONINFO).

lpOutBuf Must point to a VERSIONINFO structure as defined by  
OEMIOCTL.H. The fields should have these values: 
• cboemverinfo sizeof (tagOemVerInfo); 
• verinfover 1 
• sig;  “ITC\0” 
• id; ‘ N’ 
• tgtcustomer “” 
• tgtplat SeaRay 
• tgtplatversion Current build version number 
• tgtcputype[8]; “Intel\0” 
• tgtcpu “PXA255\0”; 
• tgtcoreversion “” 
• date Build time 
• time Build date

nOutBufSize The size of VERSIONINFO in bytes.

Return Values
Returns TRUE if function succeeds. Returns FALSE if the function fails. 
GetLastError() may be used to get the extended error value.

IOCTL_HAL_GET_BOOTLOADER_VERINFO
Returns the HAL version information of the Pocket PC image.

Usage
#include “oemioctl.h”

Syntax
BOOL KernelIoControl( IOCTL_HAL_GET_OAL_VERINFO,LPVOID 
lpInBuf, DWORD nInBufSize,LPVOID lpOutBuf,DWORD 
nOutBufSize,LPDWORD lpBytesReturned );
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Parameters
lpInBuf Should be set to NULL.

nInBufSize Should be set to zero.

lpOutBuf Must point to a VERSIONINFO structure as defined by  
OEMIOCTL.H. The fields should have these values:  
• cboemverinfo Sizeof (tagOemVerInfo); 
• verinfover 1 
• sig; “ITC\0” 
• id; ‘B’ 
• tgtcustomer “” 
• tgtplat SeaRay 
• tgtplatversion Current build version number of the  
bootstrap loader 
• tgtcputype[8]; “Intel\0”; 
• tgtcpu “PXA255\0” 
• tgtcoreversion “” 
• date Build time 
• time Build date

nOutBufSize The size of VERSIONINFO in bytes.

lpBytesReturned The number of bytes returned to lpOutBuf.

Return Values
Returns TRUE if function succeeds. Returns FALSE if the function fails. 
GetLastError() may be used to get the extended error value.

IOCTL_HAL_WARMBOOT
Causes the system to perform a warm-boot. The object store is retained.

Usage
#include “oemioctl.h”

Syntax
BOOL KernelIoControl( IOCTL_HAL_WARMBOOT,LPVOID 
lpInBuf,DWORD nInBufSize,LPVOID lpOutBuf,DWORD 
nOutBufSize,LPDWORD lpBytesReturned );

Parameters
lpInBuf Should be set to NULL.

lpInBufSize Should be set to zero.

lpOutBuf Should be NULL.

nOutBufSize Should be zero.

Return Values
None.
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IOCTL_HAL_COLDBOOT
Causes the system to perform a cold-boot. The object store is cleared.

Usage
#include “oemioctl.h”

Syntax
BOOL KernelIoControl( IOCTL_HAL_COLDBOOT,LPVOID 
lpInBuf,DWORD nInBufSize,LPVOID lpOutBuf,DWORD 
nOutBufSize,LPDWORD lpBytesReturned );

Parameters
lpInBuf Should be set to NULL.

lpInBufSize Should be set to zero.

lpOutBuf Should be NULL.

nOutBufSize Should be zero.

Return Values
None.

IOCTL_HAL_GET_RESET_INFO
This code allows software to check the type of the most recent reset.

Usage
#include “oemioctl.h”

Syntax
BOOL KernelIoControl( IOCTL_HAL_GET_RESET_INFO,LPVOID 
lpInBuf,DWORD nInBufSize,LPVOID lpOutBuf,DWORD 
nOutBufSize,LPDWORD lpBytesReturned );

Parameters
lpInBuf Should be set to NULL.

lpInBufSize Should be set to zero.

lpOutBuf Must point to a HAL_RESET_INFO structure. See sample below.

nOutBufSize The size of HAL_RESET_INFO in bytes.

lpBytesReturned The number of bytes returned by the function.

Return Values
Returns TRUE if function succeeds. Returns FALSE if the function fails. 
May use GetLastError() to get the extended error value.
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Sample
typedef struct { 
DWORD ResetReason; // most recent reset type 
DWORD ObjectStoreState; // state of object store 
} HAL_RESET_INFO, * PHAL_RESET_INFO; 
 
// Reset reason types 
#define HAL_RESET_TYPE_UNKNOWN 0 
#define HAL_RESET_REASON_HARDWARE 1 // cold 
#define HAL_RESET_REASON_SOFTWARE 2 // suspend 
#define HAL_RESET_REASON_WATCHDOG 4 
#define HAL_RESET_BATT_FAULT 8 // power fail 
#define HAL_RESET_VDD_FAULT 16 // warm boot 
 
// Object store state flags 
#define HAL_OBJECT_STORE_STATE_UNKNOWN 0 
#define HAL_OBJECT_STORE_STATE_CLEAR 1 

IOCTL_HAL_GET_BOOT_DEVICE
This IOCTL code allows software to check which device CE booted from.

Usage
#include “oemioctl.h”

Syntax
BOOL KernelIoControl( IOCTL_HAL_GET_BOOT_DEVICE,LPVOID 
lpInBuf,DWORD nInBufSize,LPVOID lpOutBuf,DWORD 
nOutBufSize,LPDWORD lpBytesReturned );

Parameters
lpInBuf Should be set to NULL.

lpInBufSize Should be set to zero.

lpOutBuf Must point to a buffer large enough to hold a DWORD (4 bytes) 
that contains the boot device. These boot devices are supported: 
#define HAL_BOOT_DEVICE_UNKNOWN   0 
#define HAL_BOOT_DEVICE_ROM_XIP   1 
#define HAL_BOOT_DEVICE_ROM   2 
#define HAL_BOOT_DEVICE_PCMCIA_ATA   3 
#define HAL_BOOT_DEVICE_PCMCIA_LINEAR 4 
#define HAL_BOOT_DEVICE_IDE_ATA   5 
#define HAL_BOOT_DEVICE_IDE_ATAPI   6

nOutBufSize The size of lpOutBuf in bytes (4).

lpBytesReturned The number of bytes returned by the function.

Return Values
Returns TRUE if function succeeds. Returns FALSE if the function fails. 
May use GetLastError() to get the extended error value.
158 CN2B Mobile Computer User’s Manual



Chapter 7 —  Programming
IOCTL_HAL_REBOOT
Causes the system to perform a warm-boot. The object store is retained.

Usage
#include “oemioctl.h”

Syntax
BOOL KernelIoControl( IOCTL_HAL_REBOOT,LPVOID 
lpInBuf,DWORD nInBufSize,LPVOID lpOutBuf,DWORD 
nOutBufSize,LPDWORD lpBytesReturned );

Parameters
lpInBuf Should be set to NULL.

lpInBufSize Should be set to zero.

lpOutBuf Should be NULL.

nOutBufSize Should be zero.

Return Values
None.

IOCTL_PROCESSOR_INFORMATION
Returns processor information.

Usage
#include “pkfuncs.h”

Syntax
BOOL KernelIoControl( IOCTL_PROCESSOR_INFORMATION,LPVOID 
lpInBuf,DWORD nInBufSize,LPVOID lpOutBuf,DWORD 
nOutBufSize,LPDWORD lpBytesReturned );
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Parameters
lpInBuf Should be set to NULL.

nInBufSize Should be set to zero.

lpOutBuf Should be a pointer to the PROCESSOR_INFO structure. The 
PROCESSOR_INFO structure stores information that describes 
the CPU more descriptively. 
typedef __PROCESSOR_INFO { 
WORD wVersion; // Set to value 1 
WCHAR szProcessorCore[40]; // “ARM\0” 
WORD wCoreRevision; // 4 
WCHAR szProcessorName[40]; // “PXA255\0” 
WORD wProcessorRevision; // 0 
WCHAR szCatalogNumber[100]; // 0 
WCHAR szVendor[100]; // “Intel Corporation\0” 
DWORD dwInstructionSet; // 0 
DWORD dwClockSpeed; // 400 
}

nOutBufSize Should be set to sizeof(PROCESSOR_INFO) in bytes.

lpBytesReturned Returns sizeof(PROCESSOR_INFO);

Return Values
Returns TRUE if function succeeds. Returns FALSE if the function fails. 
May use GetLastError() to get the extended error value.

IOCTL_GET_CPU_ID
Returns Xscale processor ID.

Usage
#include “oemioctl.h”

Syntax
BOOL KernelIoControl( IOCTL_GET_CPU_ID,LPVOID lpInBuf, 
DWORD nInBufSize,LPVOID lpOutBuf,DWORD nOutBufSize,LPDWORD 
lpBytesReturned );

Parameters
lpInBuf Should point to a CPUIdInfo structure defined in OEMIO-

CTL.H.

lpInBufSize Should be sizeof(CPUIdInfo).

lpOutBuf Should be NULL.

nOutBufSize Should be set to 0.

lpBytesReturned Returns sizeof(PROCESSOR_INFO);

Return Values
Returns TRUE if function succeeds. Returns FALSE if the function fails. 
May use GetLastError() to get the extended error value.
160 CN2B Mobile Computer User’s Manual



Chapter 7 —  Programming
Network Selection APIs
The Network Selection APIs change the network adapter configuration 
programmatically. Both drivers support the same IOCTL function num-
bers for loading and unloading the drivers. Loading and unloading of the 
802.11b/g driver is performed by the FWL1: device in the system by per-
forming DeviceIOControl() calls to the driver. Loading and unloading of 
the driver for the built-in Ethernet adapter is performed by the SYI1: device 
in the system by performing DeviceIOControl() calls to the driver. 

• For loading an NDIS driver associated with an adapter, the IOCTL is 
IOCTL_LOAD_NDIS_MINIPORT.

• For unloading NDIS drivers associated with an adapter the IOCTL is 
IOCTL_UNLOAD_NDIS_MINIPORT.

Example
#include <winioctl.h> 
#include “sysio.h” 
void DoLoad(int nDevice) {  
LPTSTR devs[] = { _T(“SYI1:”), _T(“FWL1:”) }; 
HANDLE hLoaderDev; 
DWORD bytesReturned; 
hLoaderDev = CreateFile(devs[nDevice], GENERIC_READ|GENERIC_WRITE, 0, 
NULL, OPEN_EXISTING, 0, NULL); 
if (hLoaderDev != INVALID_HANDLE_VALUE) { 

if (!DeviceIoControl( hLoaderDev, IOCTL_LOAD_NDIS_MINIPORT, NULL, -1, 
NULL, 0,  

&bytesReturned, NULL)){ 
MessageBox(NULL, TEXT(“SYSIO IoControl Failed”), TEXT(“Network  
loader”),MB_ICONHAND); 
if (hLoaderDev!=INVALID_HANDLE_VALUE) CloseHandle(hLoaderDev); 
hLoaderDev = INVALID_HANDLE_VALUE; // bad handle 

}else { 
CloseHandle(hLoaderDev); 

} 
} 
} 
void DoUnload(int nDevice) { 
LPTSTR devs[] = { _T(“SYI1:”), _T(“FWL1:”) }; 
HANDLE hLoaderDev; 
DWORD bytesReturned; 
hLoaderDev = CreateFile(devs[nDevice], GENERIC_READ|GENERIC_WRITE, 0, 
NULL, OPEN_EXISTING, 0, NULL); 
if (hLoaderDev != INVALID_HANDLE_VALUE) { 

if (!DeviceIoControl( hLoaderDev, IOCTL_UNLOAD_NDIS_MINIPORT, NULL, -1, 
NULL, 0,  

&bytesReturned, NULL)){ 
MessageBox(NULL, TEXT(“SYSIO IoControl Failed”),TEXT(“Network  
loader”),MB_ICONHAND); 
if (hLoaderDev!=INVALID_HANDLE_VALUE) CloseHandle(hLoaderDev); 
hLoaderDev = INVALID_HANDLE_VALUE; // bad handle 

}else { 
CloseHandle(hLoaderDev); 

} 
} 
}

The API provided by Intermec exposes a limited set of routines for a pro-
grammer to access and affect the 802.11b/g network interface card from 
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within their application. The routines provided also reads/writes values to 
the CE registry pertaining to the 802.11b/g radio driver. By using the pro-
vided functions, a programmer can alter the 802.11b/g parameters of Net-
work Name (SSID), WEP keys, infrastructure modes, radio channel, and 
power management modes. A programmer can also retrieve network con-
nect status and signal strength indication from the RF network card.

The API is contained within the 80211API.DLL file that should be present 
in any load with the 802.11b/g networking installed.

NETWLAN.DLL 
PRISMNDS.DLL

This is the 802.11b/g driver. It is present in all CN2B CE loads that use the 802.11b/g net-
work interface card.

80211API.DLL This file is an Intermec authored file that provides the programmer with a set of API calls to 
configure or monitor status of the 802.11b/g network.

80211CONF.EXE This is the “Control Panel” for configuring the 802.11b/g network parameters. Note that it is 
an EXE file and is actually called by CPL802.CPL (see below).

CPL802.CPL A control panel application that does nothing but call 80211CONF.EXE.

80211SCAN.EXE Internally manages the Scan List activity.

802PM.DLL This handles profile management for radio configurable values.

URODDSVC.EXE This handles radio configuration and security authentication based on a selected profile.

The Profile Manager supports up to four radio configuration profiles. 
These profiles are the same as those set by the Wireless Network applet that 
runs on the Windows CE unit. You can configure different 802.11b/g pro-
files and switch between them using the 802.11 API. See the ConfigurePro-
file() function on page 176 for more information.

Basic Connect/Disconnect Functions
These functions are available when using the 802.11b/g radio module.

RadioConnect()
Connects to the available radio. Use this function if you plan on using a lot 
of API calls that talk directly to the radio. Note that the 802.11b/g radio 
must be enabled via NDISTRAY before you can connect to it.

Syntax UINT RadioConnect( );

Parameters None

Return Values ERROR_SUCCESS when successful, otherwise ERR_CONNECT_FAILED

Remarks Call this function before calling other functions found within this API. It hunts out and connects to 
the 802.11b/g radio available on the system. Check extended error codes if anything else is returned.

Definitions #ifdef DYNAMIC_LOADING 
typedef UINT (*PFN_RadioConnect)(); 
#else 
UINT RadioConnect(); 
#endif
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RadioDisconnect()
Call this function when done using the 802.11 API to clean up a connec-
tion from a previous RadioConnect() call. If you do not call this function, 
you may leave memory allocated.

Syntax UINT RadioDisconnect( );

Parameters None

Return Values ERROR_SUCCESS when successful, otherwise 
ERR_CONNECT_FAILED

Remarks None

Definitions #ifdef DYNAMIC_LOADING 
typedef UINT (*PFN_RadioDisconnect)(); 
#else 
UINT RadioDisconnect(); 
#endif

RadioDisassociate()
Call this function to have the 802.11b/g radio disassociate from the current 
service set. The radio then enters an “off” mode until it is woken again by 
setting the Service Set Identifier (SSID). Also, the NDIS driver generates an 
NDIS media disconnect event.

Syntax UINT RadioDisassociate( );

Parameters None

Return Values ERROR_SUCCESS on success, else ERR_CONNECT_FAILED

Remarks None

Definitions #ifdef DYNAMIC_LOADING 
typedef UINT (*PFN_RadioDisassociate)(); 
#else 
UINT RadioDisassociate(); 
#endif

Query Information Functions

GetAssociationStatus()
Call this to obtain the radio’s current association status with a service set.

Syntax UINT GetAssociationStatus( ULONG & );

Parameters NDIS_RADIO_ASSOCIATED Indicates the radio is associated with an access point

NDIS_RADIO_SCANNING Indicates radio is looking to associate with an access point

Return Values ERROR_SUCCESS when successful, ERR_QUERY_FAILED when the query failed, or 
ERR_CONNECT_FAILED if a connection with the radio failed.

Remarks Data is only valid if the function returns ERROR_SUCCESS. Also, if ERROR_SUCCESS is 
returned, your ULONG reference is populated by one of the parameters listed above.
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GetAuthenticationMode()
Call this function to obtain the radio’s current authentication mode.

Syntax UINT GetAuthenticationMode( ULONG & );

Parameters NDIS_RADIO_AUTH_MODE_OPEN 802.11 Open Authentication. Indicates that 
the radio is using an open system.

NDIS_RADIO_AUTH_MODE_SHARED 802.11 Shared Authentication. Indicates that 
the radio is using a shared key.

NDIS_RADIO_AUTH_MODE_AUTO Auto switch between Open/Shared. Indicates 
automatic detection is used when available.

NDIS_RADIO_AUTH_MODE_ERROR Defined as error value. Indicates authentication 
mode was not determined or is unknown.

NDIS_RADIO_AUTH_MODE_WPA WPA Authentication

NDIS_RADIO_AUTH_MODE_WPA_PSK WPA Preshared Key Authentication

NDIS_RADIO_AUTH_MODE_WPA_NONE WPA None

Return Values ERROR_SUCCESS when successful, ERR_QUERY_FAILED when the query failed, or  
ERR_CONNECT_FAILED if a connection with the radio failed.

Remarks Data is only valid if ERROR_SUCCESS is returned. Also, if ERROR_SUCCESS is returned, your 
USHORT reference is populated with one of the parameters listed above.

Definitions #ifdef DYNAMIC_LOADING 
typedef UINT (*PFN_GetAuthenticationMode)(ULONG &); 
#else 
UINT GetAuthenticationMode(ULONG &); 
#endif

GetBSSID()
Call this function to get the current MAC address (BSSID) of the service 
set. In ESS mode, this is the MAC address of the access point the radio is 
associated with. In IBSS mode, this is a randomly generated MAC address, 
and serves as the ID for the IBSS.

Definitions #ifdef DYNAMIC_LOADING 
typedef UINT (*PFN_GetAssociationStatus)(ULONG &); 
#else 
UINT GetAssociationStatus(ULONG &); 
#endif

Syntax UINT GetBSSID( TCHAR * );

Parameters Pointer to a character array, which is populated with the current 
BSSID after a successful call.

Return Values ERROR_SUCCESS when successful, ERR_QUERY_FAILED when 
the query failed, or ERR_CONNECT_FAILED if a connection with 
the radio failed.

Remarks If ERROR_SUCCESS is returned, your TCHAR array is populated 
with the BSSID of the current service set: xx-xx-xx-xx-xx-xx
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GetDiversity()
Call this function to get the current diversity setting of your 802.11b/g 
radio. This uses an optional NDIS5.1 OID to query the radio, of which a 
large number of 802.11b/g devices do not support. This may be inaccurate.

Syntax UINT GetDiversity(USHORT *);

Parameters None.

Return Values ERROR_SUCCESS when successful, ERR_QUERY_FAILED when 
the query failed, or ERR_CONNECT_FAILED if a connection with 
the radio failed.

Remarks If ERROR_SUCCESS is returned, your USHORT reference is popu-
lated with one of the parameters listed above.

Definitions #ifdef DYNAMIC_LOADING 
typedef UINT (*PFN_GetDiversity)(USHORT *); 
#else 
UINT GetDiversity(USHORT *); 
#endif

GetLinkSpeed()
Call this function to get the current link speed of the 802.11b/g radio.

Syntax UINT GetLinkSpeed( int & );

Parameters This accepts an int reference, and your int is populated with the cur-
rent link speed, in Mbps, rounded to the nearest whole integer, for 
example: 1, 2, 5, 11, etc. 

Return Values ERROR_SUCCESS when successful, ERR_QUERY_FAILED when 
the query failed, or ERR_CONNECT_FAILED if a connection with 
the radio failed.

Remarks Data returned is valid if ERROR_SUCCESS is returned.

Definitions #ifdef DYNAMIC_LOADING 
typedef UINT (*PFN_GetLinkSpeed)(int &); 
#else 
UINT GetLinkSpeed(int &); 
#endif

Definitions #ifdef DYNAMIC_LOADING 
typedef UINT (*PFN_GetBSSID)(TCHAR *); 
#else 
UINT GetBSSID(TCHAR *); 
#endif
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GetMac()
Call this function to get the MAC address of the 802.11b/g radio.

Syntax UINT GetMac( TCHAR * );

Parameters Pointer to a character array, which is populated with the MAC 
address after a successful call.

Return Values ERROR_SUCCESS when successful, ERR_QUERY_FAILED when 
the query failed, or ERR_CONNECT_FAILED if a connection with 
the radio failed.

Remarks If ERROR_SUCCESS is returned, your TCHAR array is populated 
with the formatted MAC address of the adapter, as follows: xx-xx-
xx-xx-xx-xx

Definitions #ifdef DYNAMIC_LOADING 
typedef UINT (*PFN_GetMac)(TCHAR *); 
#else 
UINT GetMac(TCHAR *); 
#endif

 

Note: Be sure to call RadioConnect() before calling this function for this 
function to work properly.

GetNetworkMode()
Call this function to get the current Network Mode (SSID) for the 
802.11b/g radio.

Syntax UINT GetNetworkMode( ULONG & );

Parameters NDIS_NET_MODE_IBSS 802.11 Ad-Hoc Mode.

NDIS_NET_MODE_ESS 802.11 Infrastructure Mode.

NDIS_NET_MODE_UNKNOWN Anything Else/Unknown Error

NDIS_NET_AUTO_UNKNOWN Automatic Selection. Use of this option is not 
supported or recommended.

NDIS_NET_TYPE_OFDM_5G 5 Gigahertz 54 Mbps

NDIS_NET_TYPE_OFDM_2_4G 802.11 2.4 Gigahertz

Return Values ERROR_SUCCESS when successful, ERR_QUERY_FAILED when the query failed, or 
ERR_CONNECT_FAILED if a connection with the radio failed.

Remarks If ERROR_SUCCESS is returned, your ULONG reference is populated with one of the parameters 
listed above.

Definitions #ifdef DYNAMIC_LOADING 
typedef UINT (*PFN_GetNetworkMode)(ULONG &); 
#else 
UINT GetNetworkMode(ULONG &); 
#endif
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GetNetworkType()
Call this function to get the current network type of the radio. Do not con-
fuse this with GetNetworkMode().

Syntax UINT GetNetworkType( ULONG & );

Parameters NDIS_NET_TYPE_FH Indicates this is a frequency hopping radio.

NDIS_NET_TYPE_DS Indicates that this is a direct sequence radio.

NDIS_NET_TYPE_UNDEFINED Indicates this radio is unknown or undefined.

Return Values ERROR_SUCCESS when successful, ERR_QUERY_FAILED when the query failed, or 
ERR_CONNECT_FAILED if a connection with the radio failed.

Remarks If ERROR_SUCCESS is returned, your ULONG reference is populated with one of the parameters 
listed above.

Definitions #ifdef DYNAMIC_LOADING 
typedef UINT (*PFN_GetNetworkType)(ULONG &); 
#else 
UINT GetNetworkType(ULONG &); 
#endif

GetSSID()
Call this function to get the desired SSID of the 802.11b/g radio.

Syntax UINT GetSSID( TCHAR * );

Parameters Pointer to a character array, which is populated with the current SSID 
when successful.

Return Values ERROR_SUCCESS when successful, ERR_QUERY_FAILED when 
the query failed, or ERR_CONNECT_FAILED if a connection with 
the radio failed.

Remarks If ERROR_SUCCESS is returned, your TCHAR array is populated 
with the desired SSID.

Definitions #ifdef DYNAMIC_LOADING 
typedef UINT (*PFN_GetSSID)(TCHAR *); 
#else 
UINT GetSSID(TCHAR *); 
#endif

Note: Call RadioConnect() before this function for this function to work 
properly.
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GetPowerMode()
Call this function to get the current power savings mode of the radio.

Syntax UINT GetPowerMode( ULONG & );

Parameters NDIS_RADIO_POWER_MODE_CAM Continuous Access Mode (ie: always on).

NDIS_RADIO_POWER_MODE_PSP Power Saving Mode.

NDIS_RADIO_POWER_UNKNOWN Unknown power mode.

NDIS_RADIO_POWER_AUTO Auto.

NDIS_RADIO_POWER_MODE_FAST_PSP Fast PSP, good savings, fast

Return Values ERROR_SUCCESS when successful, ERR_QUERY_FAILED when the query failed, or 
ERR_CONNECT_FAILED if a connection with the radio failed.

Remarks If ERROR_SUCCESS is returned, your ULONG reference is populated with one of the parameters 
listed above.

Definitions #ifdef DYNAMIC_LOADING 
typedef UINT (*PFN_GetPowerMode)(ULONG &); 
#else 
UINT GetPowerMode(ULONG &); 
#endif

Note: Do not use Automatic Switching mode at this time.

GetRSSI()
Call this function to get the current RSSI (Radio Signal Strength Indica-
tor), in Dbm.

Syntax UINT GetRSSI( ULONG & );

Parameters References a ULONG that is populated with the current RSSI after a 
successful call.

Return Values ERROR_SUCCESS when successful, ERR_QUERY_FAILED when 
the query failed, or ERR_CONNECT_FAILED if a connection with 
the radio failed.

Remarks If ERROR_SUCCESS is returned, your ULONG reference contains 
the RSSI. Valid RSSI range is from -100 Dbm to -30 Dbm.

Definitions #ifdef DYNAMIC_LOADING 
typedef UINT (*PFN_GetRSSI)(ULONG &); 
#else 
UINT GetRSSI(ULONG &); 
#endif
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GetTXPower()
Call this function to get the current transmit power of the radio.

Syntax UINT GetTXPower( ULONG & );

Parameters NDIS_POWER_LEVEL_63 63 mW

NDIS_POWER_LEVEL_30 30 mW

NDIS_POWER_LEVEL_15 15 mW

NDIS_POWER_LEVEL_5 5 mW

NDIS_POWER_LEVEL_1 1 mW

NDIS_POWER_LEVEL_UNKNOWN Unknown Value or Error.

Return Values ERROR_SUCCESS when successful, ERR_QUERY_FAILED when the query failed, or 
ERR_CONNECT_FAILED if a connection with the radio failed.

Remarks If ERROR_SUCCESS is returned, your ULONG reference is populated with the TX power in mil-
liwatts (mW). Valid ranges are from 5 mW to 100 mW.

Definitions #ifdef DYNAMIC_LOADING 
typedef UINT (*PFN_GetTXPower)(ULONG &); 
#else 
UINT GetTXPower(ULONG &); 
#endif

GetWepStatus()
Call this to get the current state of the radio’s WEP and encryption levels.

Syntax UINT GetWepStatus( ULONG & );

Parameters NDIS_ENCRYPTION_1_ENABLED WEP enabled; TKIP, AES not enabled, and 
transmit key may or may not be available.

NDIS_ENCRYPTION_DISABLED Indicates AES, TKIP, WEP disabled, and trans-
mit key available.

NDIS_ENCRYPTION_NOT_SUPPORTED Indicates WEP, TKIP, AES not supported.

NDIS_ENCRYPTION_1_KEY_ABSENT Indicates AES, TKIP, WEP disabled, and trans-
mit key not available.

NDIS_ENCRYPTION_2_ENABLED Indicates TKIP, WEP enabled; AES not enabled, 
and transmit key available.

NDIS_ENCRYPTION_2_KEY_ABSENT Indicates no transmit keys available for TKIP, 
WEP, TKIP, WEP enabled; AES not enabled. 

NDIS_ENCRYPTION_3_ENABLED Indicates AES, TKIP, WEP enabled, and trans-
mit key available.

NDIS_ENCRYPTION_3_KEY_ABSENT Indicates no transmit keys available for AES, 
TKIP, WEP, AES, TKIP, WEP enabled.

Return Values ERROR_SUCCESS when successful, ERR_QUERY_FAILED when the query failed, or 
ERR_CONNECT_FAILED if a connection with the radio failed.

Remarks If ERROR_SUCCESS returned, ULONG reference is populated with a parameter listed above.
CN2B Mobile Computer User’s Manual 169



Chapter 7 — Programming
GetRadioIpAddress()
Call this function to obtain a formatted string indicating whether DHCP is 
enabled, and what is the current adapters IP address.

Syntax UINT GetRadioIpAddress( TCHAR * );

Parameters Pointer to a character array that contains the formatted string of the 
IP address and static/DHCP information.

Return Values ERROR_SUCCESS when successful, ERR_QUERY_FAILED when 
the query failed, or ERR_CONNECT_FAILED if a connection with 
the radio failed.

Remarks If ERROR_SUCCESS is returned, your TCHAR array contains a 
string formatted as follows: 
IP: DHCP Enabled\nxxx.xxx.xxx.xxx\n or  
IP: DHCP Disabled\nxxx.xxx.xxx.xxx\n

Definitions #ifdef DYNAMIC_LOADING 
typedef UINT (*PFN_GetRadioIpAddress)(TCHAR *); 
#else 
UINT GetRadioIpAddress(TCHAR *); 
#endif

GetCCXStatus()
Call this to get information about the current CCX status of the adapter.

Syntax UINT GetCCXStatus( ULONG & );

Parameters NDIS_NETWORK_EAP_MODE_OFF Disable EAP mode.

NDIS_NETWORK_EAP_MODE_ON Enable EAP mode.

Return Values ERROR_SUCCESS when successful, ERR_QUERY_FAILED when the query failed, or 
ERR_CONNECT_FAILED if a connection with the radio failed.

Remarks If ERROR_SUCCESS is returned, your ULONG reference is populated with one of parameters 
listed above.

Definitions #ifdef DYNAMIC_LOADING 
typedef UINT (*PFN_GetCCXStatus)(ULONG &); 
#else 
UINT GetCCXStatus(ULONG &); 
#endif

Definitions #ifdef DYNAMIC_LOADING 
typedef UINT (*PFN_GetWepStatus)(ULONG &); 
#else 
UINT GetWepStatus(ULONG &); 
#endif
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Set Information Functions

AddWep()
Call this function to add a WEP key to the radio. Call this function multi-
ple times when adding more than one WEP key. Save the “default” key for 
last. For example, when adding four keys, and the second key is the default 
transmit key, add keys 1, 3 and 4 before you add key 2.
Note: Add the default transmit key last.

Syntax UINT AddWep( ULONG, BOOL, TCHAR * );

Parameters ULONG Specifies the key index to be set. Valid values are 0-3.

BOOL When set to TRUE, specifies that this key is the default transmit key.

TCHAR Pointer to a character array that specifies the key data in either HEX (length of 10 
or 26) or ASCII (length of 5 or 13). This string must be null-terminated.

Return Values ERROR_SUCCESS when successful, ERR_QUERY_FAILED when the query failed, or 
ERR_CONNECT_FAILED if a connection with the radio failed.

Remarks When adding WEP keys to the radio, turn off encryption before you add the keys, then turn encryp-
tion back on afterwards. Also, be sure to add the TRANSMIT KEY last.

Definitions #ifdef DYNAMIC_LOADING 
typedef UINT (*PFN_AddWep)(ULONG, BOOL, TCHAR *); 
#else 
UINT AddWep(ULONG, BOOL, TCHAR *); 
#endif

EnableWep()
Enables or disables WEP encryption on the radio (TRUE/FALSE).

Syntax UINT EnableWep( BOOL );

Parameters Set BOOL to TRUE to enable WEP encryption, or FALSE to disable 
WEP encryption.

Return 
Values

ERROR_SUCCESS when successful, ERR_QUERY_FAILED when 
the query failed, or ERR_CONNECT_FAILED if a connection with 
the radio failed.

Remarks Call this function with TRUE as the parameter to enable WEP encryp-
tion. Call this function with the FALSE parameter to disable WEP 
encryption. This call is an alias for EncryptionStatus(). See the following: 
EnableWEP(TRUE) = EncryptionSta-
tus(NDIS_ENCRYPTION_1_ENABLED) 
EnableWEP(FALSE) = EncryptionSta-
tus(NDIS_ENCRYPTION_DISABLED)

Definitions #ifdef DYNAMIC_LOADING 
typedef UINT (*PFN_EnableWep)(BOOL); 
#else 
UINT EnableWep(BOOL); 
#endif
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EncryptionStatus()
Call this function to set the desired encryption status.

Syntax UINT EncryptionStatus( UINT mode );

Parameters NDIS_ENCRYPTION_1_ENABLED WEP is enabled; TKIP and AES are not enabled, 
and a transmit key may or may not be available. 
(same as NDIS_RADIO_WEP_ENABLED)

NDIS_ENCRYPTION_DISABLED Indicates that AES, TKIP, and WEP are dis-
abled, and a transmit key is available. (Same as 
NDIS_RADIO_WEP_DISABLED)

NDIS_ENCRYPTION_NOT_SUPPORTED Indicates that encryption (WEP, TKIP, and 
AES) is not supported. (Same as 
NDIS_RADIO_WEP_NOT_SUPPORTED)

NDIS_ENCRYPTION_1_KEY_ABSENT Indicates that AES, TKIP, and WEP are dis-
abled, and a transmit key is not available. (Same 
as NDIS_RADIO_WEP_ABSENT)

NDIS_ENCRYPTION_2_ENABLED Indicates that TKIP and WEP are enabled; AES 
is not enabled, and a transmit key is available.

NDIS_ENCRYPTION_2_KEY_ABSENT Indicates no transmit keys available for use by 
TKIP or WEP (enabled) and AES is not enabled. 

NDIS_ENCRYPTION_3_ENABLED Indicates that AES, TKIP, and WEP are enabled, 
and a transmit key is available.

NDIS_ENCRYPTION_3_KEY_ABSENT Indicates there are no transmit keys available for 
use by AES, TKIP, or WEP, which are enabled.

Return Values ERROR_SUCCESS when successful, ERR_QUERY_FAILED when the query failed, or 
ERR_CONNECT_FAILED if a connection with the radio failed.

Remarks None.

Definitions #ifdef DYNAMIC_LOADING 
typedef UINT (*PFN_EncryptionStatus)(UINT mode);  
#else 
UINT EncryptionStatus(UINT mode);  
#endif
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SetAuthenticationMode()
Call this function to set the desired authentication mode.

Syntax UINT SetAuthenticationMode( ULONG );

Parameters NDIS_RADIO_AUTH_MODE_OPEN 802.11 Open Authentication. Indicates that 
the radio is using an open system.

NDIS_RADIO_AUTH_MODE_SHARED 802.11 Shared Authentication. Indicates that 
the radio is using a shared key.

NDIS_RADIO_AUTH_MODE_AUTO Auto switch between Open/Shared. Indicates 
automatic detection is used when available.

NDIS_RADIO_AUTH_MODE_ERROR Defined as error value. Indicates the authenti-
cation mode was not determined at this time or 
is unknown.

NDIS_RADIO_AUTH_MODE_WPA WPA Authentication

NDIS_RADIO_AUTH_MODE_WPA_PSK WPA Preshared Key Authentication

NDIS_RADIO_AUTH_MODE_WPA_NONE WPA None

Return Values ERROR_SUCCESS when successful, ERR_QUERY_FAILED when the query failed, or 
ERR_CONNECT_FAILED if a connection with the radio failed.

Remarks None.

Definitions #ifdef DYNAMIC_LOADING 
typedef UINT (*PFN_SetAuthenticationMode)(ULONG); 
#else 
UINT SetAuthenticationMode(ULONG); 
#endif

SetChannel()
This function is currently not implemented. Ad-hoc networks automati-
cally select a channel or use the already existing channel.

Syntax UINT SetChannel( USHORT );

Parameters USHORT value that should populate with the desired channel (1-
14).

Return Values None.

Remarks None.

Definitions #ifdef DYNAMIC_LOADING 
typedef UINT (*PFN_SetChannel)(USHORT); 
#else 
UINT SetChannel(USHORT); 
#endif
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SetNetworkMode()
Call this function to set the desired Network Mode.

Syntax UINT SetNetworkMode( ULONG );

Parameters NDIS_NET_MODE_IBSS 802.11 Ad-Hoc Mode.

NDIS_NET_MODE_ESS 802.11 Infrastructure Mode.

NDIS_NET_MODE_UNKNOWN Anything Else/Unknown Error

NDIS_NET_AUTO_UNKNOWN Automatic Selection. Use of this option is not 
supported or recommended.

NDIS_NET_TYPE_OFDM_5G 5 Gigahertz 54 Mbps

NDIS_NET_TYPE_OFDM_2_4G 802.11 2.4 Gigahertz

Return Values ERROR_SUCCESS when successful, ERR_QUERY_FAILED when the query failed, or 
ERR_CONNECT_FAILED if a connection with the radio failed.

Remarks None.

Definitions #ifdef DYNAMIC_LOADING 
typedef UINT (*PFN_SetNetworkMode)(ULONG); 
#else 
UINT SetNetworkMode(ULONG); 
#endif

SetPowerMode()
Call this function to set the desired power mode.

Syntax UINT SetPowerMode( ULONG mode );

Parameters NDIS_RADIO_POWER_MODE_CAM Continuous Access Mode (ie: always on).

NDIS_RADIO_POWER_MODE_PSP Power Saving Mode.

NDIS_RADIO_POWER_UNKNOWN Unknown power mode.

NDIS_RADIO_POWER_AUTO Auto.

NDIS_RADIO_POWER_MODE_FAST_PSP Fast PSP, good savings, fast

Return Values ERROR_SUCCESS when successful, ERR_QUERY_FAILED when the query failed, or 
ERR_CONNECT_FAILED if a connection with the radio failed.

Remarks None.

Definitions #ifdef DYNAMIC_LOADING 
typedef UINT (*PFN_SetPowerMode)(ULONG mode); 
#else 
UINT SetPowerMode(ULONG mode); 
#endif
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SetSSID()
Call this function with a pointer to a null-terminated TCHAR array con-
taining the desired SSID to set the desired SSID of the adapter.

Syntax UINT SetSSID( TCHAR * );

Parameters Pointer to a character array that contains the desired SSID. This should be null-terminated.

Return Values ERROR_SUCCESS when successful, ERR_QUERY_FAILED when the query failed, or 
ERR_CONNECT_FAILED if a connection with the radio failed.

Remarks If an “ANY” network is desired, pass in _T(“ANY”).

Definitions #ifdef DYNAMIC_LOADING 
typedef UINT (*PFN_SetSSID)(TCHAR *); 
#else 
UINT SetSSID(TCHAR *); 
#endif

SetCCXStatus()
Call this function to set the desired CCX / Network EAP status.

Syntax UINT SetCCXStatus( ULONG );

Parameters NDIS_NETWORK_EAP_MODE_OFF Disable Network EAP / CCX

NDIS_NETWORK_EAP_MODE_ON Enable Network EAP / CCX

Return Values ERROR_SUCCESS when successful, ERR_QUERY_FAILED when the query failed, or 
ERR_CONNECT_FAILED if a connection with the radio failed.

Remarks None.

Definitions #ifdef DYNAMIC_LOADING 
typedef UINT (*PFN_SetCCXStatus)(ULONG); 
#else 
UINT SetCCXStatus(ULONG); 
#endif

SetMixedCellMode()
Call this function to set the desired mixed cell mode.

Syntax UINT SetMixedCellMode( ULONG );

Parameters NDIS_MIXED_CELL_OFF Disable Mixed Cell

NDIS_MIXED_CELL_ON Enable Mixed Cell

Return Values ERROR_SUCCESS when successful, ERR_QUERY_FAILED when the query failed, or 
ERR_CONNECT_FAILED if a connection with the radio failed.

Remarks None.

Definitions #ifdef DYNAMIC_LOADING 
typedef UINT (*PFN_SetMixedCellMode)(ULONG); 
#else 
UINT SetMixedCellMode(ULONG); 
#endif
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RemoveWep()
Call this with a key index of 0-3 to remove the WEP key at that index.

Syntax UINT RemoveWep( ULONG );

Parameters ULONG value that specifies the key index to set. Valid values are 0-3.

Return Values ERROR_SUCCESS when successful, ERR_QUERY_FAILED when fails, or 
ERR_CONNECT_FAILED if connection with radio fails.

Remarks On disassociation with all BSSIDs of the current service set, WEP key is removed by the adapter.

Definitions #ifdef DYNAMIC_LOADING 
typedef UINT (*PFN_RemoveWEP)(ULONG); 
#else 
UINT RemoveWEP(ULONG); 
#endif

Helper Functions

ConfigureProfile()
If using the Intermec 802.11 Profile Management system, you can pass a 
specific profile name to program the API to configure the radio.

Syntax UINT ConfigureProfile( TCHAR * );

Parameters Pointer to a character array that contains the profile name. This should be null-terminated.

Return Values ERROR_SUCCESS when successful, ERR_QUERY_FAILED when the query failed, or 
ERR_CONNECT_FAILED if a connection with the radio failed.

Remarks Call this function with a pointer to a null-terminated TCHAR array that contains the name of the 
profile you wish to configure. This function reads profile data from the profile manager, sets that 
profile as the default active profile, and configures the radio appropriately. If needed, the supplicant 
and any other related services are automatically started and stopped.

Definitions #ifdef DYNAMIC_LOADING 
typedef UINT (*PFN_ConfigureProfile)(TCHAR *); 
#else 
UINT ConfigureProfile(TCHAR *); 
#endif
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EnableZeroConfig()
This enables or disables the Wireless Zero Configuration Wizard from 
Microsoft. After calling this function, a warm-boot is required for the 
change to take effect. Note that enabling this effectively disables all SET com-
mands in this API.

Syntax UINT EnableZeroConfig( USHORT );

Parameters TRUE Enable Wireless Zero Config

FALSE Disable Wireless Zero Config

Return Values ERROR_SUCCESS when successful, ERR_ZERO_CONFIG_CHANGE_FAILED when the 
query failed.

Remarks Call this function to set the desired Zero Config status.

Definitions #ifdef DYNAMIC_LOADING 
typedef UINT (*PFN_EnableZeroConfig)(USHORT); 
#else 
UINT EnableZeroConfig(USHORT); 
#endif

isZeroConfigEnabled()
Call this function to determine whether Zero Config is currently enabled.

Syntax UINT isZeroConfigEnabled( );

Parameters None.

Return Values TRUE if ZeroConfig is enabled, and FALSE if it is disabled.

Remarks None.

Definitions #ifdef DYNAMIC_LOADING 
typedef UINT (*PFN_isZeroConfigEnabled)(); 
#else 
UINT isZeroConfigEnabled(); 
#endif

isSupplicantRunning()
Call this function to determine whether the security supplicant is running.

Syntax UINT isSupplicantRunning( );

Parameters None.

Return Values TRUE if the security supplicant is running, FALSE if not running.

Remarks None.

Definitions #ifdef DYNAMIC_LOADING 
typedef UINT (*PFN_isSupplicantRunning)(); 
#else 
UINT isSupplicantRunning(); 
#endif
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StartScanList()
If a scan list is configured on the system, this causes the API to begin the 
process of scanning for an available network. This call can take quite a 
while to process (depending upon the length of the scan list and how long it 
takes to find a valid network), you may wish to call it from a separate thread.

Syntax UINT StartScanList( );

Parameters None.

Return Values ERROR_SUCCESS when successful.

Remarks Call this function to start the scan list functionality of the system.

Definitions #ifdef DYNAMIC_LOADING 
typedef UINT (*PFN_StartScanList)(); 
#else 
UINT StartScanList(); 
#endif

StartSupplicant()
Call this to start the supplicant service if it is installed on the system.

Syntax UINT StartSupplicant( );

Parameters None.

Return Values ERROR_SUCCESS when successful.

Remarks None.

Definitions #ifdef DYNAMIC_LOADING 
typedef UINT (*PFN_StartSupplicant)(); 
#else 
UINT StartSupplicant(); 
#endif

StopSupplicant()
Call this function to stop the supplicant service.

Syntax UINT StopSupplicant( );

Parameters None.

Return Values ERROR_SUCCESS when successful.

Remarks None.

Definitions #ifdef DYNAMIC_LOADING 
typedef UINT (*PFN_StopSupplicant)(); 
#else 
UINT StopSupplicant(); 
#endif
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isDHCPEnabled()
Call this to determine whether DHCP is enabled on the current adapter.

Syntax UINT isDHCPEnabled( );

Parameters None.

Return Values TRUE if DHCP is enabled, FALSE if it is not.

Remarks None.

Definitions #ifdef DYNAMIC_LOADING 
typedef UINT (*PFN_isDHCPEnabled)(); 
#else 
UINT isDHCPEnabled(); 
#endif

RenewDHCP()
Call this to force a DHCP renewal on the current network adapter.

Syntax UINT RenewDHCP( );

Parameters None.

Return Values ERROR_SUCCESS when successful.

Remarks You should not have to call this function.

Definitions #ifdef DYNAMIC_LOADING 
typedef UINT (*PFN_RenewDHCP)(); 
#else 
UINT RenewDHCP(); 
#endif

GetCurrentDriverName()
Call this function to populate the TCHAR array with the driver name.

Syntax UINT GetCurrentDriverName( TCHAR * );

Parameters Pointer to a TCHAR array which contains the name of the driver when successful.

Return Values ERROR_SUCCESS when successful.

Remarks This function is called with a pointer to a TCHAR array that is large enough to hold the name of the 
driver PLUS the null terminator.

Definitions #ifdef DYNAMIC_LOADING 
typedef UINT (*PFN_GetCurrentDriverName)(TCHAR *); 
#else 
UINT GetCurrentDriverName(TCHAR *); 
#endif
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ResetRadioToSystemSave()
Call this function to force the radio to reset to the last desired active profile.

Syntax UINT ResetRadioToSystemSave( );

Parameters None.

Return Values ERROR_SUCCESS when successful.

Remarks None.

Definitions #ifdef DYNAMIC_LOADING 
typedef UINT (*PFN_ResetRadioToSystemSave)(); 
#else 
UINT ResetRadioToSystemSave(); 
#endif

EnableSuppLogging()
Call this function to set the desired supplicant logging mode.

Syntax UINT EnableSuppLogging( ULONG );

Parameters NDIS_SUPP_LOGGING_ON Supplicant Logging Enabled

NDIS_SUPP_LOGGING_OFF Supplicant Logging Disabled

Return Values ERROR_SUCCESS when successful.

Remarks None.

Definitions #ifdef DYNAMIC_LOADING 
typedef UINT (*PFN_EnableSuppLogging)(ULONG); 
#else 
UINT EnableSuppLogging(ULONG); 
#endif

SwitchPacketDriver()
Call this function to switch between available packet drivers on the system.

Syntax UINT SwitchPacketDriver( USHORT );

Parameters INTERMEC_PACKET_DRIVER Intermec Packet Driver (ZNICZIO)

NDISUIO_PACKET_DRIVER Microsoft Packet Driver (NDISUIO)

Return Values ERROR_SUCCESS when successful.

Remarks After switching to a new packet driver, perform a warm boot for changes to take effect.

Definitions #ifdef DYNAMIC_LOADING 
typedef UINT (*PFN_SwitchPacketDriver)(USHORT); 
#else 
UINT SwitchPacketDriver(USHORT); 
#endif
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Notifications
Use the following information to programmatically control the vibrator, to 
write an application to turn on the vibrator when a message is received via 
the WLAN radio link, and turn it off when the user hits a key.

Vibrator support is implemented in the NLED driver as a false LED. The 
vibrator is LED 5 and is identified with an CycleAdjust of -1. The vibrate 
option is only available in the notifications panel when the vibrator is 
present in the system.

Regarding an applications interface to NLED.DLL, LEDs must be avail-
able for use by applications. This is possible via two functions exported by 
the COREDLL.DLL file. To use the LED functions, declare these as extern 
“C” as follows:

extern ”C” BOOL WINAPI NLEDGetDeviceInfo(UINT nInfoId, 
void *pOutput); 
extern ”C” BOOL WINAPI NLEDSetDevice( UINT nDeviceId, void 
*pInput);

The LEDs are enumerated for access through the data structures associated 
with these APIs: Notification LED (0), Alpha Lock LED (2), Scanner LED 
(3), or Low Battery (4).

NLEDGetDeviceInfo

Usage
#include “nled.h”

Syntax
BOOL NLEDGetDeviceInfo ( UINT nInfoId, void *pOutput );

Parameters
nInfoId Integer specifying the information to return. These values are defined:

NLED_COUNT_INFO Indicates the pOutput buffer specifies the number of LEDs 
on the device.

NLED_SUPPORTS_INFO_ID Indicates the pOutput buffer specifies information about the 
capabilities supported by the LED.

NLED_SETTINGS_INFO_ID Indicates the pOutput buffer contains information about the 
LED current settings.

pOutput Pointer to the buffer to which the information is returned. The buffer points to various structure 
types defined in “nled.h”, depending on the value of nId, as detailed in the following table:

Value of nID 
LED_COUNT_INFO 
NLED_SUPPORTS_INFO 
NLED_SETTINGS_INFO

Structure in pOutput 
NLED_COUNT_INFO 
NLED_SUPPORTS_INFO 
NLED_SETTINGS_INFO
CN2B Mobile Computer User’s Manual 181



Chapter 7 — Programming
NLEDSetDevice

Usage
#include “nled.h”

Syntax
BOOL NLEDSetDevice ( UINT nDeviceId, void *pInput );

Parameters
nDeviceId Integer specifying the device identification. The following is defined:

NLED_SETTINGS_INFO_ID Contains information about the desired LED settings.

pInput Pointer to the buffer that contains the NLED_SETTINGS_INFO structure.

Reboot Functions
There are several methods, via Kernel I/O Control functions, that an appli-
cation program can use to force the CN2B Computer to reboot.

IOCTL_HAL_REBOOT
IOCTL_HAL_REBOOT performs a warm-boot. See page 159.

IOCTL_HAL_COLDBOOT
Invoking with this forces a cold reboot, resets the CN2B Computer, reloads 
Windows CE as if a power-up was performed, and discards the contents of 
the Windows CE RAM-based object. See page 157.

IOCTL_HAL_WARMBOOT
This function is supported on CN2B Computers. It performs a warm boot 
of the system, preserving the object store. See page 156.

Remapping the Keypad
Note: Only experienced application developers should perform this func-
tion of remapping the keypad. Data within the CN2B Computer could be 
lost should any problems occur.

Applications have the ability to remap keys on the CN2B keypad. This 
allows applications to enable keys that would otherwise not be available, 
such as the [F1] function key. Also, to disable keys that should not be avail-
able, such as the alpha key because no alpha entry is required. Use caution 
when attempting to remap the keypad because improper remapping may 
cause the keypad to become unusable. This can be corrected by performing 
a cold-boot on the device that reloads the default keymap.
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Choosing How to Change Keypad Registry Settings
There are several ways to change the keypad registry settings:

• You can use a registry editing program to change the keypad registry 
entries. You can run the Microsoft eMbedded Visual C++ Remote Regis-
try Editor on your PC, using ActiveSync to connect to the CN2B Com-
puter. Or you can download and run a third-party registry editing 
program on your CN2B Computer. After you make your changes, you 
need to perform a warm boot on the CN2B Computer for the changes to 
take effect. For help, see “Performing a Warm-Boot” on page 11.

• You can write an application to change the keypad registry entries. An 
application gives you a convenient way to customize multiple CN2B 
Computers. Make sure your application sets the named event 
KeybdSettingsChangeEvent after you change the registry entries for the 
changes to take effect.

• You can use a .CAB file to edit the registry. You can install the 
_ResetMePlease_.txt file in your .CAB file to force a warm boot to acti-
vate the changes.

Note that remapping the keys in this way affects the key mapping for the 
entire system, not just for the application that does the remapping.

Planes
There are three “planes” supported for the CN2B keypad. Keys used in 
more than one shift plane must be described in each plane.

Unshifted Plane
The unshifted plane contains values from the keypad when not pressed 
with other keys, such as the following:

Press the Key To Enter This

[1] 1

[5] 5

[9] 9

Orange Plane
The orange plane contains values from the keypad when a key is simulta-
neously pressed with the orange key, such as the following:

Press the Keys To Enter This

orange [0] Start menu

orange [6] A4

orange [9] PgDn
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Alpha (Green) Plane
The alpha plane contains values from the keypad when the keypad has been 
placed in alpha mode by pressing the green [Alpha] key, such as:

Press the Keys To Enter This

[Alpha] [1] Caps

[Alpha] [5] j

[Alpha] [9] w

Locating the Registry Settings for Your Key Values
Key values for each plane are stored in the registry. All units ship with a 
default key mapping loaded in the registry. Applications that change the 
default mapping need to read the appropriate key from the registry into an 
array of words, modify the values required and then write the updated val-
ues back into the registry. The registry access can be done with standard 
Microsoft API calls, such as RegOpenKeyEx(), RegQueryValueEx(), and 
RegSetValueEx(). These registry keys contain the plane mappings:

• The unshifted plane mapping can be found in the registry at: 
HKEY_LOCAL_MACHINE\HARDWARE\DEVICEMAP\KEYBD\Vkey

• The orange plane mapping can be found in the registry at: 
HKEY_LOCAL_MACHINE\HARDWARE\DEVICEMAP\KEYBD\VkeyGold

• The alpha plane mapping can be found in the registry at: 
HKEY_LOCAL_MACHINE\HARDWARE\DEVICEMAP\KEYBD\VkeyAlpha

How Key Values Are Stored in the Registry
To know which fields to update in the registry, you must know what Scan 
Codes are assigned to each physical key (see page 185). The Scan Code is 
used at the lowest level of the system to let the keypad driver know which 
physical key is pressed. The keypad driver takes that scan code and looks it 
up in a table (a copy of the table in the registry) to determine the values to 
pass to the operating system.

Each registry key is just an array that describes to the keypad driver what 
value needs to be passed for each physical key. The key values are indexed 
by the scan code, this is a zero-based index. For example in the unshifted 
plane, the [4] key has a scan code of 0x06. This means that the seventh 
word under the “Vkey” registry key has the value for the [4] key. Taking a 
sample of the “Vkey” registry key shows the following values:

00,00,0B,05,02,03,C1,07,04,03,BE,00,34,00,00,00,. . .

The value is 34,00. The values are in reverse byte order because that is the 
way the processor handles data. When writing an application, nothing 
needs to be done to swap the bytes, as this will happen automatically when 
the data is read into a byte value. This is something you just need to be 
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aware of when looking at the registry. Knowing this, we can see that the 
value that the keypad driver will pass to the system is a hex 34. Looking that 
up on an UNICODE character chart, we see that it maps to a “4”. If you 
wanted the key, labeled “4”, to output the letter “A” instead, you would 
need to change the seventh word to “41” (the hexadecimal representation 
of “A” from the UNICODE chart), then put the key back into the registry.
Note: Do not remap scan codes 0x01, 0x41, 0x42, 0x43, or 0x44, or the 
CN2B Computer becomes unit unusuable until a cold-boot is performed.

If you wish to disable a certain key, remap its scan code to 0x00.

Change Notification
Just changing the registry keys do not immediately change the key map-
pings. Signal the “ITC_KEYBOARD_CHANGE” named event using the 
CreateEvent() API to notify the keypad driver the registry was updated.

Advanced Keypad Remapping
It is also possible to map multiple key presses to one button and to map 
named system events to a button. The multiple key press option could be 
useful to cut down on the number of keys needed to press in a given situa-
tion or to remap which key behaves like the action key. Mapping events to 
a button could be useful to change which buttons will fire the scanner, con-
trol volume, and allow for suspending and resuming the device. If you need 
help performing one of these advanced topics please contact Intermec 
Technical Support.

Scan Codes
At the lowest driver level, the CN2B keypad identifies keys as scan codes. 
These scan codes are sent via the keypad microcontroller, and cannot be 
changed without modifying the keypad firmware.

Keypad Scan Codes and Registry Entries 

Press this Key Meaning Scan Code Registry Entry

Reserved 0x00

[I/O] I/O button 0x01

Scanner Handle Trigger 0x100 #define VK_SCAN3

Scanner Left 0x03 Fkeycode9

Scanner Right 0x05 Fkeycode10

[4] 4/GHI/A2 0x06 Fkeycode17
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None 0x07

Left arrow/Back Tab 0x08 Fkeycode2

None 0x09

[BkSp] BkSp// (forward slash) 0x0A Fkeycode2

orange orange key 0x0B Fkeycode3

None 0x0C

[Esc] Esc/– (minus sign) 0x0D Fkeycode20

[v] Down arrow 0x0E Fkeycode8

[1] 1/Caps 0x0F Fkeycode23

[7] 7/PQRS/PgUp 0x10 Fkeycode27

[Alpha] [Alpha] key 0x11 Fkeycode24

None 0x12

[^] Up arrow/Volume increase 0x13 Fkeycode7

Right arrow/Tab 0x14 Fkeycode5

[2] 2/ABC 0x15 Fkeycode7

[8] 8/TUV/* (asterisk) 0x16 Fkeycode8

[0] 0/Win 0x17 Fkeycode26

[5] 5/JKL/A3 0x18 Fkeycode16

None 0x19

[Action] Action/+ (plus symbol) 0x1A

[3] 3/DEF/backlight 0x1B Fkeycode21

[9] 9/WXYZ/PgDn 0x1C Fkeycode25

[ENTER] Enter/@ (at symbol) 0x1D Fkeycode6

[6] 6/MNO/A4 0x1E Fkeycode18

None 0x1F-0x40

Charge Detect 0x41

LCD frontlight 0x42

Ambient light 0x42

Keypad Scan Codes and Registry Entries (continued)

Press this Key Meaning Scan Code Registry Entry
186 CN2B Mobile Computer User’s Manual



Chapter 7 —  Programming
Understanding Keypad Attributes
The keypad attributes are as follows.

• “OrangeObeyClear” = dword:0

• “OrangeOneShot” = dword:1

• “GreenObeyClear” = dword:0

• “GreenOneShot” = dword:0

• “MultimapTimeout” = dword:258 (see next section for a description)

When you press the Orange B key or Green C key, a timer starts and 
will turn Orange or Green mode off after three seconds. To force Orange 
or Green mode to stay active after the timer has expired (which is also called 
“locking” the mode) you must set *ObeyClear to 0.

When you press a key in Orange or Green mode, the orange or green func-
tion for that key is produced and Orange or Green mode is turned off. To 
force Orange or Green mode to stay active after a key has been pressed 
(which is also called “locking” the mode) you must set *OneShot to 0.

Creating Multiple Key Definitions
In the case of multiple key definitions, the first byte is the number of possi-
ble keys (in words) that key physical key can cycle between. The second 
byte must be 0x80 (this is what makes it a multi-key definition). The values 
following should be two bytes for each possible key.

Multiple key definitions can also be used for FkeyCode and FkeyMeta 
mappings. In multi-key mode, only one VK code can be emitted by the 
key.

MultimapTimeout is the number of milliseconds you have to press the key 
again before the current selection is emitted. The default is 258, which 
equals 600ms (0.6 seconds).

To understand MultimapTimeout, consider the numeric keypad. When 
you press the Green C key and the [2] key, you have selected the “a” 
character. You have 0.6 seconds to press the [2] key again for “b.” If you do 

Threshold crossed 0x42

Headset detected 0x43

Keypad Backlight 0x44

Ambient Light 0x44

Threshold Crossed 0x44

Keypad Scan Codes and Registry Entries (continued)

Press this Key Meaning Scan Code Registry Entry
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not press a key within 0.6 seconds, the “a” is emitted. If you press another 
key within 0.6 seconds, the timeout is cancelled, the “a” is emitted, and you 
have 0.6 seconds to press the second key again to select a different letter.

Sample Registry Settings
This section lists sample keypad registry settings for the numeric keypad 
and the scroll keypad.

Numeric Keypad Registry Settings
[HKEY_LOCAL_MACHINE\HARDWARE\DEVICEMAP\KEYBD\FKEYS\27] 
"FkeyCode2" = hex:08,00 
"FkeyCode3" = hex:04,01; to enter Orange mode 
"FkeyCode5" = hex:09,00 
"FkeyCode6" = hex:0D,00 
"FkeyCode7" = hex:32,00 
"FkeyCode8" = hex:38,00 
"FkeyCode10" = hex:01,01 
"FkeyCode11" = hex:02,01

"FkeyCode16" = hex:35,00; to emit the number 5 
"FkeyCode17" = hex:34,00 
"FkeyCode18" = hex:36,00 
"FkeyCode20" = hex:1B,00 
"FkeyCode21" = hex:33,00 
"FkeyCode22" = hex:6E,00 
"FkeyCode23" = hex:31,00 
"FkeyCode24" = hex:05,01 
"FkeyCode25" = hex:39,00 
"FkeyCode26" = hex:30,00 
"FkeyCode27" = hex:37,00

"FkeyMeta5" = hex:10,00,09,00; to emit Shift-Tab (back tab) 
"FkeyMeta23" = hex:5B,00,C1,00; to launch APP 1 
"FkeyMeta24" = hex:BD,00

"FkeyAlpha2" = hex:20,00 
"FkeyAlpha7" = hex:03,80,41,00,42,00,43,00 
"FkeyAlpha8" = hex:03,80,54,00,55,00,56,00 
"FkeyAlpha16" = hex:03,80,4A,00,4B,00,4C,00 
"FkeyAlpha17" = hex:03,80,47,00,48,00,49,00 
"FkeyAlpha18" = hex:03,80,4D,00,4E,00,4F,00 
"FkeyAlpha20" = hex:14,00

"FkeyAlpha21" = hex:03,80,44,00,45,00,46,00 
"FkeyAlpha23" = hex:BD,00 
"FkeyAlpha25" = hex:04,80,57,00,58,00,59,00,5A,00 
"FkeyAlpha26" = hex:12,00 
"FkeyAlpha27" = hex:04,80,50,00,51,00,52,00,53,00

Scroll Keypad Registry Settings
[HKEY_LOCAL_MACHINE\HARDWARE\DEVICEMAP\KEYBD\FKEYS\9\0] 
;"FkeyCode1" = hex:5B,00,C1,00 
"FkeyCode1" = hex:70,00 
"FkeyCode2" = hex:25,00 
"FkeyCode3" = hex:04,01 
;"FkeyCode4" = hex:5B,00,C2,00 
"FkeyCode4" = hex:71,00 
"FkeyCode5" = hex:27,00 
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"FkeyCode6" = hex:0D,00 
"FkeyCode7" = hex:26,00 
"FkeyCode8" = hex:28,00 
"FkeyCode9" = hex:00,01 
"FkeyCode10" = hex:01,01 
"FkeyCode11" = hex:02,01

;"FKeyMeta1" = hex:5B,00,C3,00 
"FKeyMeta1" = hex:72,00 
"FKeyMeta2" = hex:25,00 
;"FKeyMeta3" = hex:5B,00,C5,00 
"FKeyMeta3" = hex:74,00 
;"FKeyMeta4" = hex:5B,00,C4,00 
"FKeyMeta4" = hex:73,00 
"FKeyMeta5" = hex:27,00 
"FKeyMeta6" = hex:1B,00 
"FKeyMeta7" = hex:03,01 
"FKeyMeta8" = hex:06,01 

"OrangeObeyClear" = dword:1 
"OrangeOneShot" = dword:1
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AConfigurable Settings

www.intermec.comThis appendix contains information about the Inter-
mec Settings, Utilities, and Wireless Network applets that may be on the 
CN2B Mobile Computer. Information about using reader commands and 
configuration bar codes to configure some of your settings is also in this 
appendix.
Note: Information about the settings you can configure with the Intermec 
Settings applet is described in the Intermec Computer Command Reference 
Manual (P/N: 073529). The online manual is available from the Intermec 
web site at www.intermec.com.
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Configuration Parameters
A configuration parameter changes the way the CN2B Computer operates, 
such as configuring a parameter to have the CN2B Computer emit a very 
loud beep in a noisy environment. Use either of the following methods to 
execute configuration parameters:

• Send parameters from an SNMP management station. See “SNMP 
Configuration on the Mobile Computer” on page 108.

• Scan EasySet bar codes. You can use the EasySet bar code creation soft-
ware from Intermec to print configuration labels. Scan the labels to 
change the scanner configuration and data transfer settings.

Use the Intermec EasySet software to print configuration labels you can 
scan to change your configuration settings. For more information, see 
the EasySet online help. EasySet is available from the Intermec Data 
Capture web site.

Menus of available parameters for each group are listed. Use the scroll bars 
to go through the list. Expand each menu (+) to view its parameter settings. 
Tap a parameter to select, or expand a parameter to view its subparameters.

Note that each parameter or subparameter is shown with its default setting 
or current setting in (< >) brackets. Tap a parameter or subparameter to 
select that parameter, then do any of the following to change its setting: 
Tap Apply to apply any changes.

• Typing a new value in an entry field.

• Choosing a new value from the drop-down list.

• Selecting a different option. The selected option contains a bullet.

• Tap Defaults, then Apply to restore factory-default settings. Tap Yes 
when you are prompted to verify this action.

• Tap Refresh to discard changes and start again. Tap Yes when you are 
prompted to verify this action.

Intermec Settings Applet
You may have the Intermec Settings applet. Information about the settings 
you can configure with this applet is described in the Intermec Computer 
Command Reference Manual. The online manual is available from the Inter-
mec web site at www.intermec.com.

See the Data Collection Resource Kit in the Intermec Developer Library 
(IDL) for information about data collection functions. The IDL is available 
as a download from the Intermec web site at www.intermec.com/idl. Con-
tact your Intermec representative for more information.
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To access the settings from the CN2B Computer, tap Start > Settings > 
the System tab > Intermec Settings to access its applet. 

Utilities Applet
The Utilities applet examines and modifies settings and operational modes 
of specific hardware and software on the CN2B Computer, including the 
registry storage, wakeup mask, and application launch keys.

Registry Save
From the CN2B Computer, tap Start > Settings > the System tab > Utili-
ties > the Registry Save tab to access the Registry Save page.

For Windows Mobile 2003, the only medium available for saving the regis-
try is the Flash File System (PSM). Registry data is stored in the 
“\Flash_File_Store\Registry” path. Check Enable Registry Storage to 
enable this function. 
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Wakeup Mask
From the CN2B Computer, tap Start > Settings > the System tab > Utili-
ties > the Wakeup Mask tab to access the Wakeup Mask page.

This page programs three scanner buttons and the A1 and A2 application 
keys to be “wakeup” or resume keys. That is, to prompt the CN2B Com-
puter to “wake up” or resume activity after going to “sleep” as a result of 
being inactive after a length of time. This information remains between 
warm and cold boots. Check the appropriate box, then tap ok to apply. 

Based on the setting, do the following to “wake up” the CN2B Computer.

Middle Scanner Button Squeeze the button on the Scan Handle

Left Scanner Button Squeeze the left scanner button

Right Scanner Button Squeeze the right scanner button

GOLD + A1 (Application 1) Press orange [period]

GOLD + A2 (Application 2) Press orange [4]

App Launch
From the CN2B Computer, tap Start > Settings > the System tab > Utili-
ties > the App Launch tab to access the Application Launch page.

This page programs or maps two scanner buttons and four application keys 
to start up to six applications. Note that the left scanner button also acts as the 
record button.
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For CN2B Computers with an imager, 
default mappings are shown in the following illustration. 

For CN2B Computers without an imager, 
the default maps the Record, Calendar, Contacts, and Tasks applications 
the top four and the A3 and A4 buttons are “unassigned.”
Note: Record, Calendar, Contacts, and Tasks are Pocket PC applications. 
See Chapter 2, “Windows Mobile 2003” for information.

• To assign an application to a button, select an application from the 
applicable drop-down list box. 

• To assign a new application, select the “Add new application” option, 
which brings up an Open File dialog and browse Secure Digital storage 
cards for new applications.

• To disable or unmap a currently mapped application from a correspond-
ing button, select “unassigned” from the applicable drop-down list.

• Tap Defaults in the lower right corner to restore defaults.
Note: You cannot map an application to more than one button. Should 
you assign the same application to two buttons, a verification prompt 
appears after the second button to confirm whether you want to remap the 
application. If you tap Yes, the applet changes the first button to “unas-
signed” and maps the application to the second button.

Note: All changes are activated immediate upon selection.

Wireless Network Applet
Note: See Chapter 4, “Network Support” for information about the 
802.11b/g radio module.
CN2B Mobile Computer User’s Manual 195



Appendix A — Configurable Settings
About the Wireless Network
Your wireless adapter (network interface card) connects to wireless net-
works of two types: infrastructure networks and ad-hoc networks.

• Infrastructure networks get you onto your corporate network and the 
internet. Your CN2B Computer establishes a wireless connection to an 
access point, which links you to the rest of the network. When you con-
nect to a network via an access point, you are using the 802.11b/g infra-
structure mode.

• Ad-hoc networks are private networks shared between two or more cli-
ents, even with no access point.

Each wireless network is assigned a name (or Service Set Identifier — 
SSID) to allow multiple networks to coexist in the same area without 
infringement.

Intermec recommends using security measures with wireless networks to 
prevent unauthorized access to your network and to ensure your privacy of 
transmitted data. The following are required elements for secure networks:

• Authentication by both the network and the user

• Authentication is cryptographically protected

• Transmitted data

There are many schemes available for implementing these features.

Terminology
Below are terms you may encounter when configuring wireless networks:

• CKIP (Cisco Key Integrity Protocol) 
This is Cisco’s version of the TKIP protocol, compatible with Cisco Air-
net products.

• EAP (Extensible Authentication Protocol) 
802.11b/g uses this protocol to perform authentication. This is not nec-
essarily an authentication mechanism, but is a common framework for 
transporting actual authentication protocols. Intermec provides a num-
ber of EAP protocols for you to choose the best for the network.

• TKIP (Temporal Key Integrity Protocol) 
This protocol is part of the IEEE 802.11b/g encryption standard for 
wireless LANs., which provides per-packet key mixing, a message integ-
rity check and a re-keying mechanism, thus overcoming most of the 
weak points of WEP. This encryption is more difficult to crack than the 
standard WEP. Weak points of WEP include:

• No Installation Vector (IV) reuse protection

• Weak keys or no key updates

• No protection against message replay

• No detection of message tampering
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• WEP (Wired Equivalent Privacy) encryption 
With preconfigured WEP, both the client CN2B Computer and access 
point are assigned the same key, which can encrypt all data between the 
two devices. WEP keys also authenticate the CN2B Computer to the 
access point — unless the CN2B Computer can prove it knows the WEP 
key, it is not allowed onto the network.

WEP keys are only needed if they are expected by your clients. There are 
two types available: 64-bit (5-character strings, 12345) (default) and 
128-bit (13-character strings, 1234567890123). Enter these as either 
ASCII (12345) or Hex (0x3132333435).

• WPA (Wi-Fi Protected Access) 
This is an enhanced version of WEP that does not rely on a static, shared 
key. It encompasses a number of security enhancements over WEP, 
including improved data encryption via TKIP and 802.11b/g authenti-
cation with EAP.

Configuring Your Wireless Network
To start 802.11b/g communications on the CN2B Computer, tap Start > 
Settings > the System tab > Wireless Network to access the Profile Wizard 
for the 802.11b/g radio module.

A profile contains all the information necessary to authenticate you to the 
network, such as login name, password or certificate, and protocols by 
which you are authenticated. 

You can have up to four profiles for different networks. For example, you 
may have different login names or passwords on different networks, or you 
may use a password on one network, and a certificate on another.

Use the Profiles page to select and configure between the networking envi-
ronments assigned to this 802.11b/g radio. 

• Profile: 
Tap the drop-down list to choose between four different profiles 
assigned to this unit, then tap Edit Select Profile, make the changes 
(starting on the next page), then tap OK to return to the Profiles page.
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• Enable Microsoft’s Wireless Zero Config 
Check this box to enable Microsoft’s Wireless Zero Config application. 
This effectively disables the Intermec software solution for 802.11b/g, 
including configuration via the Wireless Network applet.

Basic
Use the Basic page to set the network type, name, and manage battery 
power for this profile. Tap ok to return to the Profiles page.

• Profile Label: 
Enter a unique name for your profile.

• Network type: 
Tap the drop-down list to select either “Infrastructure” if your network 
uses access points to provide connectivity to the corporate network or 
internet; or “Ad-Hoc” to set up a private network with participants.

• Channel: 
If you selected “Ad-Hoc” for the network type, select the channel on 
which you are communicating with others in your network. There are 
up to 11 channels available.

• SSID (Network Name): 
This assumes the profile name unless another name is entered in this field. 
If you want to connect to the next available network or are not familiar 
with the network name, enter “ANY” in this field. Consult your LAN 
administrator for network names.

• Enable Power Management: 
Check this box to conserve battery power (default), or clear this box to 
disable this feature. 

Security
The following are available from the 8021x Security drop-down list. Note 
that the last five methods are available if you have purchased the security pack-
age. Contact your Intermec representative for information.

• None (next paragraph)

• PEAP (page 200)
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• TLS (page 202)

• TTLS (page 204)

• LEAP (page 208)

• EAP-FAST (page 209)

None
Use “None” to disable 802.11b/g Security and enable WEP encryption.

To Disable 802.1x Security 
Set 8021x Security as “None,” Association to “Open,” and Encryption to 
“None.” 

To Enable WEP Encryption

1 Set 8021x Security as “None,” Association to either “Open” if WEP 
keys are not required; or “Shared” when WEP keys are required for asso-
ciation, and Encryption to “WEP” (page 197).

2 If you had set Association to “Shared,” then select a data transmission 
key from the Data TX Key drop-down list near the bottom of this 
screen, then enter the encryption key for that data transmission in the 
appropriate Key # field. 
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PEAP (Protected EAP)
This protocol is suitable for performing secure authentication against Win-
dows domains and directory services. It is comparable to EAP-TTLS (see 
page 18), both in its method of operation and its security, though not as 
flexible. This does not support the range of inside-the-tunnel authentica-
tion methods supported by EAP-TTLS. Microsoft and Cisco both support 
this protocol.

Use “PEAP” to configure the use of PEAP as an authentication protocol 
and to select “Open,” “WPA,” or “Network EAP” as an association mode.

To Enable PEAP with an Open Association

1 Set 8021x Security as “PEAP” and Association to “Open.”

2 Enter your unique user name and password to use this protocol. Select 
Prompt for password to have the user enter this password each time to 
access the protocol; or leave Use following password as selected to auto-
matically use the protocol without entering a password.

3 Tap Get Certificates to obtain or import server certificates (page 207).

4 Tap Additional Settings to assign an inner PEAP authentication and set 
options for server certificate validation and trust (page 202). 

To Enable PEAP with WPA Encryption

1 Set 8021x Security as “PEAP” and Association to “WPA” (page 197).

2 Enter your unique user name and password to use this protocol. Select 
Prompt for password to have the user enter this password each time to 
access the protocol, or leave Use following password as selected to auto-
matically use the protocol without entering a password.

3 Tap Get Certificates to obtain or import server certificates (page 207).

4 Tap Additional Settings to assign an inner PEAP authentication and set 
options for server certificate validation and trust (page 202).
200 CN2B Mobile Computer User’s Manual



Appendix A —  Configurable Settings
To Enable PEAP with Network EAP

1 Set 8021x Security as “PEAP,” Association to “Network EAP” 
(page 196), and Encryption to either “WEP” (page 196) or “CKIP” 
(page 197).

2 Enter your unique user name and password to use this protocol. Select 
Prompt for password to have the user enter this password each time to 
access the protocol, or leave Use following password as selected to auto-
matically use the protocol without entering a password.

3 Tap Get Certificates to obtain or import server certificates (page 207).

4 Tap Additional Settings to assign an inner PEAP authentication and set 
options for server certificate validation and trust (page 202). 
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Additional Settings

1 Select an authentication method from the Inner PEAP Authentication 
drop-down list.

• EAP/MS-CHAP-V2 
Authenticates against a Windows Domain Controllre and other non-
Windows user databases. This is Microsoft’s implementation of 
PEAP.

• EAP/Token Card 
Use with token cards. The password value entered is never cached. 
This is Cisco’s implementation of PEAP.

• EAP/MD5-Challenge 
Message Digest 5. A secure hashing authentication algorithm.

2 Check Validate Server Certificate to verify the identity of the authenti-
cation server based on its certificate when using TTLS or PEAP.

3 Enter the Common Names of trusted servers. Note that if these fields are 
left blank, the server certificate trust validation is not performed or required. 
Click ok to return to the Security page. 

TLS (EAP-TLS)
EAP-TLS is a protocol that is based on the TLS (Transport Layer Security) 
protocol widely used to secure web sites. This requires both the user and 
authentication server have certificates for mutual authentication. While 
cryptically strong, this requires corporations that deploy this to maintain a 
certificate infrastructure for all their users.

Use “TLS” to configure the use of EAP-TLS as an authentication protocol, 
and to select “Open,” “WPA,” or “Network EAP” as an association mode.

To Enable TLS with an Open Association

1 Set 8021x Security as “TLS,” and Association to “Open.” Skip Encryp-
tion as it is automatically set to “WEP” (page 197).

2 Enter your unique Subject Name and User Name to use this protocol.

3 Tap Get Certificates to obtain or import server certificates (page 207).
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4 Tap Additional Settings to set options for server certificate validation 
and trust (page 204). 

To Enable TLS with WPA Encryption

1 Set 8021x Security as “TLS” and Association to “WPA” (page 197). 

2 Enter a unique Subject Name and User Name as credentials.

3 Tap Get Certificates to obtain or import server certificates (page 207).

4 Tap Additional Settings to set options for server certificate validation 
and trust (page 204). 

To Enable TLS with Network EAP

1 Set 8021x Security as “TLS,” Association to “Network EAP” 
(page 196), and Encryption to either “WEP” (page 197) or “CKIP” 
(page 196).

2 Enter a unique Subject Name and User Name as credentials.

3 Tap Get Certificates to obtain or import server certificates (page 207).
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4 Tap Additional Settings to assign an inner TLS authentication and set 
options for server certificate validation and trust (page 204). 

Additional Settings

1 Check Validate Server Certificate to verify the identity of the authenti-
cation server based on its certificate when using TLS.

2 Enter the Common Names of trusted servers. Note that if these fields are 
left blank, the server certificate trust validation is not performed or required.

3 Click ok to return to the Security page. 

TTLS (EAP-Tunneled TLS)
This protocol provides authentication like EAP-TLS (see page 202) but 
does not require certificates for every user. Instead, authentication servers 
are issued certificates. User authentication is done using a password or other 
credentials that are transported in a securely encrypted “tunnel” established 
using server certificates.

EAP-TTLS works by creating a secure, encrypted tunnel through which 
you present your credentials to the authentication server. Thus, inside EAP-
TTLS there is another inner authentication protocol that you must configure 
via Additional Settings.

Use “TTLS” to configure the use of EAP-TTLS as an authentication proto-
col, and select “Open,” “WPA,” or “Network EAP” as an association mode.
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To Enable TTLS with an Open Association (default configuration)

1 Set 8021x Security as “TTLS” and Association to “Open.”

2 Enter your unique user name and password to use this protocol. Select 
Prompt for password to have the user enter this password each time to 
access the protocol, or leave Use following password as selected to auto-
matically use the protocol without entering a password.

3 Tap Get Certificates to obtain or import server certificates (page 207).

4 Tap Additional Settings to assign an inner TTLS authentication and an 
inner EAP, and set options for server certificate validation (page 206). 

To Enable TTLS with WPA Encryption

1 Set 8021x Security as “TTLS” and Association to “WPA” (page 197).

2 Enter your unique user name and password to use this protocol. Select 
Prompt for password to have the user enter this password each time to 
access the protocol, or leave Use following password as selected to auto-
matically use the protocol without entering a password.

3 Tap Get Certificates to obtain or import server certificates (page 207).

4 Tap Additional Settings to assign an inner TTLS authentication and an 
inner EAP, and set options for server certificate validation (page 206). 
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To Enable TTLS with Network EAP

1 Set 8021x Security as “TTLS” and Association to “Network EAP” 
(page 196), and Encryption to either “WEP” (page 197) or “CKIP” 
(page 196).

2 Enter your unique user name and password to use this protocol. Select 
Prompt for password to have the user enter this password each time to 
access the protocol, or leave Use following password as selected to auto-
matically use the protocol without entering a password.

3 Tap Get Certificates to obtain or import server certificates (page 207).

4 Tap Additional Settings to assign an inner TTLS authentication and set 
options for server certificate validation and trust (page 206). 

Additional Settings

1 Select an authentication protocol from the Inner TTLS Authentication 
drop-down list:

• PAP (Password Authentication Protocol) 
A simple authentication protocol that sends security information in 
the clear.

• CHAP (Challenge Handshake Authentication Protocol) 
Use of Radius to authenticate a terminal without sending security data 
in the clear. Authenticates against non-Windows user databases. You 
cannot use this if authenticating against a Windows NT Domain or 
Active Directory.

• MS-CHAP, MS-CHAP-V2 
Authenticates against a Windows Domain Controller and other non-
Windows user databases.

• PAP/Token Card 
Use with token cards. The password value entered is never cached.

• EAP (Extensible Authentication Protocol) 
See page 196 for information about EAP.

2 If you select “EAP” for the inner authentication protocol, then select an 
inner EAP protocol from the Inner EAP drop-down list.
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3 Enter the Common Names of trusted servers. Note that if these fields are 
left blank, the server certificate trust validation is not performed or required.

4 Check Validate Server Certificate to verify the identity of the authenti-
cation server based on its certificate when using TTLS, PEAP, and TLS.

5 Enter the Anonymous EAP-TTLS Name as assigned for public usage. 
Use of this outer identity protects your login name or identity.

6 Click ok to return to the Security page. 

To Get Certificates
Certificates are pieces of cryptographic data that guarantee a public key is 
associated with a private key. They contain a public key and the entity 
name that owns the key. Each certificate is issued by a certificate authority.

Use this page to import a certificate onto the CN2B Computer.

Root Certificates

1 Tap the <<< button next to the Import Root Certificate field to select 
the root certificate (DER-encoded .CER file) to import.

2 Click Import Root Cert to install the selected certificate.

User Certificate

1 Tap the <<< button next to the Certificate Path field to select the user 
certificate (DER-encoded .CER file without the private key) to import.

2 Tap the <<< button next to the Key Path field to select the private key 
(.PVK file) which corresponds to the user certificate chosen in step 1.

3 Tap Import User Cert to install the selected certificate.
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Web Enrollment 
Tap Web Enrollment to obtain a user certificate over the network from an 
IAS Server. Tap ok to return to the Security page. 

LEAP (Cisco Lightweight EAP)
LEAP is the Cisco Lightweight version of EAP. See page 196 for informa-
tion about EAP.

Use “LEAP” to configure the use of LEAP as an authentication protocol, 
select “Open,” “WPA,” or “Network EAP” as an association mode, or 
assign Network EAP. Note that this defaults to the Network EAP.

To Enable LEAP with an Open Association

1 Set 8021x Security as “LEAP” and Association to “Open.”

2 Enter your unique User Name to use this protocol.

3 Select Prompt for password to have the user enter this password each 
time to access the protocol, or leave Use following password as selected 
to automatically use the protocol without entering a password. 

To Enable LEAP with WPA Encryption

1 Set 8021x Security as “LEAP” and Association to “WPA” (page 197).

2 Enter your unique User Name to use this protocol.
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3 Select Prompt for password to have the user enter this password each 
time to access the protocol, or leave Use following password as selected 
to automatically use the protocol without entering a password. 

To Enable LEAP with Network EAP

1 Set 8021x Security as “LEAP,” Association to “Network EAP” 
(page 196) and Encryption to either “WEP” (page 197) or “CKIP” 
(page 196).

2 Enter your unique User Name to use this protocol.

3 Select Prompt for password to have the user enter this password each 
time to access the protocol, or leave Use following password as selected 
to automatically use the protocol without entering a password. 

EAP-FAST (EAP-Flexible Authentication via Secured Tunnel )
The EAP-FAST protocol is a client-server security architecture that 
encrypts EAP transactions with a TLS tunnel. While similar to PEAP, it 
differs significantly as EAP-FAST tunnel establishment is based on strong 
secrets unique to users. These secrets are called Protected Access Credentials 
(PACs), which CiscoSecure ACS generates using a master key known only 
to CiscoSecure ACS. Because handshakes based upon shared secrets are 
intrinsically faster than handshakes based upon PKI, EAP-FAST is the sig-
nificantly faster of the two solutions that provide encrypted EAP transac-
tions. No certificate management is required to implement EAP-FAST.
CN2B Mobile Computer User’s Manual 209



Appendix A — Configurable Settings
Use “EAP-FAST” to configure the use of EAP-FAST as an authentication 
protocol, select “Open,” “WPA,” “Network EAP” as an association mode.

To Enable EAP-FAST with an Open Association

1 Set 8021x Security as “EAP-FAST” and Association to “Open.”

2 Enter your unique User Name to use this protocol.

3 Select Prompt for password to have the user enter this password each 
time to access the protocol, or leave Use following password as selected 
to automatically use the protocol without entering a password.

4 Tap Additional Settings to set options for PAC management and assign 
an anonymous EAP-FAST name (page 212). 

To Enable EAP-FAST with WPA Encryption

1 Set 8021x Security as “EAP-FAST” and Association to “WPA” 
(page 197).

2 Enter your unique User Name to use this protocol.

3 Select Prompt for password to have the user enter this password each 
time to access the protocol, or leave Use following password as selected 
to automatically use the protocol without entering a password.

4 Tap Additional Settings to set options for PAC management and assign 
an anonymous EAP-FAST name (page 212). 
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To Enable EAP-FAST with WPA Encryption

1 Set 8021x Security as “EAP-FAST” and Association to “WPA2” 
(page 197).

2 Enter your unique User Name to use this protocol.

3 Select Prompt for password to have the user enter this password each 
time to access the protocol, or leave Use following password as selected 
to automatically use the protocol without entering a password.

4 Tap Additional Settings to set options for PAC management and assign 
an anonymous EAP-FAST name (page 212). 

To Enable EAP-FAST with Network EAP

1 Set 8021x Security as “EAP-FAST,” Association to “Network EAP” 
(page 196), and Encryption to either “WEP” (page 197) or “CKIP” 
(page 196).

2 Enter your unique User Name to use this protocol.

3 Select Prompt for password to have the user enter this password each 
time to access the protocol, or leave Use following password as selected 
to automatically use the protocol without entering a password.

4 Tap Additional Settings to set options for PAC management and assign 
an anonymous EAP-FAST name. See below for more information. 
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Additional Settings

1 Tap PAC Manager to view the PAC files currently installed on your 
CN2B Computer. Tap ok to return to the Additional Settings screen.

2 If you already have a PAC on your CN2B Computer, clear Allow Auto-
matic PAC provisioning to avoid receiving additional PACs from the 
server.

3 If Allow Automatic PAC provisioning is checked, you can check:

• Prompt before acquiring a new PAC for notification of any incom-
ing PACs.

• Prompt before replacing a PAC for notification whether to replace a 
current PAC with an incoming PAC.

4 Enter the Anonymous EAP-FAST Name as assigned for public usage. 
This outer identity protects your login name or identity.

5 Click ok to return to the Security page. 

Advanced
Use this page to configure additional settings for this profile. Tap ok to 
return to the Profiles page.

• Detect Rogue APs (Access Points): 
Wireless NICs and access points associate based on the SSID configured 
for the NIC. Given an SSID, the BSSID with the strongest signal is 
often chosen for association. After association, 802.1x authentication 
may occur and during authentication credentials to uniquely identify a 
user — these are passed between the NIC and the access point.

The base 802.1x technology does not protect the network from “rogue 
APs.” These can mimic a legitimate access point to authentication proto-
cols and user credentials. This provides illegal users ways to mimic legiti-
mate users and steal network resources and compromise security.

Check this box to detect and report client behavior suspected of being 
rogue access points. Once detected, your CN2B Computer no longer 
associates with that access point until you perform a warm-boot.
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Clear this box to solve access point connection problems that result when 
an access point gets put on the rogue access point list due to inadvertant 
failed authentications and not because it is a real rouge.

• Enable mixed cell: 
Mixed cell is a profile-dependent setting. If enabled, you can connect to 
mixed cell without using WEP, then you can query the cell to determine 
whether you can use encryption.

• Allow fast roaming (CCKM): 
When using a wireless LAN that uses Cisco Access Points, a LEAP-
enabled client device can roam from one access point to another without 
involving the authentication (RADIUS) server. If enabled, Cisco Cen-
tralized Key Management (CCKM), an access point configured to pro-
vide Wireless Domain Services (WDS) takes the place of the RADIUS 
server (caching credentials of an initial authentication with the RADIUS 
server) and authenticates the client without perceptible delay in voice or 
other time-sensitive applications.

• Enable Logging: 
Check this box to log what activity incurs for this profile. 
CN2B Mobile Computer User’s Manual 213



Appendix A — Configurable Settings
Other Configurable Parameters
Configure the following parameters by sending reader commands through 
the network or from an application. See next page for information.

Reader Command Description Option

Audio Volume Changes the volume of all audio signals. 0 - Off 
1 - Very quiet 
2 - Quiet 
3 - Normal (default) 
4 - Loud 
5 - Very loud

Automatic Shutoff Sets the length of time the CN2B Computer remains 
on with no activity. When you turn on the CN2B 
Computer, it either resumes exactly where it was when 
you turned it off or boots and restarts your application.

1 - 1 minute 
2 - 2 minutes 
3 - 3 minutes (default) 
4 - 4 minutes 
5 - 5 minutes

Backlight Timeout Sets the length of time that the display backlight 
remains on. If you set a longer timeout value, you use 
the battery power at a faster rate.

10 - 10 seconds 
30 - 30 seconds 
60 - 1 minute (default) 
120 - 2 minutes 
180 - 3 minutes 
240 - 4 minutes 
300 - 5 minutes

Date/Time Sets the current date and time. Date 
Year - 0000–9999 (1999) 
Month - 1–12 (6) 
Day - 1–31 (1) 
Time 
Hour - 0–23 (0) 
Minute - 0–59 (00) 
Second - 0–59 (00)

Key Clicks Enables or disables the keypad clicks. The CN2B Com-
puter emits a click each time you press a key or decode a 
row of a two-dimensional symbology.

0 - Disable clicks 
1 - Enable soft key clicks 
2 - Enable loud key clicks (default)
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Using Reader Commands
After the CN2B Computer is connected to your network, you can send the 
CN2B Computer a reader command from an application to perform a task, 
such as changing the time and date. Some reader commands temporarily 
override configuration settings and some change the configuration settings.

Change Configuration
The Change Configuration command must precede any configuration 
command. If you enter a valid string, the CN2B Computer configuration is 
modified and the computer emits a high beep. To send the Change Config-
uration command through the network, use the $+ [command] syntax 
where command is the two-letter command syntax for the configuration 
command followed by the value to be set for that command.

You can also make changes to several different commands by using the  
$+ [command]...[command n] syntax. There are seven configuration 
command settings that you can change in this way. See each command for 
information on respective acceptable “data” values.

Command Syntax

Audio Volume BVdata

Automatic Shutoff EZdata

Backlight Timeout DFdata

Key Clicks KCdata

Virtual Wedge Grid AFdata

Virtual Wedge Postamble AEdata

Virtual Wedge Preamble ADdata

Example 1
To change the Beep Volume to Off, you can send this string to the CN2B 
Computer through the network: $+BV0 
where: 

$+ Indicates Change Configuration. 
BV Specifies the Audio Volume parameter. 
0 Specifies a value of Off.

Example 2
To change the Beep Volume to Very Quiet and the Virtual Wedge Grid to 
123: $+BV1AF123: 

$+ Indicates Change Configuration 
BV1 Specifies Audio Volume, set to Very Quiet (1) 
AF123 Specifies Virtual Wedge Grid, set to a value of 123.
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Set Time and Date
This command sets the date and time on the CN2B Computer. The 
default date and time is June 1, 1999 at 12:00 AM.

From the network, send the following:

/+ yyyymmddhhmmss

where acceptable values for the date are:

yyyy 0000-9999 Year 
mm 01-12 Month of the year 
dd 01-31 Day of the month 
hh 00-23 Hour 
mm 00-59 Minutes 
ss 00-59 Seconds

You can also set the time and date by using the Clock applet in the Settings 
menu. Tap Start > Settings > the System tab > the Clock icon. 

Configuration Bar Codes
You can change some settings on your CN2B Computer by scanning the 
following Code 39 bar code labels.
Note: When you use a bar code creation utility to make a scannable bar 
code label, the utility probably adds opening and closing asterisks automat-
ically. Asterisks are included here for translation purposes.

 

Audio Volume
Note: The Audio Volume parameter information is on page 214.

Turn Audio Off

*$+BV0*
*$+BV0*
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Set Audio Volume to very quiet

*$+BV1*
*$+VB1*

Set Audio Volume to quiet

*$+BV2*
*$+BV2*

Set Audio Volume to normal (default)

*$+BV3*
*$+BV3*

Set Audio Volume to loud

*$+BV4*
*$+BV4*

Set Audio Volume to very loud

*$+BV5*
*$+BV5*

Automatic Shutoff
Note: The Automatic Shutoff parameter information is on page 214.

Set Automatic Shutoff to 1 minute

*$+EZ1*
*$+EZ1*

Set Automatic Shutoff to 2 minutes

*$+EZ2*
*$+EZ2*

Set Automatic Shutoff to 3 minutes (default)

*$+EZ3*
*$+EZ3*

Set Automatic Shutoff to 4 minutes

*$+EZ4*
*$+EZ4*

Set Automatic Shutoff to 5 minutes

*$+EZ5*
*$+EZ5*
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Backlight Timeout
Note: The Backlight Timeout parameter information is on page 214.

Backlight Timeout 10 seconds

*$+DF10*
*$+DF10*

Backlight Timeout 30 seconds

*$+DF30*
*$+DF30*

Backlight Timeout 1 minute (default)

*$+DF60*
*$+DF60*

Backlight Timeout 2 minutes

*$+DF120*
*$+DF120*

Backlight Timeout 3 minutes

*$+DF180*
*$+DF180*

Backlight Timeout 4 minutes

*$+DF240*
*$+DF240*

Backlight Timeout 5 minutes

*$+DF300*
*$+DF300*

Key Clicks
Note: The Key Clicks parameter information is on page 214.

Disable key clicks

*$+KC0*
*$+KC0*

Enable soft key clicks

*$+KC1*
*$+KC1*
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Enable loud key clicks (default)

*$+KC2*
*$+KC2*

Virtual Wedge Grid, Preamble, Postamble
The following parameters are user-configurable strings. Refer to a full 
ASCII chart for more information.

Grid
For Virtual Wedge Grid, the first part of the bar code would be the follow-
ing, which can include a string of up to 240 characters.

*$+AF
*$+AF

Preamble
For Virtual Wedge Preamble, the first part of the bar code would be below, 
followed by a string of up to 31 characters (no <NUL>) and an asterisk.

*$+AD
*$+AD

Postamble
For Virtual Wedge Postamble, the first part of the bar code would be 
below, followed by a string of up to 31 characters (no <NUL>) and an 
asterisk.

*$+AE
*$+AE
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BTroubleshooting the CN2B 
Computer

Use this appendix to solve problems you may encounter while using the 
CN2B Mobile Computer.
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Problems and Solutions
These tables offer solutions to the problems you may encounter.

Problems While Operating the CN2B Computer 

Problem Solution

You press Power to turn on the 
CN2B and nothing happens.

Try these possible solutions in order:
1 Make sure the battery door is installed correctly and completely closed.
2 Make sure you have a charged battery installed correctly.
3 The battery may be discharged. Replace the battery with a spare charged bat-

tery, or charge the battery and try again.
4 Perform a warm-boot on the CN2B Computer.

You press Power to turn off the 
CN2B and nothing happens.

To turn off (or suspend) the CN2B Compuyter, hold the Power key for 2 or 3 
seconds, then release it.
If the CN2B Computer is processing data, it may not turn off when you press 
Power. Wait until the CN2B Computer finishes processing.
If the CN2B Computer appears to be locked up, perform a warm-boot on the 
CN2B Computer.
If the CN2B Computer does not respond to a warm-boot, perform a cold-boot.

The CN2B Computer is not 
responding to the stylus.

Press and hold the Power key for 2 to 3 seconds, then release it to turn off the 
CN2B Computer. Press Power again to turn on the CN2B Computer.

You place the CN2B Computer 
in the communications dock, and 
the Battery light turns on and is 
orange.

• The temperature may not be within the charging range. Make sure that the 
temperature is from 0°C to 40°C (32°F to 104°F). 

• The battery may be damaged. Replace the battery.

The CN2B Computer appears 
locked up and you cannot enter 
data.

Try these possible solutions in order:
1 Wait at least 10 seconds and try again. If the CN2B Computer is still connect-

ing to the Intermec Application Server or the host, it ignores any input from 
the keypad or scanner.

2 Press and hold the Power key for 2 to 3 seconds, and then release it to turn off 
the CN2B Computer. Press Power again to turn on the CN2B Computer.

3 Perform a warm-boot on the CN2B Computer.
4 Perform a cold-boot on the CN2B Computer.
5 Try reloading the firmware.
6 If the CN2B Computer does not boot or reset, contact your local Intermec 

service representative for help.
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Problems While Configuring Security 

Problem Solution

The CN2B Computer does not 
appear to be authenticating.

The CN2B Computer may not be communicating with your access point. Make 
sure the network name on the CN2B Computer is the same as the network name 
(SSID) of the access point that you are trying to communicate with. The default 
network name is “INTERMEC.” 
The 802.1x security network may not be active. Make sure that the server soft-
ware is properly loaded and configured on the server PC. For help, see the docu-
mentation that shipped with your server software.
The access point that you are trying to communicate with may not be communi-
cating with the server. Make sure your access point is turned on, properly config-
ured, and has 802.1x security enabled.

The CN2B Computer indicates 
that it is not authenticated.

Make sure that:
• The User Name and Password parameters on your CN2B Computer match 

the user name and password on your authentication server. You may need to 
re-enter the password on both your CN2B Computer and the authentication 
server.

• On your authentication server, the user and group are allowed and the group 
policy is allowed to log in to the server. For help, see the documentation for 
your authentication server software.

• The IP address and secret key for your access point must match the IP address 
and secret key on your authentication server. You may need to re-enter the IP 
address and secret key on both your access point and authentication server.

• The authentication server software is running on the server PC.

The CN2B Computer indicates 
that it is authenticated, but it does 
not communicate with the host. 

Make sure that the CN2B IP address, host IP address, subnet mask, and default 
router are properly configured for your network.

You are setting up multiple access 
points in a network, with different 
SSIDs, and the connection fails.

The CN2B Computer does not save WEP key values when you change the SSID. 
Re-enter the WEP key value after you change the SSID and save your changes. 
You should now be able to connect to the different access points.

Problems with Wireless Connectivity 

Problem Solution

A Network Connection icon 
appears on the status bar, but the 
host computer is not receiving any 
data from the CN2B Computer. 

In a UDP Plus network, there may be a problem with the connection between 
the Intermec Application Server and the host computer. Check with your net-
work administrator or see the user’s manual for the Intermec Application Server. 
In a TCP/IP network, there may be a problem with the connection between the 
access point and the host computer. Check with your network administrator or 
use your access point user’s manual.

When you turn on the CN2B 
Computer after it was suspended 
for a while (10-15 minutes or 
longer), it can no longer send or 
receive messages over the net-
work.

The CN2B Computer may not recognize the network card. Turn off the CN2B 
Computer, and then turn it on again.
The host may have deactivated or lost your current terminal emulation session. 
In a TCP/IP direct connect network, you need to turn off the “Keep Alive” mes-
sage (if possible) from the host so that the TCP session is maintained while a 
CN2B Computer is suspended.
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The CN2B Computer is con-
nected to the Intermec Applica-
tion Server or host computer and 
you move to a new site to collect 
data. A Network Connection icon 
was visible but now the no net-
work connection icon is visible. 

You may have gone out of range of an access point. 
Try moving closer to an access point or to a different location to re-establish 
communications. Once you are in range again, the network connection icon 
appears again. Any data you collected while out of range is transmitted over the 
network.

The no network connection icon 
appears on the status bar.#

The no network connection icon appears in three situations:
• The CN2B Computer may not have an IP address. You must configure an IP 

address for the CN2B Computer or make sure that DHCP assigned an 
address. Use Intermec Settings and select the radio tab to make sure an IP 
address is assigned.

• The CN2B Computer may not be connected to the access point. Try these 
possible solutions in order:
• Make sure the access point is turned on and operating.
• Make sure you are not using the CN2B Computer out of range of an 

access point. Try moving closer to an access point to re-establish commu-
nications.

• Make sure the CN2B Computer is configured correctly for your network. 
The radio parameters on the CN2B Computer must match the values set 
for all access points the CN2B Computer may communicate with.

• If you have an 802.11b/g radio, the radio initialization process may have 
failed. Try resetting the CN2B Computer.

• If you have tried these possible solutions and the no network connection icon 
still appears, you may have a defective radio card. For help, contact your local 
Intermec representative.

Problems While Scanning Bar Codes 

Problem Solution

You cannot see a red beam of light 
from the scanner when you press 
the Scan button or one of the 
Side Scan buttons and aim the 
scanner at a bar code label.

There are three possible problems:
• You may be too far away from the bar code label. Try moving closer to the bar 

code label and scan it again.
• You may be scanning the bar code label “straight on.” Change the scanning 

angle and try again.
• The PSM files may not be correctly installed.
You can test the effective range of the scanner. Move within 61 cm (2 ft) of a wall 
and test the scanner. You need to be within the scanning range to scan bar code 
labels.

When you release the Scan but-
ton or Side Scan button, the 
Good Read light does not turn 
off. 

The Good Read light remains on if you configure the CN2B Computer to use 
continuous/edge triggering. If you configure the CN2B Computer for level trig-
gering and the Good Read light remains on, there may be a problem. Press the 
Scan button or one of the Side Scan buttons again without scanning a bar code 
label. If the light is still on, contact your local Intermec service representative.

Problems with Wireless Connectivity (continued)

Problem Solution
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Sending the CN2B Computer to Intermec for Service
If you send the CN2B Computer in for service, it is your responsibility to 
save the computer data and configuration. Intermec is responsible only for 
ensuring that the keypad and other hardware features match the original 
configuration when repairing or replacing your computer. 

For help understanding your warranty and finding help, see “Global Ser-
vices and Support” on page xv.

You may be asked for the version of the operating system running on your 
CN2B Computer. For help finding this information, see “Software Build 
Version” on page 12.

The scanner will not read the bar 
code label. 

Make sure you aim the scanner beam so it crosses the entire bar code label in one 
pass.
The angle you are scanning the bar code label may not be working well, or you 
may be scanning the label “straight on.” Try scanning the bar code label again, 
but vary the scanning angle.
The bar code label print quality may be poor or unreadable. To check the quality 
of the bar code label, try scanning a bar code label that you know will scan. Com-
pare the two bar code labels to see if the bar code quality is too low. You may 
need to replace the label that you cannot scan.
Make sure the bar code symbology you are scanning is enabled. Use Intermec 
Settings to check the symbologies. If your bar code symbology is disabled, enable 
it and then try scanning the bar code label again.
Note: If you restored the CN2B Computer to factory default settings, some of the sym-
bologies may be disabled. Make sure that the application you are running on the com-
puter is expecting input from a bar code. You may need to use the input panel to enter 
this information instead of scanning it.

The scanner does not read the bar 
code labels quickly, or the scan-
ning beam seems faint or 
obscured.

The scanner window may be dirty. Clean the window with a solution of ammo-
nia and water. Wipe dry. Do not allow abrasive material to touch the window.

You scan a valid bar code label to 
enter data for your application. 
The data decoded by the CN2B 
Computer does not match the 
data encoded in the bar code 
label. 

The computer may have decoded the bar code label in a symbology other than 
the label’s actual symbology. Try scanning the bar code label again. Make sure 
you scan the entire label. 
To operate the computer quickly and efficiently, you should only enable the bar 
code symbologies that you are going to scan. 

Problems While Scanning Bar Codes (continued)

Problem Solution
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Cleaning the Scanner Window and the Touch Screen
To keep the computer in good working order, you may need to clean the 
scanner window and touch screen with a solution of ammonia and water. 

You can clean the scanner window and the touch screen as often as needed 
for the environment in which you are using the computer. You can help 
keep the touch screen clean by using the stylus, instead of your fingertip, to 
tap the screen.
There are no user-serviceable parts inside the CN2B Computer. Open-
ing the unit voids the warranty and may cause damage to the internal 
components.

To clean the scanner window and touch screen

1 Press and hold the Power key for 2 to 3 seconds, and then release it to 
turn off the CN2B Computer.

2 Dip a clean towel or rag in the ammonia solution and wring out the 
excess. Wipe off the scanner window and touch screen. Do not allow any 
abrasive material to touch these surfaces. 

3 Wipe dry.

To clean the scanner window
• You can use the Screen Cleaner Kit (P/N: 346-065-101) to clean the 

scanner window.
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Index
Symbols
__RESETMEPLEASE__.TXT, 136

Numerics
1D area imager reading distances, 124
6820 printers

NPCP driver, 112
printer support, 111

6920 Communications Server
ManifestName parameter, 144

802.11
API, 161
channel, 198
communications setup, 94, 197
configuration profiles, 162
EAP-FAST

network EAP, 211
WPA encryption, 210, 211

LEAP
network EAP, 209
WPA encryption, 208

network type, 198
PEAP

network EAP, 201
WPA encryption, 200

profile label, 198
profile security information

WEP encryption, 199
profiles, 197

advanced settings, 212
basic information, 198
security information, 198

SSID (network name), 198
TLS

network EAP, 203
TTLS

network EAP, 206
WPA encryption, 205

WPA authentication with pre-shared key
Zero Configuration, 98

zero configuration
WEP encryption, 97

802.11b/g communications, 93
80211API.DLL, 162
80211CONF.EXE, 162
80211SCAN.EXE, 162
802PM.DLL, 162

A
abrasive material, avoiding, 226
Abstract Syntax Notation.1 See ASN.1
Accessory list, 16
Accounts

via Inbox, 55
ActiveSync

adding programs, 32
Folder behavior connected to email server, 54
installing applications, 75
Microsoft Reader, 66
Pocket Internet Explorer

favorite links, 68
mobile favorites, 69
Mobile Favorites folder, 68

replicating registry settings, 77
Start menu icon, 22
URL, 34
Windows Mobile, 34

add_registry_section
AddReg

flags, 132
registry_root_string, 132
value_name, 132

Adding programs
ActiveSync, 32
to the Start menu, 33

via File Explorer, 33
Windows Mobile, 31

AddReg
add_registry_section

flags, 132
registry_root_string, 132
value_name, 132

DefaultInstall, 129
AddWep(), 171
Adjusting settings

Windows Mobile, 31
AllDay events

Calendar
creating, 39

ammonia and water for cleaning, 226
Annotations index

Microsoft Reader, 67
APIs

802.11, 161
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Applets
clock, 31, 216
intemec settings

beeper volume, 7, 108, 119
intermec settings, 192

printers, 119
smartsystems, 7, 108

menu, 31
owner information, 31
password, 31
power, 31

battery status, 3
RAM maintenance, 4

system
wireless network, 94, 197

today, 31
utilities, 193

app launch, 194
registry save, 193
wakeup mask, 194

wireless network, 195
Application keys

utilities applet, 194
Application launch applet, 194
AppName

CEStrings, 127
Appointments

Calendar
assigning to a category, 41
changing, 38
creating, 38
setting a reminder, 40
viewing, 38

ASCII
printing, 112
printing to a port

port print method, 112
raw text to printer, 112

ASN.1, 109
Asset management

DeviceURL parameter, 143
Attaching notes to text

Microsoft Reader, 67
Audio files

Windows Media Player, 65
Audio system

external headset jack, 2
microphone, 2
speaker, 2

AutoCab

command line syntax, 83
AutoFTP, 149
AutoIP, 99
Automatic Private IP See AutoIP
Automatic shutoff

bar code configuration, 214, 217
configuration parameter, 214

Autostart FTP, 149
Avalanche, 76
AvantGo channels

Pocket Internet Explorer, 70

B
Backlight timeout

bar code configuration, 214, 218
configuration parameter, 214

Bar code configuration
audio volume, 214
automatic shutoff, 214
backlight timeout, 214
key clicks, 214

Bar codes
configuration

audio volume, 216
automatic shutoff, 217
backlight timeout, 218
Code 39, 216
key clicks, 218

internal scanner supported symbologies, 124
scanning labels, 216

Basic connect/disconnect functions, 162
Battery

capacity, 17
low battery conditions, 3
RAM maintenance, 4
specifications, 17
status, 3

battery
removing, 15

Beeper
silencing the volume, 7
volume

turning it on, 6
BlockSize

FTP Server, 143
Bluetooth

accessing, 86
activating, 86
connecting with remote devices, 88
WPport, 87
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Books
Microsoft Reader

adding bookmarks, 67
adding drawings, 67
annotations index, 67
attaching notes, 67
copying, 67
highlighting, 67
reading, 67
removing, 68
searching, 67

Browsing the Internet
Pocket Internet Explorer, 71

Build information
software, 12

BuildMax
CEDevice, 128

BuildMin
CEDevice, 128

C
CAB files

after the extraction, 136
creating, 126
creating INF files, 126
creating with CAB Wizard, 139
installation functions

SETUP.DLL, 136
Cabinet Wizard

creating CAB files, 139
troubleshooting, 140
using the application, 126

CABWIZ.EXE, 126
Calendar

all day events
creating, 39

appointments
assigning to a category, 41
changing, 38
creating, 38
setting a reminder, 40
viewing, 38

categories, 36
options

changing, 43
recurrence pattern, 37
Start menu icon, 22
synchronizing, 36

Capacitor, internal super, 3
Card support

radios, 15
card, SD

inserting, 13
removing, 14

Categories
calendar, 36

CEDevice
BuildMax, 128
BuildMin, 128
ProcessorType, 127
UnsupportedPlatforms, 127
VersionMax, 128
VersionMin, 128

CESelfRegister
DefaultInstall, 129

CESetupDLL
DefaultInstall, 129

CEShortcuts
DefaultInstall, 129
shortcut_list_section

shortcut_filename, 133
shortcut_type_flag, 133
target_file_path, 133

CESignature
SourceDiskNames, 129
Version, 126

CEStrings
AppName, 127
InstallDir, 127

Channel
802.11 radio module, 198

ClassID field values
VN_CLASS_ASIC, 152
VN_CLASS_BOOTSTRAP, 152
VN_CLASS_KBD, 152

cleaning the scanner window and touch screen, 226
Clock applet

setting date and time, 216
Windows Mobile settings, 31

CloseHandle(), 112
DTR printing, 117, 118
NPCP printing, 112, 114

Closing drivers
NPCP, 114

Cold boot
IOCTL_HAL_COLDBOOT, 157

Cold boot, performing, 11
COM1

NPCP parameter, 113
COM1 port, 112
Command line syntax

AutoCab, 83
Communications

DTR, 118
NPCP, 115

CompactFlash cards
installing applications, 76
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Computer shutdown, 3
Configuration parameters

automatic shutoff, 214
backlight timeout, 214
date/time, 214
key clicks, 214
volume, 214

ConfigureProfile(), 176
Connecting to

an ISP, 101
email server, 108

Connecting to a mail server
via Inbox, 55

Connections
directly to email server, 108
ending, 107
to an ISP, 101

via modem, 101
via modem

to an ISP, 101
Connections See Getting connected, 100
Contacts

adding to speed dial, 49
changing options, 49
copying, 47
creating, 44
MSN Messenger

managing, 64
sending messages, 65
working with, 64

sending a message, 48
Start menu icon, 22
synchronizing, 45
viewing, 45

contents, in SDMMC Disk folder, 14
Control panel applets

intermec settings, 192
Converting writing to text, 27
CopyFiles

file_list_section
destination_filename, 131
flags, 131
source_filename, 131

Copyfiles
DefaultInstall, 129

Copying
contacts, 47

COREDLL.DLL, 181
CPL802.CPL, 162
CreateEvent(), 185

CreateFile(), 112
DTR printing, 117
NPCP printing, 112, 113

D
Date, setting, 216
Date/Time

configuration parameter, 214
DefaultInstall

AddReg, 129
CESelfRegister, 129
CESetupDLL, 129
CEShortcuts, 129
Copyfiles, 129

DeregisterDevice(), 113
DTR printing, 117

DestinationDirs
file_list_section, 130

Detect rogue APs, 212
DEVICEID.H, 154
DeviceIOControl(), 161

DTR printing, 117
NPCP printing, 112

DeviceIoControl()
NPCP printing, 114

DeviceName
FTP Server, 143

DeviceURL
FTP Server, 143

DHCP, 99
replicating registry settings, 77

disk_ordinal
SourceDiskNames, 129

Display specifications, 16
DllRegisterServer, 129
DllUnregisterServer, 129
Documents

creating via Pocket Word, 57
DRAM

low battery shutdown, 3
maintenance, 4

Drawing
creating, 28

Drawing mode
Pocket Word, 60

Drawing on the screen
Pocket Word, 60

Drawings
adding via Microsoft Reader, 67
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Drivers
DTR

communications, 118
installing, 117
opening, 117
removing, 117
writing to, 118

NPCP
closing, 114
communications, 115
I/O controls, 114
installing, 113
opening, 113
reading from, 114
removing, 113
writing to, 114

DTR printing, 117
closing driver, 118
communications, 118
opening driver, 117
removing driver, 117
writing to driver, 118

E
EAP-FAST

802.11 radio module
network EAP, 211
WPA encryption, 210, 211

profile security information, 209
WEP encryption, 210

Editing a profile, 197
EnableSuppLogging(), 180
EnableWep(), 171
EnableZeroConfig(), 177
EncryptionStatus(), 172
Ending a connection, 107
Environmental specifications, 16
Epson Escape Sequences, 112
ERROR_INSUFFICIENT_BUFFER

IOCTL_HAL_ITC_READ_PARM, 151
IOCTL_HAL_ITC_WRITE_SYSPARM, 153

ERROR_INVALID_PARAMETER
IOCTL_HAL_ITC_READ_PARM, 151
IOCTL_HAL_ITC_WRITE_SYSPARM, 153

EXITME.BIN, 148
Expansion slot specifications, 16

F
Favorite links

Pocket Internet Explorer, 68
File Explorer

adding programs to Start menu, 33
File Transfer Protocol See FTP
file_list_section

CopyFiles
destination_filename, 131
flags, 131
source_filename, 131

DestinationDirs, 130
filename

SourceDiskFiles, 130
files

accessing on the SD card, 14
Find feature

Windows Mobile, 30
fingerprints, cleaning, 226
Flash File Store

packaging an application, 74
Flash file system, utilities applet, 193
Folder behavior connected to email server

ActiveSync, 54
IMAP4, 55
POP3, 55
SMS, 54

FRAME_NOT_ACKED, 115
FTP

client, 145
configurable parameters, 143

BlockSize, 143
DeviceName, 143
DeviceURL, 143
IDNATarget, 144
ManifestName, 144
PauseAtStartup, 144
Root, 144

FTPDCMDS subdirectory, 148
heartbeat, 145
RTC 959, 147
server, 145

installing applications, 76
server requests

CDUP, 145
CWD, 145
DELE, 145
HELP, 145
LIST, 145
MKD, 145
MODE, 145
NLST, 145
NOOP, 145
PASS, 145
PWD, 145
QUIT, 145
RETR, 145
RMD, 145
RNFR, 145
RNTO, 145
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SITE, 146
SITE ATTRIB, 146
SITE BOOT, 146
SITE COPY, 146
SITE EKEY, 147
SITE EVAL, 147
SITE EXIT, 146
SITE GVAL, 147
SITE HELP, 146
SITE KILL, 146
SITE LOG, 147
SITE PLIST, 147
SITE PVAL, 147
SITE RUN, 147
SITE STATUS, 147
SITE TIMEOUT, 147
STOR, 145
SYST, 145
TYPE, 145
USER, 145
XCUP, 145
XCWD, 145
XMKD, 145
XPWD, 145
XRMD, 145

stopping server from application, 148
support, 145
web browsers, 147

FTPDCE.EXE, 145, 148
AutoFTP, 149
FTP Server, 141

FTPDCE.TXT, 148
FTPDCMDS subdirectory

FTP support, 148

G
GDI approach, 112
GetAssociationStatus(), 163
GetAuthenticationMode(), 164
GetBSSID(), 164
GetCCXStatus(), 170
GetCurrentDriverName(), 179
GetDiversity(), 165
GetLinkSpeed(), 165
GetMac(), 166
GetNetworkMode(), 166
GetNetworkType(), 167
GetPowerMode(), 168
GetRadioIpAddress(), 170
GetRSSI(), 168
GetSSID(), 167
Getting connected

ISP, 100
to an ISP, 101

creating a modem connection, 101
Windows Mobile, 100

GetTXPower(), 169
GetWepStatus(), 169
Good Read light

troubleshooting, 224

H
HAL

verion of Pocket PC
IOCTL_HAL_GET_BOOTLOADER_VE

RINFO, 155
IOCTL_HAL_GET_OAL_VERINFO, 155

Headset jack, external, 2
Helper functions, 176
Highlighting text

Microsoft Reader, 67
host computer not receiving data, troubleshooting, 
223

I
I/O controls

NPCP driver, 114
ID field values

IOCTL_HAL_ITC_READ_PARM
ITC_NVPARM_80211_INSTALLED, 152
ITC_NVPARM_80211_RADIOTYPE, 152
ITC_NVPARM_BLUETOOTH_INSTAL

LED, 153
ITC_NVPARM_CONTRAST, 152
ITC_NVPARM_DISPLAY_TYPE, 151
ITC_NVPARM_ECN, 152
ITC_NVPARM_INTERMEC_DATACOL

LECTION_HW, 152
ITC_NVPARM_INTERMEC_DATACOL

LECTION_SW, 152
ITC_NVPARM_INTERMEC_SOFTWAR

E_CONTENT, 152
ITC_NVPARM_MANF_DATE, 151
ITC_NVPARM_MCODE, 152
ITC_NVPARM_SERIAL_NUM, 151
ITC_NVPARM_SERIAL2_INSTALLED, 

153
ITC_NVPARM_SERVICE_DATE, 151
ITC_NVPARM_SIM_PROTECT_HW_I

NSTALLED, 153
ITC_NVPARM_SIM_PROTECT_SW_IN

STALLED, 153
ITC_NVPARM_VERSION_NUMBER, 

152
ITC_NVPARM_WAN_RI, 152

IOCTL_HAL_ITC_WRITE_SYSPARM
ITC_ WAKEUP_MASK, 154
ITC_REGISTRY_SAVE_ENABLE, 154
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IDLs
Bluetooth, 86
data collection, 7, 108, 122, 192
printing, 112
smartsystems, 82
URL, 12

IDNA
DeviceName, 143
DeviceURL, 143
IDNATarget, 144
ManifestName, 144

IDNATarget
FTP Server, 144

IMAP4
Folder behavior connected to email server, 55

Inbox
accounts, 55
connecting to a mail server, 55
downloading messages from server, 56
getting connected, 100
managing email messages and folders, 54
Start menu icon, 22
synchronizing email messages, 54
using My Text, 30

INF files
creating, 126

Input panel
letter recognizer, 25
Pocket Word, 58
selecting typed text, 26
Windows Mobile, 22

inserting
SD card, 13

Installation functions
SETUP.DLL, 136

InstallDir
CEStrings, 127

installing
SD card, 13

Installing applications
Avalanche, 76
SmartSystems, 77
using a storage card, 76
using Secure Digital cards, 76
with ActiveSync, 75
with FTP Server, 76

Installing drivers
DTR, 117
NPCP, 113

Instant messaging, 62
Integrated scanners See Internal scanners
Intermec Developer Library, 7
Intermec Device Network Announcement See 

IDNA
Intermec part numbers, 16
Intermec settings, 192

beeper volume, 108
Intermec settings applet

printers, 119
smartsystems, 7, 108

INTERMEC.MIB, 109
INTERMEC_PACKET_DRIVER

SwitchPacketDriver(), 180
Internal scanners

configuring, 123
reading distances

EV10, 124
specifications, 17
supported symbologies, 124

Internet explorer
software build version, 12

Internet Service Provider See ISP, 100
IOCTL_GET_CPU_ID, 160
IOCTL_HAL_COLDBOOT, 157, 182
IOCTL_HAL_GET_BOOT_DEVICE, 158
IOCTL_HAL_GET_BOOTLOADER_VERINF
O, 155
IOCTL_HAL_GET_DEVICE_INFO, 150
IOCTL_HAL_GET_DEVICEID, 154
IOCTL_HAL_GET_OAL_VERINFO, 155
IOCTL_HAL_GET_RESET_INFO, 157
IOCTL_HAL_ITC_READ_PARM, 151
IOCTL_HAL_ITC_WRITE_SYSPARM, 153
IOCTL_HAL_REBOOT, 159, 182
IOCTL_HAL_WARMBOOT, 156, 182
IOCTL_LOAD_NDIS_MINIPORT, 161
IOCTL_NPCP_BIND, 115
IOCTL_NPCP_CANCEL, 115
IOCTL_NPCP_CLOSE, 115
IOCTL_NPCP_ERROR, 115
IOCTL_NPCP_FLUSH, 115
IOCTL_PROCESSOR_INFORMATION, 159
IOCTL_UNLOAD_NDIS_MINIPORT, 161
IP address

replicating registry settings, 77
isDHCPEnabled(), 179
ISP

connecting to via Windows Mobile, 101
creating

a modem connection, 101
Pocket Internet Explorer, 68
Windows Mobile, 100

isSupplicantRunning(), 177
isZeroConfigEnabled(), 177
ITC_ WAKEUP_MASK, 154
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ITC_DEVID_80211RADIO_INTEL_2011B, 
152
ITC_DEVID_80211RADIO_MAX values

ITC_DEVID_80211RADIO_INTEL_2011B, 
152

ITC_DEVID_80211RADIO_NONE, 152
ITC_DEVID_80211RADIO_NONE, 152
ITC_DEVID_INTERMEC_EVIO, 152
ITC_DEVID_SCANHW_MAX values

ITC_DEVID_INTERMEC_EVIO, 152
ITC_DEVID_SCANHW_NONE, 152

ITC_DEVID_SCANHW_NONE, 152
ITC_IFTP_STOP, 148
ITC_KEYBOARD_CHANGE

CreateEvent(), 185
ITC_NVPARM_80211_INSTALLED, 152
ITC_NVPARM_80211_RADIOTYPE, 152
ITC_NVPARM_BLUETOOTH_INSTALLED, 
153
ITC_NVPARM_CONTRAST, 152
ITC_NVPARM_DISPLAY_TYPE, 151
ITC_NVPARM_ECN, 152
ITC_NVPARM_INTERMEC_DATACOLLEC
TION_HW, 152
ITC_NVPARM_INTERMEC_DATACOLLEC
TION_SW, 152
ITC_NVPARM_INTERMEC_SOFTWARE_C
ONTENT, 152
ITC_NVPARM_MANF_DATE, 151
ITC_NVPARM_MCODE, 152
ITC_NVPARM_SERIAL_NUM, 151
ITC_NVPARM_SERIAL2_INSTALLED, 153
ITC_NVPARM_SERVICE_DATE, 151
ITC_NVPARM_SIM_PROTECT_HW_INSTA
LLED, 153
ITC_NVPARM_SIM_PROTECT_SW_INSTAL
LED, 153
ITC_NVPARM_VERSION_NUMBER, 152
ITC_NVPARM_WAN_RI, 152
ITC_REGISTRY_SAVE_ENABLE, 154
ITCADC.MIB, 109
ITCSNMP.MIB, 109
ITCTERMINAL.MIB, 109

K
Keep Alive message, 223
KernelIoControl

IOCTL_GET_CPU_ID, 160
IOCTL_HAL_COLDBOOT, 157, 182
IOCTL_HAL_GET_BOOT_DEVICE, 158
IOCTL_HAL_GET_BOOTLOADER_VERI

NFO, 155
IOCTL_HAL_GET_DEVICE_INFO, 150
IOCTL_HAL_GET_DEVICEID, 154
IOCTL_HAL_GET_OAL_VERINFO, 155
IOCTL_HAL_GET_RESET_INFO, 157
IOCTL_HAL_ITC_READ_PARM, 151
IOCTL_HAL_ITC_WRITE_SYSPARM, 153
IOCTL_HAL_REBOOT, 159, 182
IOCTL_HAL_WARMBOOT, 156, 182
IOCTL_PROCESSOR_INFORMATION, 

159
KernelIoControl(), 150
Key clicks

bar code configuration, 214, 218
configuration parameter, 214

Key sequences
alpha (green) keys, 8
orange keys, 8

Keypad
advanced remapping, 185
alpha (green) key sequences, 8
alpha plane, 184
change notification, 185
driver registry settings, 184
orange key sequences, 8
orange plane, 183
planes, 183
registry settings

alpha plane, 184
orange plane, 184
unshifted plane, 184

remapping, 182
scan codes, 185
specifications, 17

L
LEAP

802.11 radio module
network EAP, 209
WPA encryption, 208

profile security information, 208
WEP encryption, 208

LEAP security
fast roaming (CCKM), 213

LED status, 9
Letter recognizer

Windows Mobile input panel, 25
Library

Microsoft Reader, 66
Line printing, 112
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lpBytesReturned
IOCTL_GET_CPU_ID, 160
IOCTL_HAL_GET_BOOT_DEVICE, 158
IOCTL_HAL_GET_BOOTLOADER_VERI

NFO, 156
IOCTL_HAL_GET_DEVICE_INFO, 150
IOCTL_HAL_GET_DEVICEID, 154
IOCTL_HAL_GET_OAL_VERINFO, 155
IOCTL_HAL_GET_RESET_INFO, 157
IOCTL_HAL_ITC_READ_PARM, 151
IOCTL_HAL_ITC_WRITE_SYSPARM, 153
IOCTL_PROCESSOR_INFORMATION, 

160
lpInBuf

IOCTL_GET_CPU_ID, 160
IOCTL_HAL_COLDBOOT, 157
IOCTL_HAL_GET_BOOT_DEVICE, 158
IOCTL_HAL_GET_BOOTLOADER_VERI

NFO, 156
IOCTL_HAL_GET_DEVICE_INFO, 150
IOCTL_HAL_GET_DEVICEID, 154
IOCTL_HAL_GET_OAL_VERINFO, 155
IOCTL_HAL_GET_RESET_INFO, 157
IOCTL_HAL_ITC_READ_PARM, 151
IOCTL_HAL_ITC_WRITE_SYSPARM, 153
IOCTL_HAL_REBOOT, 159
IOCTL_HAL_WARMBOOT, 156
IOCTL_PROCESSOR_INFORMATION, 

160
lpInBufSize

IOCTL_GET_CPU_ID, 160
IOCTL_HAL_COLDBOOT, 157
IOCTL_HAL_GET_BOOT_DEVICE, 158
IOCTL_HAL_GET_DEVICE_INFO, 150
IOCTL_HAL_GET_DEVICEID, 154
IOCTL_HAL_GET_OAL_VERINFO, 155
IOCTL_HAL_GET_RESET_INFO, 157
IOCTL_HAL_REBOOT, 159
IOCTL_HAL_WARMBOOT, 156

lpOutBuf
IOCTL_GET_CPU_ID, 160
IOCTL_HAL_COLDBOOT, 157
IOCTL_HAL_GET_BOOT_DEVICE, 158
IOCTL_HAL_GET_BOOTLOADER_VERI

NFO, 156
IOCTL_HAL_GET_DEVICE_INFO, 150
IOCTL_HAL_GET_DEVICEID, 154
IOCTL_HAL_GET_OAL_VERINFO, 155
IOCTL_HAL_GET_RESET_INFO, 157
IOCTL_HAL_ITC_READ_PARM, 151
IOCTL_HAL_ITC_WRITE_SYSPARM, 153
IOCTL_HAL_REBOOT, 159
IOCTL_HAL_WARMBOOT, 156

IOCTL_PROCESSOR_INFORMATION, 
160

LPT9 printer device, 113

M
Managing email messages and folders

via Inbox, 54
ManifestName

FTP Server, 144
Memory and storage

specifications, 17
Menu applet

Windows Mobile settings, 31
Messages

sending to
contacts, 48

via Inbox
downloading from server, 56

MIBs
ASN.1, 109
files, 109
object identifier, 109
OIDs, 109

Microphone, 2
Microprocessor

specifications, 17
Microsoft Developer Network Library See MSDN 
library
Microsoft Exchange email account, 62
Microsoft Passport account, 62
Microsoft Reader

adding bookmarks, 67
adding drawings, 67
annotations index, 67
attaching notes, 67
books

reading, 67
removing, 68

features, 67
highlighting text, 67
searching for text, 67
using the library, 66
Windows Mobile, 66

Microsoft security
allow fast roaming (CCKM), 213
detect rogue APs, 212
enable mixed cell, 213

Migrating from another computer, 83
Mixed cell

enable via Microsoft security, 213
Mobile Favorites

Pocket Internet Explorer, 69
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Modems
creating a connection

to an ISP, 101
MSDN library, 148
MSDN Windows CE documentation, 100
MSN Messenger

about, 62
accounts

Microsoft Exchange email, 62
Microsoft Passport, 62

contacts
managing, 64
sending messages, 65
working with, 64

using My Text, 30

N
nDeviceId

NLEDGetDeviceInfo, 182
NDIS_ENCRYPTION_1_ENABLED

EncryptionStatus(), 172
GetWepStatus(), 169

NDIS_ENCRYPTION_1_KEY_ABSENT
EncryptionStatus(), 172
GetWepStatus(), 169

NDIS_ENCRYPTION_2_ENABLED
EncryptionStatus(), 172
GetWepStatus(), 169

NDIS_ENCRYPTION_2_KEY_ABSENT
EncryptionStatus(), 172
GetWepStatus(), 169

NDIS_ENCRYPTION_3_ENABLED
EncryptionStatus(), 172
GetWepStatus(), 169

NDIS_ENCRYPTION_3_KEY_ABSENT
EncryptionStatus(), 172
GetWepStatus(), 169

NDIS_ENCRYPTION_DISABLED
EncryptionStatus(), 172
GetWepStatus(), 169

NDIS_ENCRYPTION_NOT_SUPPORTED
EncryptionStatus(), 172
GetWepStatus(), 169

NDIS_MIXED_CELL_OFF
SetMixedCellMode(), 175

NDIS_MIXED_CELL_ON
SetMixedCellMode(), 175

NDIS_NET_AUTO_UNKNOWN
GetNetworkMode(), 166
SetNetworkMode(), 174

NDIS_NET_MODE_ESS
GetNetworkMode(), 166
SetNetworkMode(), 174

NDIS_NET_MODE_IBSS

GetNetworkMode(), 166
SetNetworkMode(), 174

NDIS_NET_MODE_UNKNOWN
GetNetworkMode(), 166
SetNetworkMode(), 174

NDIS_NET_TYPE_DS
GetNetworkType(), 167

NDIS_NET_TYPE_FH
GetNetworkType(), 167

NDIS_NET_TYPE_OFDM_2_4G
GetNetworkMode(), 166
SetNetworkMode(), 174

NDIS_NET_TYPE_OFDM_5G
GetNetworkMode(), 166
SetNetworkMode(), 174

NDIS_NET_TYPE_UNDEFINED
GetNetworkType(), 167

NDIS_NETWORK_EAP_MODE_OFF
GetCCXStatus(), 170
SetCCXStatus(), 175

NDIS_NETWORK_EAP_MODE_ON
GetCCXStatus(), 170
SetCCXStatus(), 175

NDIS_POWER_LEVEL_1
GetTXPower(), 169

NDIS_POWER_LEVEL_15
GetTXPower(), 169

NDIS_POWER_LEVEL_30
GetTXPower(), 169

NDIS_POWER_LEVEL_5
GetTXPower(), 169

NDIS_POWER_LEVEL_63
GetTXPower(), 169

NDIS_POWER_LEVEL_UNKNOWN
GetTXPower(), 169

NDIS_RADIO_ASSOCIATED
GetAssocationStatus(), 163

NDIS_RADIO_AUTH_MODE_AUTO
GetAuthenticationMode(), 164
SetAuthenticationMode(), 173

NDIS_RADIO_AUTH_MODE_ERROR
GetAuthenticationMode(), 164
SetAuthenticationMode(), 173

NDIS_RADIO_AUTH_MODE_OPEN
GetAuthenticationMode(), 164
SetAuthenticationMode(), 173

NDIS_RADIO_AUTH_MODE_SHARED
GetAuthenticationMode(), 164
SetAuthenticationMode(), 173

NDIS_RADIO_AUTH_MODE_WPA
GetAuthenticationMode(), 164
SetAuthenticationMode(), 173
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NDIS_RADIO_AUTH_MODE_WPA_NONE
GetAuthenticationMode(), 164
SetAuthenticationMode(), 173

NDIS_RADIO_AUTH_MODE_WPA_PSK
GetAuthenticationMode(), 164
SetAuthenticationMode(), 173

NDIS_RADIO_POWER_AUTO
GetPowerMode(), 168
SetPowerMode(), 174

NDIS_RADIO_POWER_MODE_CAM
GetPowerMode(), 168
SetPowerMode(), 174

NDIS_RADIO_POWER_MODE_FAST_PSP
GetPowerMode(), 168
SetPowerMode(), 174

NDIS_RADIO_POWER_MODE_PSP
GetPowerMode(), 168
SetPowerMode(), 174

NDIS_RADIO_POWER_UNKNOWN
GetPowerMode(), 168
SetPowerMode(), 174

NDIS_RADIO_SCANNING
GetAssociationStatus(), 163

NDIS_SUPP_LOGGING_OFF
EnableSuppLogging(), 180

NDIS_SUPP_LOGGING_ON
EnableSuppLogging(), 180

NDISUIO_PACKET_DRIVER
SwitchPacketDriver(), 180

NETWLAN.DLL, 162
Network adapters

no networking, 95
wireless 802.11, 94

Network Connection icon, 223, 224
Network EAP

EAP-FAST security method, 211
LEAP security method, 209
PEAP security method, 201
TLS security method, 203
TTLS security method, 206

Network type
802.11 radio module, 198

nInBufSize
IOCTL_HAL_GET_BOOTLOADER_VERI

NFO, 156
IOCTL_HAL_ITC_READ_PARM, 151
IOCTL_HAL_ITC_WRITE_SYSPARM, 153
IOCTL_PROCESSOR_INFORMATION, 

160
nInfoId

NLEDGetDeviceInfo, 181
NLED driver

vibrator, 181

NLED.H, 181, 182
NLEDGetDeviceInfo, 181
NLEDSetDevice, 182

NLED_COUNT_INFO
NLEDGetDeviceInfo, 181

NLED_SETTINGS_INFO_ID
NLEDGetDeviceInfo, 181
NLEDSetDevice, 182

NLED_SUPPORTS_INFO_ID
NLEDGetDeviceInfo, 181

NLEDGetDeviceInfo, 181
NLEDSetDevice, 182
Notes

drawing on the screen, 28
creating a drawing, 28

recording a message, 29
Start menu icon, 22
synchronizing notes, 52
writing on the screen, 26

alternate writing, 27
converting writing to text, 27
tips for good recognition, 28

nOutBufSize
IOCTL_GET_CPU_ID, 160
IOCTL_HAL_COLDBOOT, 157
IOCTL_HAL_GET_BOOT_DEVICE, 158
IOCTL_HAL_GET_BOOTLOADER_VERI

NFO, 156
IOCTL_HAL_GET_DEVICE_INFO, 150
IOCTL_HAL_GET_DEVICEID, 154
IOCTL_HAL_GET_OAL_VERINFO, 155
IOCTL_HAL_GET_RESET_INFO, 157
IOCTL_HAL_ITC_READ_PARM, 151
IOCTL_HAL_ITC_WRITE_SYSPARM, 153
IOCTL_HAL_REBOOT, 159
IOCTL_HAL_WARMBOOT, 156
IOCTL_PROCESSOR_INFORMATION, 

160
NPCP printing, 112, 113

closing driver, 114
COM1 parameters, 113
communications, 115
driver I/O controls, 114
installation, 113
LPT9, 113
opening driver, 113
reading from driver, 114
removal, 113
sample code, 116
writing to driver, 114

NPCPPORT.DLL, 112

O
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Object Store
packaging an application, 74

Object store
IOCTL_HAL_COLDBOOT, 157
IOCTL_HAL_REBOOT, 159
IOCTL_HAL_WARMBOOT, 156

OEMIOCTL.H
IOCTL_GET_CPU_ID, 160
IOCTL_HAL_COLDBOOT, 157
IOCTL_HAL_GET_BOOT_DEVICE, 158
IOCTL_HAL_GET_BOOTLOADER_VERI

NFO, 155
IOCTL_HAL_GET_OAL_VERINFO, 155
IOCTL_HAL_GET_RESET_INFO, 157
IOCTL_HAL_ITC_READ_PARM, 151
IOCTL_HAL_ITC_WRITE_SYSPARM, 153
IOCTL_HAL_REBOOT, 159
IOCTL_HAL_WARMBOOT, 156

Oldstyle device ID, 154
ONeil printing

installing driver, 117
ONEIL.DLL, 117
Opening drivers

DTR, 117
NPCP, 113

Operating system
specifications, 17

Operating temperature, 16
OSVERSIONINFO.dwBuildNumber, 128
OSVERSIONINFO.dwVersionMajor, 128
OSVERSIONINFO.dwVersionMinor, 128
Owner Information applet

Windows Mobile settings, 31

P
Packaging an application

Flash File Store, 74
Object Store, 74
Persistent Storage Manager, 74
Secure Digital storage cards, 74

Page format printing, 112
Password applet

Windows Mobile settings, 31
Patent information, vii
PauseAtStartup

FTP Server, 144
PB20 printers

DTR driver, 117
printer support, 111

PB40 printers
DTR driver, 117
printer support, 111

PB42 configuration, 119

PB42 printers
DTR driver, 117
printer support, 111

PEAP
802.11 radio module

network EAP, 201
WPA encryption, 200

profile security information, 200
WEP encryption, 200

Phone application
CDMA radios

adding contact to speed dial, 49
Physical dimensions

specifications, 17
Physical specifications, 16
pInput

NLEDSetDevice, 182
PKFUNCS.H

IOCTL_HAL_GET_DEVICEID, 154
IOCTL_PROCESSOR_INFORMATION, 

159
Planes, keypad, 183
Pocket Excel

about, 60
creating a workbook, 61

Pocket Internet Explorer
about, 68
AvantGo channels, 70
browsing the Internet, 71
favorite links, 68
getting connected, 100
mobile favorites, 69
Mobile Favorites folder, 68
software build, 12
Start menu icon, 22
viewing mobile favorites and channels, 70

Pocket Outlook, 35
Pocket PC

IOCTL_HAL_GET_BOOTLOADER_VERI
NFO, 155

IOCTL_HAL_GET_OAL_VERINFO, 155
Pocket Word

about, 57
creating a document, 57
drawing mode, 60
synchronizing, 60
typing mode, 58
writing mode, 59

POP3
Folder behavior connected to email server, 55

pOutput
NLEDGetDeviceInfo, 181
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Power applet
battery status, 3
RAM maintenance, 4
Windows Mobile settings, 31

Printer support, 112
NPCP printer driver, 112
ONeil printer driver, 117

Printers, 119
PRISMNDS.DLL, 162
problems, finding and solving, 225
Processor information

IOCTL_PROCESSOR_INFORMATION, 
159

ProcessorType
CEDevice, 127

Profile label
802.11 radio module, 198

Profiles
802.11 radio module, 197

advanced settings, 212
basic information, 198
security information, 198

editing, 197
Programs, adding or removing

Windows Mobile, 31
Provider

Version, 126
PSM

determining build version, 10
packaging an application, 74

pull-tab, on an SD card, 13

Q
Query Information functions, 163

R
RadioConnect(), 162
RadioDisassociate(), 163
RadioDisconnect(), 163
Radios

card support, 15
Reader commands, 215

configuration change, 215
date and time settings, 216

ReadFile()
NPCP printing, 112

Reading distances
EV10, 124

Reading from drivers
NPCP, 114

Reboot methods
IOCTL_HAL_COLDBOOT, 182
IOCTL_HAL_REBOOT, 182
IOCTL_HAL_WARMBOOT, 182

REBOOTME.BIN, 148
Recharging time, 17
Record button

recording a message, 29
Recording

via Notes, 29
via Pocket Word, 59

Recovery CD
AutoCab method, 83
RegFlushKey() API, 141

Recurrence pattern
Calendar, 37

REGFLUSH.CAB, 77
RegFlushKey(), 141
RegisterDevice(), 113

DTR printing, 117
Registry

confirm the new regisry file, 79
delete the old registry save, 78, 79
FTP Server parameters, 143
keypad remapping, 184
replicating settings, 77
save location

IOCTL_HAL_ITC_WRITE_SYSPARM, 
153

update other computers, 79
Registry Save applet, 193
Registry settings

AutoCfg, 100
AutoFTP, 149
AutoInterval, 100
AutoIP/DHCP, 99
DhcpMaxRetry, 100
DhcpRetryDialogue, 100
keypad driver, 184
keypad planes

alpha, 184
orange, 184
unshifted, 184

RegOpenKeyEx(), 184
RegQueryValueEx(), 184
RegSetValueEx(), 184
Regulatory approvals

specifications, 17
RemoveWep(), 176
removing

battery, 15
SD card, 14

Removing drivers
DTR, 117
NPCP, 113

Removing programs
Windows Mobile, 31
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RenewDHCP(), 179
Replicating registry settings, 77
Reset button, 11
ResetRadioToSystemSave(), 180
Resource kits

Bluetooth, 86
data collection, 7, 108, 122, 192
printing, 112
smartsystems, 82
URL, 12

RFC 959, 147
Roaming

Microsoft security, 213
Root

FTP Server, 144
RPM.EXE, 130
RPMCE212.INI, 130

S
Sample code

NPCP printing, 116
SanDisk SD cards, 13
Scan codes, 185
Scanner

beeper volume
turning it off, 7
turning it on, 6

specifications, 17
unit configuration parameters

automatic shutoff, 214
backlight timeout, 214
date/time, 214
key clicks, 214
volume, 214

utilities configuration
button wakeup mask, 194

scanner
cleaning the window, 226
window, illustrated, 226

screen
cleaning, 226

SD card
accessing files, 14
attaching a pull-tab, 13
inserting, 13
removing, 14

Secure Digital cards
installing applications, 76
packaging an application, 74
specifications, 16

Set information functions, 171
SetAuthenticationMode(), 173
SetCCXStatus(), 175
SetChannel(), 173

SetMixedCellMode(), 175
SetNetworkMode(), 174
SetPowerMode(), 174
SetSSID(), 175
Setting date and time, 216
SETUP.DLL, 129, 136

DllMain, 136
installation functions, 136

SHFullScreen(), 141
shortcut_list_section

CEShortcuts
shortcut_filename, 133
shortcut_type_flag, 133
target_file_path, 133

Signature
Version, 126

SIM cards
protection hardware, 153
protection software, 153
software installed, 153

Simple Network Management Protocol See SNMP
SmartSystems, 7, 77, 108
SMS

Folder behavior connected to email server, 54
SNMP, 108
Software versions, 12
SourceDiskFiles

filename, 130
SourceDiskNames

CESignature, 129
disk_ordinal, 129

SourceDisksNames.MIPS, 130
SourceDisksNames.SH3, 130
Speaker, 2
Specifications, 16

battery, 17
display, 16
environmental, 16
expansion slots, 16
integrated scanner options, 17
integrated wireless, 17
keypad options, 17
memory and storage, 17
microprocessor, 17
operating system, 17
physical dimensions, 17
regulatory approvals, 17
standard communications, 17

SSID (network name)
802.11 radio module, 198

Standard communications
specifications, 17
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Start Menu
adding programs, 33

via File Explorer, 33
StartScanList(), 178
StartSupplicant(), 178
Static IP

replicating registry settings, 77
StopSupplicant(), 178
Storage media, 13

specifications, 16
Storage temperature, 16
Stream device driver

NPCPPORT.DLL, 112
ONEIL.DLL, 117

string_key
Strings, 127

Strings
string_key, 127

SwitchPacketDriver(), 180
Symbologies

internal scanner supported symbologies, 124
scanning labels, 216

symbologies
disabled incorrectly, 225

Synchronizing
AvantGo channels, 70
Calendar, 36
contacts, 45
email messages, 54
favorite links, 68
mobile favorites, 69
notes, 52
Pocket Word, 60

System software updates, 80
SYSTEMINFO.dwProcessorType, 127

T
tab, on an SD card, 13
TAHOMA.TTF, 130
Tasks

Start menu icon, 22
TCP/IP, 93
TCP/IP client

DHCP server, 100
technical support

sending CN2 for repair, 225
Temperatures

battery, 17
troubleshooting, 222

specifications, 16
Text messages

Windows Mobile, 30
Time, setting, 216
TLS

802.11 profile
certificates, 207
WPA encryption, 203

802.11 radio module
network EAP, 203

profile security information
WEP encryption, 202
WPA encryption, 203

Today applet
Windows Mobile settings, 31

Today screen
Windows Mobile, 21

Tools CD
CAB files, 75
MIB files, 109
sample NPCP code, 116

touch screen
cleaning, 226
illustrated, 226

Troubleshooting
CAB Wizard, 140

troubleshooting
bar code symbologies, 225
lost network connection after suspend, 223
Network Connection icon, 223

TTLS
802.11 radio module

network EAP, 206
WPA encryption, 205

profile security information
WEP encryption, 204, 205

Typing mode
Pocket Word, 58

U
UDP

FTPDCE, 145
UDP broadcasts

IDNATarget parameter, 144
UDP Plus, 93
Unit

configuration parameters
automatic shutoff, 214
backlight timeout, 214
date/time, 214
key clicks, 214
volume, 214

Unit Manager
date/time, 214

Unshifted plane on keypad, 183
UnsupportedPlatforms

CEDevice, 127
Updating

bootloader, 75
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Updating the system software, 80
URLs

ActiveSync, 34
full screen display, 141
MIBs, 109
Microsoft Exchange email account, 62
Microsoft Passport account, 62
Microsoft support, 20
MSDN library, 148
MSDN Windows CE documentation, 100
Windows Mobile, 20
Windows Mobile support, 20

URODDSVC.EXE, 162
USB communications, 93
Utilities applet

app launch, 194
registry save, 193
wakeup mask, 194

UUID, 154

V
Version

CESignature, 126
Provider, 126
Signature, 126

VersionMax
CEDevice, 128

VersionMin
CEDevice, 128

Vibrator
programming, 181

Video files
Windows Media Player, 65

Viewing mobile favorites and channels
Pocket Internet Explorer, 70

Virtual wedge
bar code configuration

grid, 219
postamble, 219
preamble, 219

VN_CLASS_ASIC, 152
VN_CLASS_BOOTSTRAP, 152
VN_CLASS_KBD, 152
Volume

bar code configuration, 214, 216
configuration parameter, 214

W
Wakeup mask applet, 194
WAP pages, 68

connecting to an ISP, 101
Warm boot

IOCTL_HAL_REBOOT, 159
IOCTL_HAL_WARMBOOT, 156

Warm boot, performing, 11
WAV files, 59
Wavelink Avalanche, 76
WCESTART.INI, 130
Web browsers

FTP support, 147
Web pages, 68

connecting to an ISP, 101
WEP encryption

EAP-FAST security method, 210
LEAP security method, 208
PEAP security method, 200
profile security information, 199
TLS security method, 202
TTLS security method, 204, 205
zero configuration, 97

Windows CE documentation (MSDN), 100
Windows Media Player

Start menu icon, 22
Windows Mobile, 65

Windows Mobile
ActiveSync, 34
basic skills, 21
command bar, 22
getting connected, 100
MSN Messenger, 62
navigation bar, 22
notifications, 23
Pocket Excel, 60
Pocket Word, 57
popup menus, 23
programs, 21
support URLs, 20
Today screen, 21
where to find information, 20
Windows Media Player, 65
writing on the screen, 26

Wireless network, 94, 197
specifications, 17

Wireless TCP/IP installations
BlockSize parameter, 143

Workbook
creating via Pocket Excel, 61

WPA authentication
with pre-shared key

Zero Configuration, 98
WPA encryption

EAP-FAST security method, 210, 211
LEAP security method, 208
PEAP security method, 200
TLS security method, 203
TTLS security method, 205

WPport, 87
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WriteFile(), 112
DTR printing, 117, 118
NPCP printing, 112, 114

Writing mode
Pocket Word, 59

Writing on the screen
Pocket Word, 59

Writing on the screen See Notes, 26
Writing to drivers

DTR, 118

NPCP, 114

X
Xscale processor ID

IOCTL_GET_CPU_ID, 160

Z
Zero Configuration

enabling, 198
enabling WPA authentication, 98
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